summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/bfm/bfm-0.6.4-r1.ebuild')
-rw-r--r--x11-plugins/bfm/bfm-0.6.4-r1.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/x11-plugins/bfm/bfm-0.6.4-r1.ebuild b/x11-plugins/bfm/bfm-0.6.4-r1.ebuild
index 2cf6cf27a615..9bfacaf144e1 100644
--- a/x11-plugins/bfm/bfm-0.6.4-r1.ebuild
+++ b/x11-plugins/bfm/bfm-0.6.4-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/bfm/bfm-0.6.4-r1.ebuild,v 1.10 2012/05/05 05:12:01 jdhore Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/bfm/bfm-0.6.4-r1.ebuild,v 1.11 2014/04/07 19:34:25 ssuominen Exp $
+EAPI=5
inherit multilib toolchain-funcs
DESCRIPTION="a dockapp and gkrellm plug-in combining timecop's bubblemon and wmfishtime."
@@ -22,21 +21,20 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
gkrellm? ( >=app-admin/gkrellm-2 )"
-src_unpack() {
- unpack ${A}
- sed -e 's:CFLAGS =:CFLAGS +=:' -e 's:LDFLAGS =:LDFLAGS +=:' -e 's:strip:true:' \
+src_prepare() {
+ sed -i \
+ -e 's:CFLAGS =:CFLAGS +=:' \
+ -e 's:LDFLAGS =:LDFLAGS +=:' \
+ -e 's:strip:true:' \
-e 's:$(CFLAGS) -o $(BUBBLEFISHYMON):$(CFLAGS) $(SRCS) -o $(BUBBLEFISHYMON):' \
-e 's:$(LIBS) $(GTK2_LIBS) $(SRCS):$(LIBS) $(GTK2_LIBS):' \
-e 's:-o $(BUBBLEFISHYMON):$(GENTOO_LDFLAGS) -o $(BUBBLEFISHYMON):' \
- -i "${S}"/Makefile
+ Makefile || die
}
src_compile() {
- emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}" || die "emake failed."
-
- if use gkrellm; then
- emake gkrellm CC="$(tc-getCC)" || die "emake failed."
- fi
+ emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}"
+ use gkrellm && emake gkrellm CC="$(tc-getCC)"
}
src_install() {