summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/xcb-proto/ChangeLog8
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.7.1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-proto/xcb-proto/ChangeLog b/x11-proto/xcb-proto/ChangeLog
index 82e2369f0379..d3c838d280f9 100644
--- a/x11-proto/xcb-proto/ChangeLog
+++ b/x11-proto/xcb-proto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/xcb-proto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.73 2012/03/10 00:58:56 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.74 2012/03/23 17:28:05 chithanh Exp $
+
+*xcb-proto-1.7.1 (23 Mar 2012)
+
+ 23 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xcb-proto-1.7.1.ebuild:
+ Version bump.
10 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
xcb-proto-1.7-r1.ebuild:
diff --git a/x11-proto/xcb-proto/xcb-proto-1.7.1.ebuild b/x11-proto/xcb-proto/xcb-proto-1.7.1.ebuild
new file mode 100644
index 000000000000..2530802abef7
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.7.1.ebuild,v 1.1 2012/03/23 17:28:05 chithanh Exp $
+
+EAPI=4
+PYTHON_DEPEND="*"
+
+inherit python xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+src_prepare() {
+ python_clean_py-compile_files
+ xorg-2_src_prepare
+}
+
+pkg_postinst() {
+ python_mod_optimize xcbgen
+ ewarn "Please rebuild both libxcb and xcb-util if you are upgrading from version 1.6"
+}
+
+pkg_postrm() {
+ python_mod_cleanup xcbgen
+}