summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/rxvt-unicode/rxvt-unicode-7.7-r1.ebuild')
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-7.7-r1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-7.7-r1.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-7.7-r1.ebuild
new file mode 100644
index 000000000000..c77b277d622e
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-7.7-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-7.7-r1.ebuild,v 1.1 2006/03/31 19:44:01 exg Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="rxvt clone with XFT and Unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="truetype perl"
+
+# see bug #115992 for modular x deps
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrender
+ )
+ virtual/x11
+ )
+ dev-lang/perl
+ perl? ( sys-devel/libperl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/libtool
+ || (
+ (
+ x11-proto/xproto
+ x11-libs/libXt
+ )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ local tdir=/usr/share/terminfo
+ sed -i -e \
+ "s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+ sed -i -e \
+ "s:-g -O3:${CXXFLAGS}:" \
+ configure
+}
+
+src_compile() {
+ econf \
+ --enable-everything \
+ $(use_enable truetype xft) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ --disable-iso14755 \
+ || die
+
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ ${S}/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}
+