summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ross <aross@gentoo.org>2006-10-01 05:16:17 +0000
committerAndrew Ross <aross@gentoo.org>2006-10-01 05:16:17 +0000
commitc705d16e7ed061539f01c96d530f9c0a59524bbf (patch)
tree9baa5db3eab01da915f2dda3c5630718efb91f48
parentSet XEN_TARGET_ARCH to fix an amd64 compile error (Gentoo bug #143999). (diff)
downloadaross-c705d16e7ed061539f01c96d530f9c0a59524bbf.tar.gz
aross-c705d16e7ed061539f01c96d530f9c0a59524bbf.tar.bz2
aross-c705d16e7ed061539f01c96d530f9c0a59524bbf.zip
Allow xen-tools to be compiled with gcc-4.1 (bug #147876).
svn path=/; revision=13
-rw-r--r--app-emulation/xen-tools/Manifest8
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild11
2 files changed, 8 insertions, 11 deletions
diff --git a/app-emulation/xen-tools/Manifest b/app-emulation/xen-tools/Manifest
index 4f2e78c..71e2b9e 100644
--- a/app-emulation/xen-tools/Manifest
+++ b/app-emulation/xen-tools/Manifest
@@ -47,10 +47,10 @@ EBUILD xen-tools-3.0.2-r3.ebuild 5530 RMD160 fe932ebe8722970f5a433a0619552c6ec2f
MD5 11588a83ffd3177430efeca5cc668ba3 xen-tools-3.0.2-r3.ebuild 5530
RMD160 fe932ebe8722970f5a433a0619552c6ec2f93eaf xen-tools-3.0.2-r3.ebuild 5530
SHA256 cff3399ef7a791cafcf2053c00124ab56772b730ac8aa32a088ced857b011c1e xen-tools-3.0.2-r3.ebuild 5530
-EBUILD xen-tools-3.0.2-r4.ebuild 5217 RMD160 f76508277a3dff048063175d75dec7e05b062c3d SHA1 2d1dc4e13b8c9500136227d9e4c96b6777fc66cd SHA256 ccfb5d91670d020d66d956cae36a644800980f22ac9b030d59b86bcfe42363db
-MD5 6003c5e2f42466468dcdd4bbac5fde2d xen-tools-3.0.2-r4.ebuild 5217
-RMD160 f76508277a3dff048063175d75dec7e05b062c3d xen-tools-3.0.2-r4.ebuild 5217
-SHA256 ccfb5d91670d020d66d956cae36a644800980f22ac9b030d59b86bcfe42363db xen-tools-3.0.2-r4.ebuild 5217
+EBUILD xen-tools-3.0.2-r4.ebuild 5129 RMD160 f25fa0c8cbdf50495da03133aa4d82ed296df7b5 SHA1 8907b07d2e4e93b67bdc6ea361ccf3979aa031c1 SHA256 497c3dd81d58863cac278e071bb87c9121720b891cac78f5311edc386e609692
+MD5 7a2942ccbb78a79f6e0296737c8ef6c9 xen-tools-3.0.2-r4.ebuild 5129
+RMD160 f25fa0c8cbdf50495da03133aa4d82ed296df7b5 xen-tools-3.0.2-r4.ebuild 5129
+SHA256 497c3dd81d58863cac278e071bb87c9121720b891cac78f5311edc386e609692 xen-tools-3.0.2-r4.ebuild 5129
MD5 6618adc624bc8ab64af0f4555c33529a files/digest-xen-tools-3.0.2-r3 235
RMD160 ad3a1d2a82c40b0bca653431c2d7964809580e5e files/digest-xen-tools-3.0.2-r3 235
SHA256 274536fc8a3cb10fda114e533062b0dbddcda4ae15f52033a39b85785b221794 files/digest-xen-tools-3.0.2-r3 235
diff --git a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
index f6fbde1..ac382c5 100644
--- a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
@@ -80,13 +80,6 @@ src_unpack() {
-e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
-i {} \;
fi
- # for some reason the xen gcc checks don't work on gentoo-hardened
- if use hardened; then
- HARDFLAGS="-nopie -fno-stack-protector -fno-stack-protector-all"
- sed -e "s/CFLAGS :=/CFLAGS := ${HARDFLAGS}/" \
- -i "${S}"/tools/firmware/hvmloader/Makefile \
- "${S}"/tools/firmware/vmxassist/Makefile
- fi
# Disable the 32bit-only vmxassist, if we are not on x86 and we don't support the x86 ABI
if ! use x86 && ! has x86 $(get_all_abis); then
@@ -100,6 +93,10 @@ src_unpack() {
# Allow --as-needed LDFLAGS
epatch "${FILESDIR}/${P}"--as-needed.patch
+ # Allow building with gcc-4.1 (bug #147876)
+ sed -i 's/^CFLAGS += $(call test-gcc-flag,$(CC),-nopie)$/&\nCFLAGS += $(call test-gcc-flag,$(CC),-fnopie)/' \
+ "${S}"/tools/firmware/{hvmloader,vmxassist}/Makefile
+
# Allow building with python-2.5 (bug #149138)
# Backported from upstream - should be in 3.0.3
sed -i 's/\.2|^2\.3|^2\.4/.[2345]/' "${S}"/tools/check/check_python