summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCHTEKK <CHTEKK@localhost>2008-10-07 15:23:29 +0000
committerCHTEKK <CHTEKK@localhost>2008-10-07 15:23:29 +0000
commitd44d1adee5d84cd3a1c76445aeb2bf33cd0d5508 (patch)
tree06ae629f9325b1b7e728204541f282164ddebb9a
parentFix printer installation. (diff)
downloadchtekk-d44d1adee5d84cd3a1c76445aeb2bf33cd0d5508.tar.gz
chtekk-d44d1adee5d84cd3a1c76445aeb2bf33cd0d5508.tar.bz2
chtekk-d44d1adee5d84cd3a1c76445aeb2bf33cd0d5508.zip
Add ebuilds for EiffelStudio and the Traffic library.
svn path=/; revision=99
-rw-r--r--apps/dev-eiffel/eiffelstudio/eiffelstudio-6.2.73753.ebuild59
-rw-r--r--apps/dev-eiffel/traffic/traffic-3.3.1079.ebuild31
-rw-r--r--apps/profiles/categories1
3 files changed, 91 insertions, 0 deletions
diff --git a/apps/dev-eiffel/eiffelstudio/eiffelstudio-6.2.73753.ebuild b/apps/dev-eiffel/eiffelstudio/eiffelstudio-6.2.73753.ebuild
new file mode 100644
index 0000000..8e47684
--- /dev/null
+++ b/apps/dev-eiffel/eiffelstudio/eiffelstudio-6.2.73753.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+KEYWORDS="-* ~amd64 ~x86"
+
+MAIN_PV="${PV%.*}"
+MAIN_PV="${MAIN_PV/./}"
+SUB_PV="${PV##*.}"
+
+DESCRIPTION="EiffelStudio IDE."
+HOMEPAGE="http://${PN}.origo.ethz.ch/"
+SRC_URI="x86? ( http://download.origo.ethz.ch/${PN}/637/Eiffel${MAIN_PV}_gpl_${SUB_PV}-linux-x86.tar.bz2 )
+ amd64? ( http://download.origo.ethz.ch/${PN}/637/Eiffel${MAIN_PV}_gpl_${SUB_PV}-linux-x86-64.tar.bz2 )"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="precompile"
+
+DEPEND="sys-devel/gcc
+ dev-util/bsdiff
+ >=x11-libs/gtk+-2.6.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Eiffel${MAIN_PV}"
+
+src_compile() {
+ if use amd64 ; then
+ ISE_PLATFORM="linux-x86-64"
+ else
+ ISE_PLATFORM="linux-x86"
+ fi
+
+ if use precompile ; then
+ ISE_EIFFEL="${S}" ISE_PLATFORM=${ISE_PLATFORM} studio/spec/${ISE_PLATFORM}/bin/ec -precompile -config precomp/spec/${ISE_PLATFORM}/base.ecf -c_compile -clean || die "precompile failed"
+ ISE_EIFFEL="${S}" ISE_PLATFORM=${ISE_PLATFORM} studio/spec/${ISE_PLATFORM}/bin/ec -precompile -config precomp/spec/${ISE_PLATFORM}/base-mt.ecf -c_compile -clean || die "precompile failed"
+ ISE_EIFFEL="${S}" ISE_PLATFORM=${ISE_PLATFORM} studio/spec/${ISE_PLATFORM}/bin/ec -precompile -config precomp/spec/${ISE_PLATFORM}/vision2.ecf -c_compile -clean || die "precompile failed"
+ ISE_EIFFEL="${S}" ISE_PLATFORM=${ISE_PLATFORM} studio/spec/${ISE_PLATFORM}/bin/ec -precompile -config precomp/spec/${ISE_PLATFORM}/vision2-mt.ecf -c_compile -clean || die "precompile failed"
+ fi
+}
+
+src_install() {
+ echo "ISE_EIFFEL=/opt/Eiffel${MAIN_PV}" > "${T}/52${PN}"
+ ISE_EIFFEL=/opt/Eiffel${MAIN_PV}
+
+ if use amd64 ; then
+ echo "ISE_PLATFORM=linux-x86-64" >> "${T}/52${PN}"
+ ISE_PLATFORM="linux-x86-64"
+ else
+ echo "ISE_PLATFORM=linux-x86" >> "${T}/52${PN}"
+ ISE_PLATFORM="linux-x86"
+ fi
+
+ echo "PATH=${ISE_EIFFEL}/studio/spec/${ISE_PLATFORM}/bin" >> "${T}/52${PN}"
+
+ doenvd "${T}/52${PN}"
+
+ dodir /opt/Eiffel${MAIN_PV}
+ mv -f * "${D}"/opt/Eiffel${MAIN_PV}
+}
diff --git a/apps/dev-eiffel/traffic/traffic-3.3.1079.ebuild b/apps/dev-eiffel/traffic/traffic-3.3.1079.ebuild
new file mode 100644
index 0000000..b644637
--- /dev/null
+++ b/apps/dev-eiffel/traffic/traffic-3.3.1079.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+KEYWORDS="~amd64 ~x86"
+
+MAIN_PV="${PV%.*}"
+SUB_PV="${PV##*.}"
+
+DESCRIPTION="Traffic library."
+HOMEPAGE="http://${PN}.origo.ethz.ch/"
+SRC_URI="http://download.origo.ethz.ch/${PN}/792/traffic_ev_${MAIN_PV}_${SUB_PV}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-eiffel/eiffelstudio"
+
+S="${WORKDIR}/traffic_ev_${SUB_PV}"
+
+src_compile() {
+ echo "Nothing to compile."
+}
+
+src_install() {
+ dodir /usr/share/Eiffel/Traffic_${MAIN_PV}_${SUB_PV}
+ mv -f * "${D}"/usr/share/Eiffel/Traffic_${MAIN_PV}_${SUB_PV}
+ chgrp -R users "${D}"/usr/share/Eiffel/Traffic_${MAIN_PV}_${SUB_PV}
+ chmod -R g+w "${D}"/usr/share/Eiffel/Traffic_${MAIN_PV}_${SUB_PV}/example
+}
diff --git a/apps/profiles/categories b/apps/profiles/categories
new file mode 100644
index 0000000..312ffbd
--- /dev/null
+++ b/apps/profiles/categories
@@ -0,0 +1 @@
+dev-eiffel