aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-03 01:38:08 -0700
committerDonnie Berkholz <donnie@comet.(none)>2006-09-03 01:38:08 -0700
commit75b7e4df2cefa10985ae934eddd4151c72f62028 (patch)
treecf14f2331ff93460f45318b793332216a213a406 /app-admin
parentAdd bind-dns-keygen from RH bind rpm for system-config-bind (diff)
downloaddberkholz-75b7e4df2cefa10985ae934eddd4151c72f62028.tar.gz
dberkholz-75b7e4df2cefa10985ae934eddd4151c72f62028.tar.bz2
dberkholz-75b7e4df2cefa10985ae934eddd4151c72f62028.zip
Add system-config-bind. Not working yet locally.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/system-config-bind/Manifest8
-rw-r--r--app-admin/system-config-bind/files/digest-system-config-bind-4.0.03
-rw-r--r--app-admin/system-config-bind/system-config-bind-4.0.0.ebuild37
3 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/system-config-bind/Manifest b/app-admin/system-config-bind/Manifest
new file mode 100644
index 0000000..19b68fe
--- /dev/null
+++ b/app-admin/system-config-bind/Manifest
@@ -0,0 +1,8 @@
+DIST system-config-bind-4.0.0-44.fc6.src.rpm 9832659 RMD160 bd109d46674e2a7b41fdbfd6509677482a1da8b1 SHA1 e19997d710dc31b64c56e3fe4c4e8ad510c97ff3 SHA256 9641464e749c707b65e3c7a0dff6daa2d76fea2018c2e462a6ee31d08a8b9410
+EBUILD system-config-bind-4.0.0.ebuild 930 RMD160 98885addac081c6c8b068319884eaf5fe1096a42 SHA1 ae3c18a0a8d5ba4e0d07374caa9d0932e93cfe07 SHA256 e3821086662f4d42290cca691a093d425eb6174170559ade55f65abcc33f5709
+MD5 bb21355000b52fdda8d6099e9d2abee5 system-config-bind-4.0.0.ebuild 930
+RMD160 98885addac081c6c8b068319884eaf5fe1096a42 system-config-bind-4.0.0.ebuild 930
+SHA256 e3821086662f4d42290cca691a093d425eb6174170559ade55f65abcc33f5709 system-config-bind-4.0.0.ebuild 930
+MD5 c9d0f20697102936b5830893ec4e1393 files/digest-system-config-bind-4.0.0 301
+RMD160 29eb75ad04e3c27b9986ea0c4ccb3e64fdce876d files/digest-system-config-bind-4.0.0 301
+SHA256 c4b6cfdeb418c25f0eb9140e6d195b35c2310cf0eab6efb5a75c7126aa06774c files/digest-system-config-bind-4.0.0 301
diff --git a/app-admin/system-config-bind/files/digest-system-config-bind-4.0.0 b/app-admin/system-config-bind/files/digest-system-config-bind-4.0.0
new file mode 100644
index 0000000..5529936
--- /dev/null
+++ b/app-admin/system-config-bind/files/digest-system-config-bind-4.0.0
@@ -0,0 +1,3 @@
+MD5 43cc8c396e79a2c2a7a000efb32e621c system-config-bind-4.0.0-44.fc6.src.rpm 9832659
+RMD160 bd109d46674e2a7b41fdbfd6509677482a1da8b1 system-config-bind-4.0.0-44.fc6.src.rpm 9832659
+SHA256 9641464e749c707b65e3c7a0dff6daa2d76fea2018c2e462a6ee31d08a8b9410 system-config-bind-4.0.0-44.fc6.src.rpm 9832659
diff --git a/app-admin/system-config-bind/system-config-bind-4.0.0.ebuild b/app-admin/system-config-bind/system-config-bind-4.0.0.ebuild
new file mode 100644
index 0000000..f643326
--- /dev/null
+++ b/app-admin/system-config-bind/system-config-bind-4.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="6"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="44"
+
+DESCRIPTION="Tools for certain user account management tasks"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="=dev-python/pygtk-2*
+ dev-lang/python
+ =dev-python/gnome-python-2*
+ net-dns/bind
+ net-dns/bind-tools
+ net-dns/bind-dns-keygen
+ x11-themes/hicolor-icon-theme"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+src_install() {
+ emake ROOT="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}