aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@lotus.(none)>2008-11-13 12:59:05 -0800
committerDonnie Berkholz <donnie@lotus.(none)>2008-11-13 12:59:05 -0800
commit69e4541263596a7ddd98e82b8a98d0fdd1c5e19d (patch)
treecebd6596069be214ece9f36255b226a37899dd09 /sci-chemistry
parentmosflm: bump to 7.0.4; parallel build is broken. (diff)
downloaddberkholz-69e4541263596a7ddd98e82b8a98d0fdd1c5e19d.tar.gz
dberkholz-69e4541263596a7ddd98e82b8a98d0fdd1c5e19d.tar.bz2
dberkholz-69e4541263596a7ddd98e82b8a98d0fdd1c5e19d.zip
imosflm: bump to 1.0.0. Still bundled libs.
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/imosflm/Manifest4
-rw-r--r--sci-chemistry/imosflm/imosflm-1.0.0.ebuild (renamed from sci-chemistry/imosflm/imosflm-0.6.1.ebuild)37
2 files changed, 14 insertions, 27 deletions
diff --git a/sci-chemistry/imosflm/Manifest b/sci-chemistry/imosflm/Manifest
index afc480a..f20ca2c 100644
--- a/sci-chemistry/imosflm/Manifest
+++ b/sci-chemistry/imosflm/Manifest
@@ -1,2 +1,2 @@
-DIST imosflm-0.6.1.tar.gz 854216 RMD160 8420e6dd0f99766fde8903b646902a78d4b89b3f SHA1 3ec6585994db659a7032b39798685777d6190bd3 SHA256 12a3ab3f7d5d6b89f5a0c7261a3dee6fb5165853d6c279d03c230f746113f102
-EBUILD imosflm-0.6.1.ebuild 1231 RMD160 97e46417a2b473ce19fd151b8f83302e96fe0bee SHA1 ced5ab4aa7f75ad7806d965c43d21fc1bf993874 SHA256 b9b8ae29f06b7a375707cfde0dc70d8302770d2473cab46255d033083056181c
+DIST imosflm-1.0.0.tar.gz 1061762 RMD160 5e943c1f9dc48aad55eb6f7bb7f6dd7b09088509 SHA1 6ed3c6d7f05fcfcc0e254ced66133fc19b34394e SHA256 142eeb1771c477fb5ec121edd36f6acc95791fcb402d5233c315b1bf141a4dd4
+EBUILD imosflm-1.0.0.ebuild 1124 RMD160 c8e0c330eafbe1f3cbe1ab52b818bc09dac5caea SHA1 4ee732b4c1d578786ef45bfe04de1e9d3d085513 SHA256 e5ae7936d95bf76cafb506a64db25b4c08253b2871617d1e0a34dd3670b12e01
diff --git a/sci-chemistry/imosflm/imosflm-0.6.1.ebuild b/sci-chemistry/imosflm/imosflm-1.0.0.ebuild
index 2cd3ec5..760cf48 100644
--- a/sci-chemistry/imosflm/imosflm-0.6.1.ebuild
+++ b/sci-chemistry/imosflm/imosflm-1.0.0.ebuild
@@ -2,52 +2,39 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit toolchain-funcs eutils
+inherit eutils
DESCRIPTION="A new GUI for the Mosflm crystallographic data processing tool"
HOMEPAGE="http://www.mrc-lmb.cam.ac.uk/harry/${PN}/"
-SRC_URI="${P}.tar.gz"
+SRC_URI="${HOMEPAGE}/downloads/${P}.tar.gz"
LICENSE="ccp4"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-RESTRICT="fetch"
RDEPEND=">=dev-tcltk/itcl-3.3
>=dev-tcltk/itk-3.3
>=dev-tcltk/iwidgets-4
>=dev-tcltk/tkimg-1.3
>=dev-tcltk/tdom-0.8
>=dev-tcltk/tktreectrl-2.1
- >=sci-chemistry/mosflm-7.0.3
+ >=sci-chemistry/mosflm-7.0.4
=dev-lang/tcl-8.4*"
DEPEND="=dev-lang/tcl-8.4*"
-S="${WORKDIR}/${PN}"
-
-pkg_nofetch() {
- elog "Download ${PN}.tar.gz from ${HOMEPAGE}"
- elog "Rename it to ${SRC_URI} and place it in /usr/portage/distfiles/"
-}
-
-src_compile(){
- cd c
- $(tc-getCC) \
- ${CFLAGS} \
- ${LDFLAGS} \
- -fPIC -shared \
- -DUSE_TCL_STUBS -DTK_USE_STUBS \
- tkImageLoadDLL.c tkImageLoad.c \
- -o tkImageLoad.so \
- -ltclstub \
- || die
-}
+src_compile(){ :; }
src_install(){
insinto /usr/$(get_libdir)/${PN}
doins -r "${S}"/{lib,src,bitmaps}
fperms 775 /usr/$(get_libdir)/${PN}/src/imosflm
- insinto /usr/$(get_libdir)/${PN}/lib/
- doins "${S}"/c/tkImageLoad.so
make_wrapper imosflm /usr/$(get_libdir)/${PN}/src/imosflm
}
+
+pkg_postinst() {
+ einfo "Please make ebuilds for the bundled libraries:"
+ einfo " Tablelist: http://www.nemethi.de/"
+ einfo " Combobox: http://www1.clearlight.com/~oakley/tcl/combobox/index.html"
+ einfo " Anigif: http://cardtable.sourceforge.net/tcltk/"
+ einfo " filelist-bindings: (Comes with tktreectrl)"
+}