summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/boot0/files/boot0-7.0-gentoo.patch')
-rw-r--r--sys-freebsd/boot0/files/boot0-7.0-gentoo.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/sys-freebsd/boot0/files/boot0-7.0-gentoo.patch b/sys-freebsd/boot0/files/boot0-7.0-gentoo.patch
new file mode 100644
index 0000000..6d13a7e
--- /dev/null
+++ b/sys-freebsd/boot0/files/boot0-7.0-gentoo.patch
@@ -0,0 +1,77 @@
+Index: sys/boot/efi/libefi/Makefile
+===================================================================
+--- sys/boot/efi/libefi/Makefile.orig
++++ sys/boot/efi/libefi/Makefile
+@@ -14,7 +14,7 @@ SRCS+= efifpswa.c pal.S
+
+ CFLAGS+= -I${.CURDIR}/../include
+ CFLAGS+= -I${.CURDIR}/../include/${MACHINE_ARCH:S/amd64/i386/}
+-CFLAGS+= -I${.CURDIR}/../../../../lib/libstand
++CFLAGS+= -I/usr/include/libstand
+
+ # Pick up the bootstrap header for some interface items
+ CFLAGS+= -I${.CURDIR}/../../common
+Index: sys/boot/i386/boot2/Makefile
+===================================================================
+--- sys/boot/i386/boot2/Makefile.orig
++++ sys/boot/i386/boot2/Makefile
+@@ -24,7 +24,7 @@ CFLAGS= -Os \
+ -fno-guess-branch-probability \
+ -fomit-frame-pointer \
+ -fno-unit-at-a-time \
+- -mno-align-long-strings \
++ -march=i386 \
+ -mrtd \
+ -mno-mmx -mno-3dnow -mno-sse -mno-sse2 \
+ -D${BOOT2_UFS} \
+Index: sys/boot/i386/libi386/Makefile
+===================================================================
+--- sys/boot/i386/libi386/Makefile.orig
++++ sys/boot/i386/libi386/Makefile
+@@ -28,7 +28,7 @@ CFLAGS+= -I${.CURDIR}/../../common -I${.
+ -I${.CURDIR}/../../../contrib/dev/acpica \
+ -I${.CURDIR}/../../.. -I.
+ # the location of libstand
+-CFLAGS+= -I${.CURDIR}/../../../../lib/libstand/
++CFLAGS+= -I/usr/include/libstand/
+
+ .if ${MACHINE_ARCH} == "amd64"
+ CLEANFILES+= machine
+Index: sys/boot/ofw/libofw/Makefile
+===================================================================
+--- sys/boot/ofw/libofw/Makefile.orig
++++ sys/boot/ofw/libofw/Makefile
+@@ -7,7 +7,7 @@ SRCS= devicename.c elf_freebsd.c ofw_con
+ ofw_memory.c ofw_module.c ofw_net.c ofw_reboot.c \
+ ofw_time.c openfirm.c
+
+-CFLAGS+= -I${.CURDIR}/../../../../lib/libstand/
++CFLAGS+= -I/usr/include/libstand/
+
+ # Pick up the bootstrap header for some interface items
+ CFLAGS+= -I${.CURDIR}/../../common -I${.CURDIR}/../../.. -I.
+Index: sys/boot/pc98/libpc98/Makefile
+===================================================================
+--- sys/boot/pc98/libpc98/Makefile.orig
++++ sys/boot/pc98/libpc98/Makefile
+@@ -28,6 +28,6 @@ CFLAGS+= -I${.CURDIR}/../../common -I${.
+ -I${.CURDIR}/../../i386/libi386 \
+ -I${.CURDIR}/../../.. -I.
+ # the location of libstand
+-CFLAGS+= -I${.CURDIR}/../../../../lib/libstand/
++CFLAGS+= -I/usr/include/libstand/
+
+ .include <bsd.lib.mk>
+Index: sys/boot/sparc64/loader/Makefile
+===================================================================
+--- sys/boot/sparc64/loader/Makefile.orig
++++ sys/boot/sparc64/loader/Makefile
+@@ -63,7 +63,7 @@ LIBOFW= ${.OBJDIR}/../../ofw/libofw/lib
+ CFLAGS+= -I${.CURDIR}/../../ofw/libofw/
+
+ # where to get libstand from
+-CFLAGS+= -I${.CURDIR}/../../../../lib/libstand/
++CFLAGS+= -I/usr/include/libstand/
+
+ DPADD= ${LIBFICL} ${LIBOFW} ${LIBSTAND}
+ LDADD= ${LIBFICL} ${LIBOFW} -lstand