summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild')
-rw-r--r--dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild b/dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild
new file mode 100644
index 00000000..5bf7fd10
--- /dev/null
+++ b/dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds methods to set and authenticate against one time passwords"
+HOMEPAGE="https://github.com/heapsource/active_model_otp"
+SRC_URI="https://github.com/heapsource/active_model_otp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "
+ dev-ruby/activemodel:*
+ =dev-ruby/rotp-6.3*
+"