summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/transproc/transproc-1.1.1.ebuild')
-rw-r--r--dev-ruby/transproc/transproc-1.1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/transproc/transproc-1.1.1.ebuild b/dev-ruby/transproc/transproc-1.1.1.ebuild
new file mode 100644
index 00000000..7dfec9a4
--- /dev/null
+++ b/dev-ruby/transproc/transproc-1.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compose procs into a functional pipeline using left-to-right function composition"
+
+HOMEPAGE="https://github.com/solnic/transproc"
+LICENSE="MIT"
+
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+all_ruby_prepare() {
+ sed -e '2irequire "pathname"' -i spec/spec_helper.rb || die
+}