summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2007-02-19 15:16:41 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2007-02-19 15:16:41 +0000
commitafaa93cfa30103d9ff42b6e88f645e6648427363 (patch)
treee2126e63141e3e8ec65273eeab0e1b436355ce7b
parentDo the GCC_SPECS thing also for gcc-3 hardened filtering (diff)
downloadkevquinn-afaa93cfa30103d9ff42b6e88f645e6648427363.tar.gz
kevquinn-afaa93cfa30103d9ff42b6e88f645e6648427363.tar.bz2
kevquinn-afaa93cfa30103d9ff42b6e88f645e6648427363.zip
Align with cvs 2007-02-19
svn path=/; revision=181
-rw-r--r--hardened/toolchain/branches/pieworld/eclass/toolchain-funcs.eclass4
-rw-r--r--hardened/toolchain/branches/pieworld/eclass/toolchain.eclass67
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest8
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.1-r3.ebuild4
4 files changed, 57 insertions, 26 deletions
diff --git a/hardened/toolchain/branches/pieworld/eclass/toolchain-funcs.eclass b/hardened/toolchain/branches/pieworld/eclass/toolchain-funcs.eclass
index 8bdccd3..1774151 100644
--- a/hardened/toolchain/branches/pieworld/eclass/toolchain-funcs.eclass
+++ b/hardened/toolchain/branches/pieworld/eclass/toolchain-funcs.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain-funcs.eclass,v 1.65 2007/02/12 05:01:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain-funcs.eclass,v 1.66 2007/02/16 00:12:02 vapier Exp $
#
# Author: Toolchain Ninjas <toolchain@gentoo.org>
#
@@ -101,7 +101,7 @@ tc-is-cross-compiler() {
# rejects softfloat flags where the target always lacks an fpu.
tc-is-softfloat() {
case ${CTARGET} in
- h8300*)
+ bfin*|h8300*)
echo "only" ;;
*)
[[ ${CTARGET//_/-} == *-softfloat-* ]] \
diff --git a/hardened/toolchain/branches/pieworld/eclass/toolchain.eclass b/hardened/toolchain/branches/pieworld/eclass/toolchain.eclass
index 6b3fabd..2096027 100644
--- a/hardened/toolchain/branches/pieworld/eclass/toolchain.eclass
+++ b/hardened/toolchain/branches/pieworld/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.323 2007/02/12 05:02:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.328 2007/02/18 02:12:03 flameeyes Exp $
HOMEPAGE="http://gcc.gnu.org/"
LICENSE="GPL-2 LGPL-2.1"
@@ -137,9 +137,10 @@ else
if [[ ${PN} != "kgcc64" ]] ; then
IUSE="${IUSE} altivec build fortran nls nocxx"
- [[ -n ${PIE_VER} ]] && IUSE="${IUSE} nopie"
- [[ -n ${PP_VER} ]] && IUSE="${IUSE} nossp"
- [[ -n ${HTB_VER} ]] && IUSE="${IUSE} boundschecking"
+ [[ -n ${PIE_VER} ]] && IUSE="${IUSE} nopie"
+ [[ -n ${PP_VER} ]] && IUSE="${IUSE} nossp"
+ [[ -n ${HTB_VER} ]] && IUSE="${IUSE} boundschecking"
+ [[ -n ${D_VER} ]] && IUSE="${IUSE} d"
if version_is_at_least 3 ; then
IUSE="${IUSE} bootstrap doc gcj gtk hardened multilib objc vanilla"
@@ -182,6 +183,7 @@ fi
# Travis Tilley <lv@gentoo.org> (03 Sep 2004)
#
gcc_get_s_dir() {
+ local GCC_S
if [[ -n ${PRERELEASE} ]] ; then
GCC_S=${WORKDIR}/gcc-${PRERELEASE}
elif [[ -n ${SNAPSHOT} ]] ; then
@@ -189,7 +191,6 @@ gcc_get_s_dir() {
else
GCC_S=${WORKDIR}/gcc-${GCC_RELEASE_VER}
fi
-
echo "${GCC_S}"
}
@@ -338,6 +339,10 @@ get_gcc_src_uri() {
)"
fi
+ # support for the D language
+ [[ -n ${D_VER} ]] && \
+ GCC_SRC_URI="${GCC_SRC_URI} d? ( mirror://sourceforge/dgcc/gdc-${D_VER}-src.tar.bz2 )"
+
echo "${GCC_SRC_URI}"
}
S=$(gcc_get_s_dir)
@@ -1064,7 +1069,7 @@ gcc_src_unpack() {
gcc_quick_unpack
exclude_gcc_patches
- cd ${S:=$(gcc_get_s_dir)}
+ cd "${S}"
if ! use vanilla ; then
if [[ -n ${PATCH_VER} ]] ; then
@@ -1222,6 +1227,7 @@ gcc-compiler-configure() {
GCC_LANG="c"
is_cxx && GCC_LANG="${GCC_LANG},c++"
+ is_d && GCC_LANG="${GCC_LANG},d"
is_gcj && GCC_LANG="${GCC_LANG},java"
if is_objc || is_objcxx ; then
GCC_LANG="${GCC_LANG},objc"
@@ -1316,19 +1322,20 @@ gcc_do_configure() {
# disable a bunch of features or gcc goes boom
local needed_libc=""
case ${CTARGET} in
- *-linux) needed_libc=no-fucking-clue;;
- *-dietlibc) needed_libc=dietlibc;;
- *-freebsd*) needed_libc=freebsd-lib;;
- *-gnu*) needed_libc=glibc;;
- *-klibc) needed_libc=klibc;;
- *-uclibc*) needed_libc=uclibc;;
- mingw*) needed_libc=mingw-runtime;;
- avr) confgcc="${confgcc} --enable-shared --disable-threads";;
+ *-linux) needed_libc=no-fucking-clue;;
+ *-dietlibc) needed_libc=dietlibc;;
+ *-elf) needed_libc=newlib;;
+ *-freebsd*) needed_libc=freebsd-lib;;
+ *-gnu*) needed_libc=glibc;;
+ *-klibc) needed_libc=klibc;;
+ *-uclibc*) needed_libc=uclibc;;
+ mingw*|*-mingw*) needed_libc=mingw-runtime;;
+ avr) confgcc="${confgcc} --enable-shared --disable-threads";;
esac
if [[ -n ${needed_libc} ]] ; then
if ! has_version ${CATEGORY}/${needed_libc} ; then
confgcc="${confgcc} --disable-shared --disable-threads --without-headers"
- elif built_with_use ${CATEGORY}/${needed_libc} crosscompile_opts_headers-only ; then
+ elif built_with_use --hidden --missing false ${CATEGORY}/${needed_libc} crosscompile_opts_headers-only ; then
confgcc="${confgcc} --disable-shared --with-sysroot=${PREFIX}/${CTARGET}"
else
confgcc="${confgcc} --with-sysroot=${PREFIX}/${CTARGET}"
@@ -1358,6 +1365,8 @@ gcc_do_configure() {
confgcc="${confgcc} --enable-sjlj-exceptions"
elif [[ ${CTARGET} == *-gnu* ]] ; then
confgcc="${confgcc} --enable-__cxa_atexit"
+ elif [[ ${CTARGET} == *-freebsd* ]]; then
+ confgcc="${confgcc} --enable-__cxa_atexit"
fi
[[ ${CTARGET} == *-gnu* ]] && confgcc="${confgcc} --enable-clocale=gnu"
[[ ${CTARGET} == *-uclibc* ]] && [[ ${GCCMAJOR}.${GCCMINOR} > 3.3 ]] \
@@ -1943,12 +1952,29 @@ gcc_quick_unpack() {
unpack gcc-${GCC_RELEASE_VER}.tar.bz2
# We want branch updates to be against a release tarball
if [[ -n ${BRANCH_UPDATE} ]] ; then
- pushd ${S:-"$(gcc_get_s_dir)"} > /dev/null
+ pushd "${S}" > /dev/null
epatch ${DISTDIR}/gcc-${GCC_RELEASE_VER}-branch-update-${BRANCH_UPDATE}.patch.bz2
popd > /dev/null
fi
fi
+ if [[ -n ${D_VER} ]] ; then
+ pushd "${S}"/gcc > /dev/null
+ unpack gdc-${D_VER}-src.tar.bz2
+ cd ..
+ if use d ; then
+ ebegin "Adding support for the D language"
+ ./gcc/d/setup-gcc.sh >& "${T}"/dgcc.log
+ if ! eend $? ; then
+ eerror "The D gcc package failed to apply"
+ eerror "Please include this log file when posting a bug report:"
+ eerror " ${T}/dgcc.log"
+ die "failed to include the D language"
+ fi
+ fi
+ popd > /dev/null
+ fi
+
[[ -n ${PATCH_VER} ]] && \
unpack gcc-${PATCH_GCC_VER}-patches-${PATCH_VER}.tar.bz2
@@ -1958,7 +1984,7 @@ gcc_quick_unpack() {
if want_ssp && ! gcc_has_native_ssp ; then
if [[ -n ${PP_FVER} ]] ; then
# The gcc 3.4 propolice versions are meant to be unpacked to ${S}
- pushd ${S:-$(gcc_get_s_dir)} > /dev/null
+ pushd "${S}" > /dev/null
unpack protector-${PP_FVER}.tar.gz
popd > /dev/null
else
@@ -1974,7 +2000,6 @@ gcc_quick_unpack() {
fi
fi
- # pappy@gentoo.org - Fri Oct 1 23:24:39 CEST 2004
want_boundschecking && \
unpack "bounds-checking-gcc-${HTB_GCC_VER}-${HTB_VER}.patch.bz2"
@@ -2443,6 +2468,12 @@ is_cxx() {
! use nocxx
}
+is_d() {
+ gcc-lang-supported d || return 1
+ use build && return 1
+ use d
+}
+
is_f77() {
gcc-lang-supported f77 || return 1
use build && return 1
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest b/hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest
index 52ccaa2..ea7febe 100644
--- a/hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest
@@ -160,10 +160,10 @@ EBUILD gcc-3.4.6-r3.ebuild 5024 RMD160 447d015fe832316eec29bbde1963acad73acd4b5
MD5 9a4b9092452554690d3a48e216f3e35e gcc-3.4.6-r3.ebuild 5024
RMD160 447d015fe832316eec29bbde1963acad73acd4b5 gcc-3.4.6-r3.ebuild 5024
SHA256 d79ef43bc13a04992776a42de612f1c3c03be628833ac54c832e7c111acfbc69 gcc-3.4.6-r3.ebuild 5024
-EBUILD gcc-4.1.1-r3.ebuild 3620 RMD160 c8e53d74cf4a1bc99485dee2900d25468802bc8c SHA1 67f4462a2346175cc322fc9ca1632a8cf4ff8a48 SHA256 a3250d3d8ed6516f2ebdce133980c37c8df192e77ad3e74792476e61ce572e7e
-MD5 4b37478452551299af102bde6b9940df gcc-4.1.1-r3.ebuild 3620
-RMD160 c8e53d74cf4a1bc99485dee2900d25468802bc8c gcc-4.1.1-r3.ebuild 3620
-SHA256 a3250d3d8ed6516f2ebdce133980c37c8df192e77ad3e74792476e61ce572e7e gcc-4.1.1-r3.ebuild 3620
+EBUILD gcc-4.1.1-r3.ebuild 3621 RMD160 6680af1e737c03742241b9e52531d45822a66d49 SHA1 0c367d0c5c88f436a3d1bba019a1d00210881e0b SHA256 aadbf598501f69904bf605c1a1e9c1ad8a57d2a2734093381d04e09d4099f688
+MD5 beadc390569c05a5d7c0dfe2f73e43e3 gcc-4.1.1-r3.ebuild 3621
+RMD160 6680af1e737c03742241b9e52531d45822a66d49 gcc-4.1.1-r3.ebuild 3621
+SHA256 aadbf598501f69904bf605c1a1e9c1ad8a57d2a2734093381d04e09d4099f688 gcc-4.1.1-r3.ebuild 3621
MD5 f2ae42150d118fee847851b13498c67d files/digest-gcc-3.4.6-r3 1623
RMD160 61cd90be115485be70bc0c6511848949fd86e3ff files/digest-gcc-3.4.6-r3 1623
SHA256 fb9bc05b7f310a0ce63c7538d07315a3432bced82fc26c656e9ec0d843df2468 files/digest-gcc-3.4.6-r3 1623
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.1-r3.ebuild b/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.1-r3.ebuild
index 4e44c20..64d241b 100644
--- a/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.1-r3.ebuild
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.1-r3.ebuild,v 1.12 2007/02/12 17:37:57 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.1-r3.ebuild,v 1.13 2007/02/13 14:36:19 gustavoz Exp $
PATCH_VER="1.10"
UCLIBC_VER="1.1"
@@ -40,7 +40,7 @@ inherit toolchain
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-* alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sparc ~sparc-fbsd x86 ~x86-fbsd"
+KEYWORDS="-* alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc ~sparc-fbsd x86 ~x86-fbsd"
RDEPEND=">=sys-libs/zlib-1.1.4
|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )