summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild')
-rw-r--r--hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild b/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild
index bf201df..eef6df1 100644
--- a/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild
+++ b/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild
@@ -223,7 +223,7 @@ toolchain-glibc_src_unpack() {
if use hardened; then
einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
- # Tihs patch forces all links to use the PIC crtfiles, to build PIEs.
+ # This patch forces all links to use the PIC crtfiles, to build PIEs.
epatch ${FILESDIR}/2.5/glibc-2.5-hardened-pie.patch
# This patch fixes the PIC detector to ignore PIE
epatch ${FILESDIR}/2.4/glibc-2.4-hardened-configure-picdefault.patch
@@ -249,6 +249,10 @@ toolchain-glibc_src_unpack() {
# Build nscd with ssp-all
sed -i -e 's:-fstack-protector$:-fstack-protector-all:' ${S}/nscd/Makefile ||
die "Failed to ensure nscd builds with ssp-all"
+
+ # Fix all ifdef PIC to accept also __PIC__, in header and
+ # un-pre-processed assembler source files.
+ fixup_DPIC -style prepend ${S} "*.[h|S]"
fi
gnuconfig_update