summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-plugins-good/gst-plugins-good-1.4.4.ebuild')
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.4.4.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.4.4.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.4.4.ebuild
deleted file mode 100644
index d923d80..0000000
--- a/media-libs/gst-plugins-good/gst-plugins-good-1.4.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-GST_ORG_MODULE="gst-plugins-good"
-inherit eutils flag-o-matic gstreamer
-
-DESCRIPTION="Basepack of plugins for gstreamer"
-HOMEPAGE="http://gstreamer.freedesktop.org/"
-
-LICENSE="LGPL-2.1+"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="+orc"
-
-# dtmf plugin moved from bad to good in 1.2
-RDEPEND="
- >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
- >=media-libs/gst-plugins-base-1.2.3:${SLOT}[${MULTILIB_USEDEP}]
- >=media-libs/gstreamer-1.2.4:${SLOT}[${MULTILIB_USEDEP}]
- >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
-
- !<media-libs/gst-plugins-bad-1.1:${SLOT}
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.12
-"
-
-src_configure() {
- # gst doesnt handle optimisations well
- strip-flags
- replace-flags "-O3" "-O2"
- filter-flags "-fprefetch-loop-arrays" # see bug 22249
-
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- # Always enable optional bz2 support for matroska
- # Always enable optional zlib support for qtdemux and matroska
- # Many media files require these to work, as some container headers are often
- # compressed, bug #291154
- gstreamer_multilib_src_configure \
- --enable-bz2 \
- --enable-zlib \
- --disable-examples \
- --with-default-audiosink=autoaudiosink \
- --with-default-visualizer=goom
-}
-
-multilib_src_install_all() {
- DOCS="AUTHORS ChangeLog NEWS README RELEASE"
- einstalldocs
- prune_libtool_files --modules
-}