summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0001-Fix-parallel-make-for-Gentoo-bug-255440.patch')
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0001-Fix-parallel-make-for-Gentoo-bug-255440.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0001-Fix-parallel-make-for-Gentoo-bug-255440.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0001-Fix-parallel-make-for-Gentoo-bug-255440.patch
new file mode 100644
index 0000000..51d0c90
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0001-Fix-parallel-make-for-Gentoo-bug-255440.patch
@@ -0,0 +1,26 @@
+From 8cf7b4f825320d3aff30ea8cabb21e253519093e Mon Sep 17 00:00:00 2001
+From: Peter Alfredsen <loki_val@gentoo.org>
+Date: Thu, 22 Jan 2009 13:23:31 +0100
+Subject: [PATCH 01/10] Fix parallel make for Gentoo bug 255440
+
+---
+ src/cpp/Makefile | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/cpp/Makefile b/src/cpp/Makefile
+index 7e54282..ebffe7c 100644
+--- a/src/cpp/Makefile
++++ b/src/cpp/Makefile
+@@ -113,6 +113,9 @@ all: \
+ LIBXMLRPC_CPP_SH = $(call shlibfn, libxmlrpc_cpp)
+
+ $(LIBXMLRPC_CPP_SH): XmlRpcCpp.osh \
++ $(LIBXMLRPC_UTIL) \
++ $(LIBXMLRPC) \
++ $(LIBXMLRPC_SERVER) \
+ $(LIBXMLRPC_UTIL)
+ $(LIBXMLRPC_CPP_SH): LIBOBJECTS = XmlRpcCpp.osh
+ $(LIBXMLRPC_CPP_SH): LIBDEP = -Lblddir/src -lxmlrpc -lxmlrpc_server -L$(LIBXMLRPC_UTIL_DIR) -lxmlrpc_util
+--
+1.6.1
+