summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-08-05 13:42:32 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-08-05 13:42:32 +0000
commit2e30781b923f97b62997b2c8f15fd97fefdb51a6 (patch)
tree52312a72f5fcef1254405c8ada51fa9b76a04ca3 /sys-libs
parentRemove hardcoded use in order to use it as main compiler (diff)
downloadlu_zero-2e30781b923f97b62997b2c8f15fd97fefdb51a6.tar.gz
lu_zero-2e30781b923f97b62997b2c8f15fd97fefdb51a6.tar.bz2
lu_zero-2e30781b923f97b62997b2c8f15fd97fefdb51a6.zip
forgot to add the update
svn path=/; revision=35
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libspe/files/digest-libspe-1.1.03
-rw-r--r--sys-libs/libspe/libspe-1.1.0.ebuild55
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-libs/libspe/files/digest-libspe-1.1.0 b/sys-libs/libspe/files/digest-libspe-1.1.0
new file mode 100644
index 0000000..b0da9d5
--- /dev/null
+++ b/sys-libs/libspe/files/digest-libspe-1.1.0
@@ -0,0 +1,3 @@
+MD5 8e8122e320637123ab780692afef0887 libspe-1.1.0.tar.gz 70187
+RMD160 602f5f03184ff79b3b30731bd491a8758be00442 libspe-1.1.0.tar.gz 70187
+SHA256 06aa9eedc2fd5c7c17eb387b186c9d6ebf83e1ebe136e80fe6ff4d3b11b654b3 libspe-1.1.0.tar.gz 70187
diff --git a/sys-libs/libspe/libspe-1.1.0.ebuild b/sys-libs/libspe/libspe-1.1.0.ebuild
new file mode 100644
index 0000000..e553346
--- /dev/null
+++ b/sys-libs/libspe/libspe-1.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A wrapper library to adapt the JSRE SPU usage model to SPUFS"
+HOMEPAGE="http://www.bsc.es/projects/deepcomputing/linuxoncell/stable/libspe.html"
+SRC_URI="http://www.bsc.es/projects/deepcomputing/linuxoncell/stable/libspe/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ SYSROOT=""
+else
+ SYSROOT="${CTARGET}"
+fi
+
+src_unpack () {
+ unpack ${A}
+ #just in case something is missing
+}
+
+src_compile() {
+ myconf=""
+ use debug && myconf="${myconf} DEBUG=1"
+ make CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" ${myconf}
+}
+
+src_install() {
+ make CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" \
+ DESTDIR="$D" install
+ cp ${FILESDIR}/spe.rc6 ${T}/elfspe
+ doinitd ${T}/elfspe
+}
+
+
+pkg_postinst() {
+ einfo "You may want to register elfspe to binfmt using the"
+ einfo "provided initscript"
+ einfo "# rcupdate add elfspe boot"
+}