summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2010-07-27 01:51:29 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2010-07-27 01:51:29 +0530
commit5204623d03b45c11155cfa3915c04961535459b6 (patch)
tree86a6b5dea1a15f5a67fd1aa939b14f332849b9b5
parentAdd psb-kmod with 2.6.34 support, xf86-video-psb with min backlight fixes (diff)
downloadnirbheek-5204623d03b45c11155cfa3915c04961535459b6.tar.gz
nirbheek-5204623d03b45c11155cfa3915c04961535459b6.tar.bz2
nirbheek-5204623d03b45c11155cfa3915c04961535459b6.zip
Add shotwell, libgexiv2, libraw
-rw-r--r--media-gfx/shotwell/Manifest3
-rw-r--r--media-gfx/shotwell/files/shotwell-0.6.1-vala-0.9-fixes.patch59
-rw-r--r--media-gfx/shotwell/shotwell-0.6.1.ebuild52
-rw-r--r--media-libs/libgexiv2/Manifest2
-rw-r--r--media-libs/libgexiv2/libgexiv2-0.1.0.ebuild50
-rw-r--r--media-libs/libraw/Manifest3
-rw-r--r--media-libs/libraw/files/libraw.pc12
-rw-r--r--media-libs/libraw/libraw-0.9.1.ebuild71
8 files changed, 252 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
new file mode 100644
index 0000000..27f5d5b
--- /dev/null
+++ b/media-gfx/shotwell/Manifest
@@ -0,0 +1,3 @@
+AUX shotwell-0.6.1-vala-0.9-fixes.patch 2261 RMD160 271aab83c391f7a14d94a33ef88744bbb086048f SHA1 272a4ed1cf61ec56b987028534ead9594dbffbbd SHA256 62f82c128f4a532a4a59b6e0b5e2bc9c0113ccc862bd57e0849aaa118d455202
+DIST shotwell-0.6.1.tar.bz2 681013 RMD160 45ef932fcc46b12713cf334c31a57cd18fdc2915 SHA1 824c119ddbc853b07fcce373f92a16ff384f64b1 SHA256 01314373d35f05bcdc223eb06a0f21e76ae3e3e1d6628822816a147db1d534dc
+EBUILD shotwell-0.6.1.ebuild 1397 RMD160 25e59f8bd95f4a94cef2745fd835db90bd32a139 SHA1 4e5035e1271a236decd4ecc526b668ddc86926fb SHA256 1584efb48aaef0eba7136ca57077eddce2152466d96e853c9f9971e220d82ac3
diff --git a/media-gfx/shotwell/files/shotwell-0.6.1-vala-0.9-fixes.patch b/media-gfx/shotwell/files/shotwell-0.6.1-vala-0.9-fixes.patch
new file mode 100644
index 0000000..10d608a
--- /dev/null
+++ b/media-gfx/shotwell/files/shotwell-0.6.1-vala-0.9-fixes.patch
@@ -0,0 +1,59 @@
+Index: src/ImportPage.vala
+===================================================================
+--- src/ImportPage.vala (revision 1951)
++++ src/ImportPage.vala (revision 1952)
+@@ -620,8 +620,8 @@
+ mount.unmounted.connect(on_unmounted);
+
+ debug("Unmounting camera ...");
+- mount.unmount_with_operation(MountUnmountFlags.NONE, new Gtk.MountOperation(AppWindow.get_instance()),
+- null, on_unmount_finished);
++ mount.unmount_with_operation.begin(MountUnmountFlags.NONE,
++ new Gtk.MountOperation(AppWindow.get_instance()), null, on_unmount_finished);
+
+ return true;
+ }
+@@ -631,7 +631,7 @@
+
+ Mount mount = (Mount) source;
+ try {
+- mount.unmount_with_operation_finish(aresult);
++ mount.unmount_with_operation.end(aresult);
+ } catch (Error err) {
+ AppWindow.error_message(UNMOUNT_FAILED_MSG);
+
+Index: src/util.vala
+===================================================================
+--- src/util.vala (revision 1951)
++++ src/util.vala (revision 1952)
+@@ -635,7 +635,7 @@
+ return ((AppInfo) a).get_name().down().collate(((AppInfo) b).get_name().down());
+ }
+
+-public SortedList<AppInfo> get_apps_for_mime_types(string[] mime_types) {
++public SortedList<AppInfo> get_apps_for_mime_types(string[] mime_types) {
+ SortedList<AppInfo> external_apps = new SortedList<AppInfo>(app_info_comparator);
+
+ if (mime_types.length == 0)
+@@ -644,10 +644,10 @@
+ // 3 loops because SortedList.contains() wasn't paying nicely with AppInfo,
+ // probably because it has a special equality function
+ foreach (string mime_type in mime_types) {
+- unowned string content_type = g_content_type_from_mime_type(mime_type);
+- if (content_type == null)
+- break;
+-
++ string content_type = g_content_type_from_mime_type(mime_type);
++ if (content_type == null)
++ break;
++
+ foreach (AppInfo external_app in
+ AppInfo.get_all_for_type(content_type)) {
+ bool already_contains = false;
+@@ -709,4 +709,4 @@
+ #else
+ return "/";
+ #endif
+-}
+\ No newline at end of file
++}
diff --git a/media-gfx/shotwell/shotwell-0.6.1.ebuild b/media-gfx/shotwell/shotwell-0.6.1.ebuild
new file mode 100644
index 0000000..9e59732
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.5.2.ebuild,v 1.1 2010/05/30 06:20:04 hollow Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="http://www.yorba.org/shotwell/"
+SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3.5.9:3
+ >=dev-libs/dbus-glib-0.80
+ >=dev-libs/libgee-0.5.0
+ >=dev-libs/libunique-1.0.0
+ >=dev-libs/libxml2-2.6.32
+ >=gnome-base/gconf-2.22.0
+ >=media-libs/libexif-0.6.16
+ >=media-libs/libgexiv2-0.1.0
+ >=media-libs/libgphoto2-2.4.2
+ >=media-libs/libraw-0.9.0
+ >=net-libs/libsoup-2.26.0
+ >=net-libs/webkit-gtk-1.1.5
+ >=sys-fs/udev-145[extras]
+ >=x11-libs/gtk+-2.18.0:2"
+DEPEND="${RDEPEND}
+ >=dev-lang/vala-0.8"
+
+DOCS="AUTHORS MAINTAINERS NEWS README THANKS"
+
+src_prepare() {
+ G2CONF="--disable-schemas-install
+ --disable-desktop-update
+ --disable-icon-update"
+
+ epatch "${FILESDIR}/${P}-vala-0.9-fixes.patch"
+}
+
+src_install() {
+ # This is needed so that gnome2_gconf_savelist() works correctly.
+ insinto "${EPREFIX}"/etc/gconf/schemas
+ doins misc/shotwell.schemas || die "install gconf schema failed"
+ gnome2_src_install
+}
diff --git a/media-libs/libgexiv2/Manifest b/media-libs/libgexiv2/Manifest
new file mode 100644
index 0000000..c8de8dc
--- /dev/null
+++ b/media-libs/libgexiv2/Manifest
@@ -0,0 +1,2 @@
+DIST libgexiv2-0.1.0.tar.bz2 23971 RMD160 8f8ffb19b58772679437df072153eb26101345b1 SHA1 31d14d35189e128f3c72e51cf627fa462dc60dd9 SHA256 0efddbda2e103f0704f57b06571cacded7401323480082107ee5cde3f1d61f6f
+EBUILD libgexiv2-0.1.0.ebuild 1325 RMD160 aea461c1dc30241559391543baf84e1e0544b250 SHA1 02849a5209294495108fbedfbd7670aa79aaa6ec SHA256 db0d478bd11569c29c4d1910ed0a890c6eeacf9f1721e22ffcaabcafaee7d6bb
diff --git a/media-libs/libgexiv2/libgexiv2-0.1.0.ebuild b/media-libs/libgexiv2/libgexiv2-0.1.0.ebuild
new file mode 100644
index 0000000..eca48dd
--- /dev/null
+++ b/media-libs/libgexiv2/libgexiv2-0.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.19.ebuild,v 1.8 2010/04/18 19:24:55 maekke Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PN="gexiv2"
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
+HOMEPAGE="http://trac.yorba.org/wiki/gexiv2"
+SRC_URI="http://yorba.org/download/${MY_PN}/${MY_PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="dev-libs/glib
+ >=media-gfx/exiv2-0.19"
+DEPEND="${RDEPEND}
+ dev-lang/vala[vapigen]
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -ie 's/libtool/libtool --tag=CC/g' Makefile || die "libtool sed failed"
+}
+
+src_configure() {
+ local myconf="--prefix=/usr"
+
+ use debug && myconf+=" --debug"
+
+ # Upstream has a custom configure shell script
+ ./configure ${myconf} || die "configure failed"
+
+ echo "LIB=$(get_libdir)" >> configure.mk
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS MAINTAINERS NEWS README THANKS || die "dodoc failed"
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die "deleting .la files failed"
+ find "${D}" -name '*.a' -delete || die "deleting .la files failed"
+ fi
+}
diff --git a/media-libs/libraw/Manifest b/media-libs/libraw/Manifest
new file mode 100644
index 0000000..1f2af97
--- /dev/null
+++ b/media-libs/libraw/Manifest
@@ -0,0 +1,3 @@
+AUX libraw.pc 289 RMD160 89a58bc9aae7b465c4f504e3c7e55beb07461dfb SHA1 483d5dba5ea0d99c5d1901fa3648cc475a18c7c0 SHA256 214beae165ae5b678c386ba9db570f4bae95e55638aec054c2d3195d53ea5bdf
+DIST LibRaw-0.9.1.tar.gz 547554 RMD160 53cf7747c91b47c35014379c1cc6490e2b1468d1 SHA1 c314ac3949605ea3419f0ef1851af3af1772e6d9 SHA256 f9737af7988579945994c1eb3b9e74ff201584e7dc8a92dac0b1e83457be125c
+EBUILD libraw-0.9.1.ebuild 1791 RMD160 babaec04f599108253a88c2eaf5cf31a0a43b948 SHA1 51a18d43edad062d4f5b6dc08217ca470a91429c SHA256 d301998779edcd9b9956858d400b7cb02092c9c749136d0ed99ee72d243d6cf6
diff --git a/media-libs/libraw/files/libraw.pc b/media-libs/libraw/files/libraw.pc
new file mode 100644
index 0000000..5d688ab
--- /dev/null
+++ b/media-libs/libraw/files/libraw.pc
@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+VERSION=@version@
+
+Name: @PN@
+Description: Library for easy decoding of camera RAW files
+Requires:
+Version: @version@
+Libs: -L${libdir} -lraw -ljpeg
+Cflags: -I${includedir}/libraw -I${includedir}
diff --git a/media-libs/libraw/libraw-0.9.1.ebuild b/media-libs/libraw/libraw-0.9.1.ebuild
new file mode 100644
index 0000000..714f99f
--- /dev/null
+++ b/media-libs/libraw/libraw-0.9.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+MY_P="LibRaw-${PV}"
+
+inherit eutils
+
+DESCRIPTION="Decoding library for RAW image formats"
+HOMEPAGE="http://www.libraw.org/"
+SRC_URI="http://www.${PN}.org/data/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 CDDL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lcms openmp utils"
+
+RDEPEND="media-libs/jpeg:0
+ lcms? ( media-libs/lcms:0 )"
+DEPEND="${RDEPEND}
+ openmp? ( sys-devel/gcc[openmp] )"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ local prefix=/usr
+
+ sed -e "s:@prefix@:${prefix}:g" \
+ -e "s:@version@:${PV}:g" \
+ -e "s:@PN@:${PN}:g" \
+ ${FILESDIR}/libraw.pc > ${WORKDIR}/libraw.pc || die "pkgconfig sed failed"
+
+ sed -ie "s:CFLAGS=\(.*\):CFLAGS=${CFLAGS} \1:g" Makefile || die "CFLAGS fix failed"
+
+ if use lcms; then
+ sed -ie "s:^#\(LCMS_.*\)/usr/local/\(.*\):\1${ROOT}${prefix}/\2:" Makefile || die "Enable lcms failed"
+ sed -ie "s/^\(Libs:.*\)/\1 -llcms/g" ${WORKDIR}/libraw.pc || die "lcms pkgconfig failed"
+ fi
+
+ if use openmp; then
+ sed -ie "s:^#\(CFLAGS.*openmp\):\1:" Makefile || die "Enable openmp failed"
+ sed -ie "s/^\(Libs:.*\)/\1 -fopenmp/g" ${WORKDIR}/libraw.pc || die "openmp pkgconfig failed"
+ fi
+}
+
+src_compile() {
+ emake library || die "emake library failed"
+ if use utils; then
+ emake all_samples || die "emake utils failed"
+ fi
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)
+ doins ./lib/lib* || die "doins libs failed"
+
+ insinto /usr/include
+ doins -r ./libraw || die "doins includes failed"
+
+ if use utils; then
+ insinto /usr/bin
+ doins samples/* || die "doins utils failed"
+ fi
+
+ # Only static libs are installed
+ insinto /usr/lib/pkgconfig
+ doins ${WORKDIR}/libraw.pc || die "doins .pc failed"
+
+ dodoc Changelog.txt || die "dodoc failed"
+}