summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/kvm/files/kvm-45-qemu-no-img.patch')
-rw-r--r--app-emulation/kvm/files/kvm-45-qemu-no-img.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/app-emulation/kvm/files/kvm-45-qemu-no-img.patch b/app-emulation/kvm/files/kvm-45-qemu-no-img.patch
new file mode 100644
index 0000000..2bbc692
--- /dev/null
+++ b/app-emulation/kvm/files/kvm-45-qemu-no-img.patch
@@ -0,0 +1,78 @@
+--- kvm-45/qemu/Makefile 2007-10-02 01:36:33.000000000 -0700
++++ kvm-45/qemu/Makefile 2007-10-07 01:37:38.000000000 -0700
+@@ -17,30 +17,27 @@
+ BASE_LDFLAGS += -static
+ endif
+ ifdef BUILD_DOCS
+-DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1
++DOCS=qemu-doc.html qemu-tech.html qemu.1
+ else
+ DOCS=
+ endif
+
+ LIBS+=$(AIOLIBS)
+
+-all: $(TOOLS) $(DOCS) recurse-all
++all: $(DOCS) recurse-all
+
+ subdir-%: dyngen$(EXESUF)
+ $(MAKE) -C $(subst subdir-,,$@) all
+
+ recurse-all: $(patsubst %,subdir-%, $(TARGET_DIRS))
+
+-qemu-img$(EXESUF): qemu-img.c cutils.c block.c block-raw.c block-cow.c block-qcow.c aes.c block-vmdk.c block-cloop.c block-dmg.c block-bochs.c block-vpc.c block-vvfat.c block-qcow2.c block-parallels.c
+- $(CC) -DQEMU_TOOL $(CFLAGS) $(CPPFLAGS) $(BASE_CFLAGS) $(LDFLAGS) $(BASE_LDFLAGS) -o $@ $^ -lz $(LIBS)
+-
+ dyngen$(EXESUF): dyngen.c
+ $(HOST_CC) $(CFLAGS) $(CPPFLAGS) $(BASE_CFLAGS) -o $@ $^
+
+ clean:
+ # avoid old build problems by removing potentially incorrect old files
+ rm -f config.mak config.h op-i386.h opc-i386.h gen-op-i386.h op-arm.h opc-arm.h gen-op-arm.h
+- rm -f *.o *.a $(TOOLS) dyngen$(EXESUF) TAGS cscope.* *.pod *~ */*~
++ rm -f *.o *.a dyngen$(EXESUF) TAGS cscope.* *.pod *~ */*~
+ $(MAKE) -C tests clean
+ for d in $(TARGET_DIRS); do \
+ $(MAKE) -C $$d $@ || exit 1 ; \
+@@ -62,12 +59,11 @@
+ $(INSTALL) -m 644 qemu-doc.html qemu-tech.html "$(DESTDIR)$(docdir)"
+ ifndef CONFIG_WIN32
+ mkdir -p "$(DESTDIR)$(mandir)/man1"
+- $(INSTALL) qemu.1 qemu-img.1 "$(DESTDIR)$(mandir)/man1"
++ $(INSTALL) qemu.1 "$(DESTDIR)$(mandir)/man1"
+ endif
+
+ install: all $(if $(BUILD_DOCS),install-doc)
+ mkdir -p "$(DESTDIR)$(bindir)"
+- $(INSTALL) -m 755 $(TOOLS) "$(DESTDIR)$(bindir)"
+ mkdir -p "$(DESTDIR)$(datadir)"
+ for x in bios.bin vgabios.bin vgabios-cirrus.bin ppc_rom.bin \
+ video.x openbios-sparc32 pxe-ne2k_pci.bin \
+@@ -110,10 +106,6 @@
+ $(SRC_PATH)/texi2pod.pl $< qemu.pod
+ pod2man --section=1 --center=" " --release=" " qemu.pod > $@
+
+-qemu-img.1: qemu-img.texi
+- $(SRC_PATH)/texi2pod.pl $< qemu-img.pod
+- pod2man --section=1 --center=" " --release=" " qemu-img.pod > $@
+-
+ info: qemu-doc.info qemu-tech.info
+
+ dvi: qemu-doc.dvi qemu-tech.dvi
+@@ -161,7 +153,6 @@
+ $(bindir)/qemu-alpha \
+ $(bindir)/qemu-m68k \
+ $(bindir)/qemu-sh4 \
+- $(bindir)/qemu-img \
+ $(datadir)/bios.bin \
+ $(datadir)/vgabios.bin \
+ $(datadir)/vgabios-cirrus.bin \
+@@ -173,7 +164,7 @@
+ $(datadir)/pxe-pcnet.bin \
+ $(docdir)/qemu-doc.html \
+ $(docdir)/qemu-tech.html \
+- $(mandir)/man1/qemu.1 $(mandir)/man1/qemu-img.1 )
++ $(mandir)/man1/qemu.1 )
+
+ ifneq ($(wildcard .depend),)
+ include .depend