summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-04-22 10:52:35 +0000
committerChristian Heim <phreak@gentoo.org>2007-04-22 10:52:35 +0000
commit8cf678b4a1f44fc1d06699fa8b6f0f5bf0c6a5fa (patch)
tree6ed13384144cfec7e0602c03791233c6f493614f /hardened
parentQuote the occurences of ${D}, rewrite the pax-mark and its explanation. (diff)
downloadphreak-8cf678b4a1f44fc1d06699fa8b6f0f5bf0c6a5fa.tar.gz
phreak-8cf678b4a1f44fc1d06699fa8b6f0f5bf0c6a5fa.tar.bz2
phreak-8cf678b4a1f44fc1d06699fa8b6f0f5bf0c6a5fa.zip
Some simple comment changes, move the env.d entry from postinst to install, as it should belong into CONTENTS of the package.
svn path=/; revision=320
Diffstat (limited to 'hardened')
-rw-r--r--hardened/dev-lang/ocaml/Manifest8
-rw-r--r--hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild26
2 files changed, 18 insertions, 16 deletions
diff --git a/hardened/dev-lang/ocaml/Manifest b/hardened/dev-lang/ocaml/Manifest
index 2856dab..ebdebae 100644
--- a/hardened/dev-lang/ocaml/Manifest
+++ b/hardened/dev-lang/ocaml/Manifest
@@ -19,10 +19,10 @@ MD5 bcc5109143faee7e7b8f7f76bd4726a7 files/ocaml-rebuild.sh 1361
RMD160 a9c452fbea18de3b38d8240f887f8595e529643e files/ocaml-rebuild.sh 1361
SHA256 a8004cd4bca96ab3fc595fcfd7dbe88903833f9e430149c3d04c9fda84362b64 files/ocaml-rebuild.sh 1361
DIST ocaml-3.09.3.tar.bz2 2038617 RMD160 fdc124218c556c62c897ee6720970279e2d5426b SHA1 5d63c6e0d13463f85c0d5147d641d2bceef87d6b SHA256 607842b4f4917a759f19541a421370a834f5b948855ca54cef40d22b19a0934f
-EBUILD ocaml-3.09.3-r1.ebuild 3863 RMD160 c9ff8ee8498171472d86e29b807834065ee37fa4 SHA1 882724f5f5cca626e9c1afa5ccd83ef40297a93f SHA256 ad320e4099dd241249be39875a6d8a16a5bd3cc43439306f34a448e41eff185d
-MD5 cb05ddc48c336819b40eaf405936382e ocaml-3.09.3-r1.ebuild 3863
-RMD160 c9ff8ee8498171472d86e29b807834065ee37fa4 ocaml-3.09.3-r1.ebuild 3863
-SHA256 ad320e4099dd241249be39875a6d8a16a5bd3cc43439306f34a448e41eff185d ocaml-3.09.3-r1.ebuild 3863
+EBUILD ocaml-3.09.3-r1.ebuild 4033 RMD160 37198bf3e03d0c51601e4a2a414f2256f4c18814 SHA1 4c4804fa00e1ffbf0111be19a3b6f77370da7871 SHA256 d59c9cfbf6d28d6ad35b3d3937c55c6a1c98d380b6923fada6cf27e704c1f0f5
+MD5 cfa22ed3bcceca85ccf81958acdb5b03 ocaml-3.09.3-r1.ebuild 4033
+RMD160 37198bf3e03d0c51601e4a2a414f2256f4c18814 ocaml-3.09.3-r1.ebuild 4033
+SHA256 d59c9cfbf6d28d6ad35b3d3937c55c6a1c98d380b6923fada6cf27e704c1f0f5 ocaml-3.09.3-r1.ebuild 4033
MD5 71f3dc5bc2ee57a403689b56bc1a85c1 files/digest-ocaml-3.09.3-r1 244
RMD160 e7f0898889b94faae3b1481555bac42e9298b370 files/digest-ocaml-3.09.3-r1 244
SHA256 19708f759185ed39623e03921462ba20fb6f3533268673d2bcd7dd07cef57350 files/digest-ocaml-3.09.3-r1 244
diff --git a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
index defb049..e12ad32 100644
--- a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
+++ b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3.ebuild,v 1.9 2007/04/15 20:17:05 corsair Exp $
-inherit flag-o-matic eutils multilib pax-utils
+inherit flag-o-matic eutils multilib pax-utils versionator
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
-SRC_URI="http://caml.inria.fr/distrib/ocaml-3.09/${P}.tar.bz2"
+SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2 )/${P}.tar.bz2"
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
@@ -40,8 +40,8 @@ src_unpack() {
# in driver/ocamlcomp.sh.in. Reported upstream as issue 0004268.
epatch "${FILESDIR}"/${P}-Makefile.patch
- # Change the configure script to add the CFLAGS to bytecccompopts and
- # LDFLAGS to bytecclinkopts.
+ # Change the configure script to add the CFLAGS to bytecccompopts, LDFLAGS
+ # to bytecclinkopts.
sed -i -e "s,bytecccompopts=\"\",bytecccompopts=\"\${CFLAGS}\"," \
-e "s,bytecclinkopts=\"\",bytecclinkopts=\"\${LDFLAGS}\"," \
"${S}"/configure
@@ -102,18 +102,20 @@ src_install() {
pax-mark -m "${D}"//usr/bin/ocamldoc.opt "${D}"/usr/bin/ocamldep.opt \
"${D}"/usr/bin/ocamllex.opt "${D}"/usr/bin/camlp4r.opt \
"${D}"/usr/bin/camlp4o.opt
-}
-pkg_postinst() {
- if use latex; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ # Create and envd entry for latex input files (this definitely belongs into
+ # CONTENT and not in pkg_postinst.
+ if use latex ; then
+ echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
+ doenvd "${T}"/99ocamldoc
fi
+}
+pkg_postinst() {
echo
- elog "OCaml is not binary compatible from version to version,"
- elog "so you (may) need to rebuild all packages depending on it that"
- elog "are actually installed on your system."
- elog "To do so, you can run: "
+ elog "OCaml is not binary compatible from version to version, so you (may)"
+ elog "need to rebuild all packages depending on it, that are actually"
+ elog "installed on your system. To do so, you can run:"
elog "sh ${FILESDIR}/ocaml-rebuild.sh [-h | emerge options]"
elog "Which will call emerge on all old packages with the given options"
echo