summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-01-06 10:40:08 +0800
committerMu Qiao <qiaomuf@gentoo.org>2011-01-06 10:40:08 +0800
commita6dd6722ecf08b9b8c58a050463ebba5792a1098 (patch)
tree2399142b8b05dcf1cad6c58d38d736977196e5b0
parentfix manifest (diff)
downloadqiaomuf-a6dd6722ecf08b9b8c58a050463ebba5792a1098.tar.gz
qiaomuf-a6dd6722ecf08b9b8c58a050463ebba5792a1098.tar.bz2
qiaomuf-a6dd6722ecf08b9b8c58a050463ebba5792a1098.zip
Version bump for openfetion, fix bug in ifnet plugin
Signed-off-by: Mu Qiao <qiaomuf@gentoo.org>
-rw-r--r--net-im/openfetion/ChangeLog7
-rw-r--r--net-im/openfetion/Manifest2
-rw-r--r--net-im/openfetion/openfetion-2.1.0.ebuild55
-rw-r--r--net-misc/networkmanager/files/networkmanager-0.8.2-shared-connection.patch47
4 files changed, 100 insertions, 11 deletions
diff --git a/net-im/openfetion/ChangeLog b/net-im/openfetion/ChangeLog
index 652a281..16250bf 100644
--- a/net-im/openfetion/ChangeLog
+++ b/net-im/openfetion/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-im/openfetion
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*openfetion-2.1.0 (05 Jan 2011)
+
+ 05 Jan 2011; Mu Qiao <qiaomuf@gentoo.org> +openfetion-2.1.0.ebuild:
+ Revision bump, based on the live ebuild written by upstream
+
*openfetion-2.0.7 (28 Nov 2010)
28 Nov 2010; <gentoo@gentoo.org> +openfetion-2.0.7.ebuild, +metadata.xml:
diff --git a/net-im/openfetion/Manifest b/net-im/openfetion/Manifest
index 962516b..23af704 100644
--- a/net-im/openfetion/Manifest
+++ b/net-im/openfetion/Manifest
@@ -1,6 +1,6 @@
DIST openfetion-2.0.7.tar.gz 794386 RMD160 15bf83747d9825b4819d90cad7d080d68e85b05b SHA1 5b2a8abfa61928618c033ebc034b4a5f730003a6 SHA256 37bdab942713512ab02d34e1b16a810764e55688c93cd5daee88c64c50c22695
DIST openfetion-2.1.0.tar.gz 369094 RMD160 f190894863713b916f76f962a3eeecc53f453715 SHA1 3f078bea8a3a2fa198deebd73ded8637a81f0176 SHA256 3bd06731b6bdbeb5a66c65061ca9887b965f835e7fabf6d5da9e72ad38e34d44
EBUILD openfetion-2.0.7.ebuild 920 RMD160 57cd873fa9dfb73a1b5ae749ca0e4b6dc688ed3d SHA1 0ef3a361c038a907c1275a0289313ead7cea47ff SHA256 2a84b85d88b7e98c5c30b1c09850ff3f909494e693c96bf984e1195576a4fea9
-EBUILD openfetion-2.1.0.ebuild 1124 RMD160 cab490716d1a15e18eb66145d0e320eaa4bf8df0 SHA1 a4b0227ee53973d1ced4eadf385ead753d41fa5a SHA256 09d057b21c74b7755ce7bfe5414d5941743ce86a2c64e779221d9e91186de8fa
+EBUILD openfetion-2.1.0.ebuild 1331 RMD160 e1d55525b227f70be032f0c529f9d6486c575930 SHA1 6be97535b75f4ece23121566d41a0a773a087654 SHA256 5ef015fb333fe9b0a6dde07391ed7c1e103752b1acf1ccdce20873103275efea
MISC ChangeLog 246 RMD160 70512a2ada62cc065c03ab67a316916d7817f29b SHA1 ea3a97d6b93113203ce11cdf0239face0da9015d SHA256 7683cc21f892ff43de43abf3b00be6a1465b8353c244c519229cd2e6f1b42543
MISC metadata.xml 216 RMD160 e99c47ba555ab9c5840db973af6b2bdd21127091 SHA1 ea3e97b8a730687767cf13495aeaa94ac17352c1 SHA256 778c8364ef437a2407d3bcda74a4d84b1a29902ac8ef3dd9de78405d7f54f5fb
diff --git a/net-im/openfetion/openfetion-2.1.0.ebuild b/net-im/openfetion/openfetion-2.1.0.ebuild
new file mode 100644
index 0000000..495f17e
--- /dev/null
+++ b/net-im/openfetion/openfetion-2.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="A GTK IM client using CHINA MOBILE's Fetion Protocol 4"
+HOMEPAGE="http://ofetion.googlecode.com"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer libnotify networkmanager nls +xscreensaver"
+RESTRICT="mirror"
+
+DEPEND="gstreamer? ( media-libs/gstreamer )
+ libnotify? ( x11-libs/libnotify )
+ networkmanager? ( net-misc/networkmanager )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_disable nls)
+ $(cmake-utils_use_with libnotify)
+ $(cmake-utils_use_with gstreamer)
+ $(cmake-utils_use_with xscreensaver LIBXSS)
+ $(cmake-utils_use_with networkmanager)
+ $(cmake-utils_use_with networkmanager DBUSGLIB)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use gstreamer || rm "${D}/usr/share/openfetion/resource/newmessage.wav"
+}
+
+pkg_postinst() {
+ if ! use gstreamer; then
+ elog ""
+ elog "To use the sound reminder function, please enable gstreamer USE flag"
+ elog "and compile it again."
+ elog ""
+ fi
+}
diff --git a/net-misc/networkmanager/files/networkmanager-0.8.2-shared-connection.patch b/net-misc/networkmanager/files/networkmanager-0.8.2-shared-connection.patch
index 3536924..a9e9705 100644
--- a/net-misc/networkmanager/files/networkmanager-0.8.2-shared-connection.patch
+++ b/net-misc/networkmanager/files/networkmanager-0.8.2-shared-connection.patch
@@ -1,16 +1,17 @@
-From 4a495b961aab736fa2881057ecf8a7c5044fb4a3 Mon Sep 17 00:00:00 2001
+From 765cf2873a92bc83ce35f965e0ccf8bc5dcff6e8 Mon Sep 17 00:00:00 2001
From: Mu Qiao <qiaomuf@gentoo.org>
Date: Wed, 5 Jan 2011 13:30:08 +0800
Subject: [PATCH] Support shared and link-local method for ipv4
Signed-off-by: Mu Qiao <qiaomuf@gentoo.org>
---
- system-settings/plugins/ifnet/connection_parser.c | 49 ++++++++++++++++-----
- system-settings/plugins/ifnet/net_utils.c | 4 ++
- 2 files changed, 42 insertions(+), 11 deletions(-)
+ system-settings/plugins/ifnet/connection_parser.c | 55 ++++++++++++++++----
+ system-settings/plugins/ifnet/net_utils.c | 4 ++
+ .../plugins/ifnet/nm-ifnet-connection.c | 8 ++-
+ 3 files changed, 53 insertions(+), 14 deletions(-)
diff --git a/system-settings/plugins/ifnet/connection_parser.c b/system-settings/plugins/ifnet/connection_parser.c
-index f9fae51..def5c4a 100644
+index f9fae51..07fb511 100644
--- a/system-settings/plugins/ifnet/connection_parser.c
+++ b/system-settings/plugins/ifnet/connection_parser.c
@@ -557,7 +557,7 @@ make_ip4_setting (NMConnection * connection, gchar * conn_name, GError ** error)
@@ -22,7 +23,7 @@ index f9fae51..def5c4a 100644
gboolean is_static_block = is_static_ip4 (conn_name);
ip_block *iblock = NULL;
-@@ -569,12 +569,36 @@ make_ip4_setting (NMConnection * connection, gchar * conn_name, GError ** error)
+@@ -569,12 +569,42 @@ make_ip4_setting (NMConnection * connection, gchar * conn_name, GError ** error)
&& strstr (value, "nogateway") ? TRUE : FALSE, NULL);
if (!is_static_block) {
@@ -33,6 +34,12 @@ index f9fae51..def5c4a 100644
- PLUGIN_PRINT (IFNET_PLUGIN_NAME, "Using DHCP for %s",
- conn_name);
+ method = ifnet_get_data (conn_name, "config");
++ if (!method){
++ g_set_error (error, ifnet_plugin_error_quark (), 0,
++ "Unknown config for %s", conn_name);
++ g_object_unref (ip4_setting);
++ return;
++ }
+ if (!strcmp (method, "dhcp"))
+ g_object_set (ip4_setting,
+ NM_SETTING_IP4_CONFIG_METHOD,
@@ -65,7 +72,7 @@ index f9fae51..def5c4a 100644
} else {
iblock = convert_ip4_config_block (conn_name);
if (!iblock) {
-@@ -625,7 +649,7 @@ make_ip4_setting (NMConnection * connection, gchar * conn_name, GError ** error)
+@@ -625,7 +655,7 @@ make_ip4_setting (NMConnection * connection, gchar * conn_name, GError ** error)
}
/* add dhcp hostname and client id */
@@ -74,7 +81,7 @@ index f9fae51..def5c4a 100644
gchar *dhcp_hostname, *client_id;
get_dhcp_hostname_and_client_id (&dhcp_hostname, &client_id);
-@@ -712,7 +736,6 @@ make_ip4_setting (NMConnection * connection, gchar * conn_name, GError ** error)
+@@ -712,7 +742,6 @@ make_ip4_setting (NMConnection * connection, gchar * conn_name, GError ** error)
iblock = iblock->next;
destroy_ip_block (current_iblock);
}
@@ -82,7 +89,7 @@ index f9fae51..def5c4a 100644
/* Finally add setting to connection */
nm_connection_add_setting (connection, NM_SETTING (ip4_setting));
}
-@@ -2443,8 +2466,12 @@ write_ip4_setting (NMConnection * connection, gchar * conn_name,
+@@ -2443,8 +2472,12 @@ write_ip4_setting (NMConnection * connection, gchar * conn_name,
}
ifnet_set_data (conn_name, "config", ips->str);
g_string_free (ips, TRUE);
@@ -112,6 +119,28 @@ index 2dc253c..7e52f10 100644
dhcp6 = strstr (data, "dhcp6");
if (dhcp6) {
gchar *dhcp4;
+diff --git a/system-settings/plugins/ifnet/nm-ifnet-connection.c b/system-settings/plugins/ifnet/nm-ifnet-connection.c
+index e47495c..ebe2581 100644
+--- a/system-settings/plugins/ifnet/nm-ifnet-connection.c
++++ b/system-settings/plugins/ifnet/nm-ifnet-connection.c
+@@ -71,12 +71,14 @@ nm_ifnet_connection_new (gchar * conn_name)
+ {
+ NMConnection *tmp;
+ GObject *object;
+- GError **error = NULL;
++ GError *error = NULL;
+
+ g_return_val_if_fail (conn_name != NULL, NULL);
+- tmp = ifnet_update_connection_from_config_block (conn_name, error);
+- if (!tmp)
++ tmp = ifnet_update_connection_from_config_block (conn_name, &error);
++ if (!tmp){
++ g_error_free (error);
+ return NULL;
++ }
+ object = (GObject *) g_object_new (NM_TYPE_IFNET_CONNECTION,
+ NM_IFNET_CONNECTION_CONN_NAME,
+ conn_name, NULL);
--
1.7.2.2