summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-04-24 09:05:30 +0000
committerRichard Brown <rbrown@gentoo.org>2007-04-24 09:05:30 +0000
commit2f4a94e2876d7cf1056f094a7e8debc22249414f (patch)
treec499604c7ce11fa26b0469ccb8a57d7d0e3db2ff /dev-lang
parentemake test (diff)
downloadrbrown-2f4a94e2876d7cf1056f094a7e8debc22249414f.tar.gz
rbrown-2f4a94e2876d7cf1056f094a7e8debc22249414f.tar.bz2
rbrown-2f4a94e2876d7cf1056f094a7e8debc22249414f.zip
Change ipv6 behaviour for glibc
svn path=/; revision=11
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ruby-1.8.6-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-lang/ruby/ruby-1.8.6-r1.ebuild b/dev-lang/ruby/ruby-1.8.6-r1.ebuild
index 5f6f9d1..7cf545a 100644
--- a/dev-lang/ruby/ruby-1.8.6-r1.ebuild
+++ b/dev-lang/ruby/ruby-1.8.6-r1.ebuild
@@ -18,7 +18,7 @@ SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/$(get_version_component_range 1-2)/${P
LICENSE="Ruby"
SLOT="1.8"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug doc examples ipv6 rubytests socks5 threads tk" # cjk
+IUSE="debug doc elibc_glibc examples ipv6 rubytests socks5 threads tk" # cjk
RESTRICT="confcache"
RDEPEND=">=sys-libs/gdbm-1.8.0
@@ -77,10 +77,14 @@ src_compile() {
# Bug #168939
# We need to always enable ipv6, use --with-lookup-order-hack=INET
- # when we don't want ipv6
- myconf="--enable-ipv6"
- if ! use ipv6; then
- myconf="${myconf} --with-lookup-order-hack=INET"
+ # when we don't want ipv6 with glibc
+ if use elibc_glibc; then
+ myconf="--enable-ipv6"
+ if ! use ipv6; then
+ myconf="${myconf} --with-lookup-order-hack=INET"
+ fi
+ else
+ myconf=$(use_enable ipv6)
fi
econf --program-suffix=${SLOT/./} --enable-shared \