summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rtpflood')
-rw-r--r--net-misc/rtpflood/Manifest8
-rw-r--r--net-misc/rtpflood/files/digest-rtpflood-1.02
-rw-r--r--net-misc/rtpflood/rtpflood-1.0.ebuild26
3 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/rtpflood/Manifest b/net-misc/rtpflood/Manifest
new file mode 100644
index 0000000..f438075
--- /dev/null
+++ b/net-misc/rtpflood/Manifest
@@ -0,0 +1,8 @@
+DIST rtpflood.tar.gz 8993 RMD160 01fd90ad5a8b1fcd7d212908bb0529d493150fcb SHA1 b3b0a4d32e68d1ed24d15275cec05d625c03d662 SHA256 bdfc578b09ba6923e7e765b29c27e10bafb5a81c30defe442bf690de5623cce3
+EBUILD rtpflood-1.0.ebuild 557 RMD160 7c775ba4933bd947f7c0693c6848c2f421f164b7 SHA1 dbf5699f5e3aa0d068979d8db25a3eda0d425e9b SHA256 eedee8ad91f5da3c7404e9c1685722acdd4e394a107c4e2c7d5cef3934fb1add
+MD5 d0f60475340dd561e4748cf94a2a983a rtpflood-1.0.ebuild 557
+RMD160 7c775ba4933bd947f7c0693c6848c2f421f164b7 rtpflood-1.0.ebuild 557
+SHA256 eedee8ad91f5da3c7404e9c1685722acdd4e394a107c4e2c7d5cef3934fb1add rtpflood-1.0.ebuild 557
+MD5 844fa82b201bc70394a97e7872b317c3 files/digest-rtpflood-1.0 162
+RMD160 9f12654194ab6ad723e3c44e8569171302ba9ea1 files/digest-rtpflood-1.0 162
+SHA256 5f0999f58a0a0f8d3c847b0340cfed93f9ab61000d5382cd43d5ccabd582266d files/digest-rtpflood-1.0 162
diff --git a/net-misc/rtpflood/files/digest-rtpflood-1.0 b/net-misc/rtpflood/files/digest-rtpflood-1.0
new file mode 100644
index 0000000..abba347
--- /dev/null
+++ b/net-misc/rtpflood/files/digest-rtpflood-1.0
@@ -0,0 +1,2 @@
+RMD160 01fd90ad5a8b1fcd7d212908bb0529d493150fcb rtpflood.tar.gz 8993
+SHA256 bdfc578b09ba6923e7e765b29c27e10bafb5a81c30defe442bf690de5623cce3 rtpflood.tar.gz 8993
diff --git a/net-misc/rtpflood/rtpflood-1.0.ebuild b/net-misc/rtpflood/rtpflood-1.0.ebuild
new file mode 100644
index 0000000..9132691
--- /dev/null
+++ b/net-misc/rtpflood/rtpflood-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+DESCRIPTION="RTP flooder from the Hacking VoIP Exposed authors"
+HOMEPAGE="http://www.hackingvoip.com/sec_tools.html"
+SRC_URI="http://www.hackingvoip.com/tools/${PN}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd ${WORKDIR}/${PN}
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/${PN}
+ dobin rtpflood
+ dodoc LICENSE_SOFTWARE
+}