summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-11-16 17:38:07 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-11-16 17:38:07 +0000
commitd3ede2d47a73ea4328ab3b064d619e048b0cebd7 (patch)
treeaebd6f1084cd62a6c3a6587282a3ba40de37c287 /net-fs
parentNext version is out. (diff)
downloadoverlay-d3ede2d47a73ea4328ab3b064d619e048b0cebd7.tar.gz
overlay-d3ede2d47a73ea4328ab3b064d619e048b0cebd7.tar.bz2
overlay-d3ede2d47a73ea4328ab3b064d619e048b0cebd7.zip
New flickrfs version
svn path=/; revision=527
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/flickrfs/files/flickrfs-1.1.9.patch104
-rw-r--r--net-fs/flickrfs/flickrfs-1.1.9.ebuild2
-rw-r--r--net-fs/flickrfs/flickrfs-1.1.ebuild40
3 files changed, 145 insertions, 1 deletions
diff --git a/net-fs/flickrfs/files/flickrfs-1.1.9.patch b/net-fs/flickrfs/files/flickrfs-1.1.9.patch
new file mode 100644
index 0000000..bf1e74e
--- /dev/null
+++ b/net-fs/flickrfs/files/flickrfs-1.1.9.patch
@@ -0,0 +1,104 @@
+diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrapi.py flickrfs-1.1.9-mod/flickrapi.py
+--- flickrfs-1.1.9/flickrapi.py 2005-11-08 15:21:57.000000000 +0100
++++ flickrfs-1.1.9-mod/flickrapi.py 2005-11-14 22:07:26.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!python
+ #
+ # Flickr API implementation
+ #
+diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrfs.conf flickrfs-1.1.9-mod/flickrfs.conf
+--- flickrfs-1.1.9/flickrfs.conf 1970-01-01 01:00:00.000000000 +0100
++++ flickrfs-1.1.9-mod/flickrfs.conf 2005-11-14 21:03:03.000000000 +0100
+@@ -0,0 +1,18 @@
++[USER]
++
++# for out-of-band auth inside a web browser
++browserName : /usr/bin/firefox
++
++
++#-------------------------------------------------------------------
++
++# It is not necessary to change these. They just identifies this as
++# this application as flickrfs so that flickr.com can track the
++# usage by different api's
++
++# API key
++flickrAPIKey : f8aa9917a9ae5e44a87cae657924f42d
++
++# shared "secret"
++flickrSecret : 3fbf7144be7eca28
++
+diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrfs.py flickrfs-1.1.9-mod/flickrfs.py
+--- flickrfs-1.1.9/flickrfs.py 2005-11-08 22:01:39.000000000 +0100
++++ flickrfs-1.1.9-mod/flickrfs.py 2005-11-14 21:56:16.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!python
+ #@+leo-ver=4
+ #@+node:@file flickrfs.py
+ #===============================================================================
+@@ -58,11 +58,22 @@
+ #Import flickr python api
+ from flickrapi import FlickrAPI
+
+-# flickr auth information
+-flickrAPIKey = "f8aa9917a9ae5e44a87cae657924f42d" # API key
+-flickrSecret = "3fbf7144be7eca28" # shared "secret"
+-browserName = "/usr/bin/firefox" # for out-of-band auth inside a web browser
++# Import ConfigParser
++from ConfigParser import ConfigParser
+
++def read_config(config_file = '/etc/flickrfs/flickrfs.conf'):
++ defaults = {
++ 'flickrAPIKey' : "f8aa9917a9ae5e44a87cae657924f42d", # API key
++ 'flickrSecret' : "3fbf7144be7eca28", # shared "secret"
++ 'browserName' : "/usr/bin/firefox",} # for out-of-band auth inside a web browser
++
++ config = ConfigParser(defaults)
++ config.add_section('USER')
++
++ if os.access(config_file, os.R_OK):
++ config.read(config_file)
++
++ return config
+
+ class TransFlickr: #Transactions with flickr
+ def uploadfile(self, filepath, taglist, bufData, mode):
+@@ -1141,6 +1154,12 @@
+
+ #@+node:mainline
+ if __name__ == '__main__':
++
++ config = read_config()
++ flickrAPIKey = config.get('USER', 'flickrAPIKey')
++ flickrSecret = config.get('USER', 'flickrSecret')
++ browserName = config.get('USER', 'browserName')
++
+ try:
+ server = Flickrfs()
+ server.multithreaded = 1;
+diff -Naur --exclude='*.pyc' flickrfs-1.1.9/setup.py flickrfs-1.1.9-mod/setup.py
+--- flickrfs-1.1.9/setup.py 1970-01-01 01:00:00.000000000 +0100
++++ flickrfs-1.1.9-mod/setup.py 2005-11-14 20:23:31.000000000 +0100
+@@ -0,0 +1,20 @@
++#!/usr/bin/env python
++
++import sys
++
++from distutils.core import setup
++
++# this affects the names of all the directories we do stuff with
++sys.path.insert(0, './')
++
++setup(name = 'flickrfs',
++ version = 1.1.9,
++ description = 'A virtual filesystem that provides easy access to flickr',
++ author = 'Manish Rai Jain',
++ author_email = 'manishrjain@gmail.com',
++ url = 'http://flickrfs.sourceforge.net/',
++ py_modules = ['flickrapi'],
++ scripts = ['flickrfs'],
++ data_files = [('/etc/flickrfs', ['flickrfs.conf'])],
++ license = 'GPL',
++ )
diff --git a/net-fs/flickrfs/flickrfs-1.1.9.ebuild b/net-fs/flickrfs/flickrfs-1.1.9.ebuild
index 1250185..714c0f9 100644
--- a/net-fs/flickrfs/flickrfs-1.1.9.ebuild
+++ b/net-fs/flickrfs/flickrfs-1.1.9.ebuild
@@ -6,7 +6,7 @@ inherit distutils eutils
DESCRIPTION="Flickrfs is a virtual filesystem based upon FUSE that provides easy access to flickr."
HOMEPAGE="http://flickrfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-fs/flickrfs/flickrfs-1.1.ebuild b/net-fs/flickrfs/flickrfs-1.1.ebuild
new file mode 100644
index 0000000..1250185
--- /dev/null
+++ b/net-fs/flickrfs/flickrfs-1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils eutils
+
+DESCRIPTION="Flickrfs is a virtual filesystem based upon FUSE that provides easy access to flickr."
+HOMEPAGE="http://flickrfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~x86"
+
+RDEPEND="
+ =dev-lang/python-2.4*
+ dev-python/python-fuse"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+
+ epatch ${FILESDIR}/${P}.patch
+
+ mv flickrfs.py flickrfs
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README test.py
+}