diff options
author | Joseph Myers <joseph@codesourcery.com> | 2018-12-21 17:53:40 +0000 |
---|---|---|
committer | Joseph Myers <joseph@codesourcery.com> | 2018-12-21 17:53:40 +0000 |
commit | 192963be49678b48f60218f1f794991cdd9fe472 (patch) | |
tree | de9988c14e213591d5cf2a1b97092454516b6d22 /INSTALL | |
parent | malloc: Check the alignment of mmapped chunks before unmapping. (diff) | |
download | glibc-192963be49678b48f60218f1f794991cdd9fe472.tar.gz glibc-192963be49678b48f60218f1f794991cdd9fe472.tar.bz2 glibc-192963be49678b48f60218f1f794991cdd9fe472.zip |
Require GCC 5 or later to build glibc (bug 23993).
We know that building glibc with GCC 4.9 is broken on various
platforms (bug 23993). As it's more than a year since we last
increased the minimum GCC version to build glibc, this patch changes
the requirement to be GCC 5 or later (indeed, based on 4.9 having been
required for building 2.26, it would be consistent in terms of timing
to require GCC 6 or later from the 2.30 release onwards). It
deliberately just updates the configure test and corresponding
documentation, leaving removal of no-longer-needed __GNUC_PREREQ tests
for a separate patch.
In the NEWS entry, the requirement for a newer GCC version for
powerpc64le is reiterated (as in the entry for the 4.9 requirement in
2.26) to avoid suggesting the version requirement there has gone down.
(If that version goes up further as part of support for binary128 long
double, of course the wording would change at that time.)
Tested for x86_64.
[BZ #23993]
* configure.ac (libc_cv_compiler_ok): Require GCC 5 or later.
* configure: Regenerated.
* manual/install.texi (Tools for Compilation): Update minimum GCC
version.
* INSTALL: Regenerated.
Diffstat (limited to 'INSTALL')
-rw-r--r-- | INSTALL | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -459,9 +459,9 @@ build the GNU C Library: As of relase time, GNU 'make' 4.2.1 is the newest verified to work to build the GNU C Library. - * GCC 4.9 or newer + * GCC 5 or newer - GCC 4.9 or higher is required. In general it is recommended to use + GCC 5 or higher is required. In general it is recommended to use the newest version of the compiler that is known to work for building the GNU C Library, as newer compilers usually produce better code. As of release time, GCC 8.1.1 is the newest compiler |