aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2016-10-21 21:18:03 +0000
committerJoseph Myers <joseph@codesourcery.com>2016-10-21 21:18:03 +0000
commit7a8330c01bea0cb98654ca25e3ca5db7d48694b3 (patch)
tree1f5faab0b7c137b096e7b83bd1afa842a3938039 /benchtests/Makefile
parentpowerpc: Cleanup fenv_private.h (diff)
downloadglibc-7a8330c01bea0cb98654ca25e3ca5db7d48694b3.tar.gz
glibc-7a8330c01bea0cb98654ca25e3ca5db7d48694b3.tar.bz2
glibc-7a8330c01bea0cb98654ca25e3ca5db7d48694b3.zip
Use -fno-builtin for sqrt benchmark.
This patch makes the sqrt benchmark use -fno-builtin, as already done for benchmarks of ffs and ffsll, so that it actually benchmarks the glibc function as (presumably) intended even in the presence of the compiler inlining sqrt. Tested for x86_64 and also used for benchmarking my ARM sqrt patch. * benchtests/Makefile (CFLAGS-bench-sqrt.c): New variable.
Diffstat (limited to 'benchtests/Makefile')
-rw-r--r--benchtests/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/benchtests/Makefile b/benchtests/Makefile
index 144b32ea38..5a61522689 100644
--- a/benchtests/Makefile
+++ b/benchtests/Makefile
@@ -72,6 +72,7 @@ benchset := $(string-benchset-all) $(stdlib-benchset) $(stdio-common-benchset) \
CFLAGS-bench-ffs.c += -fno-builtin
CFLAGS-bench-ffsll.c += -fno-builtin
+CFLAGS-bench-sqrt.c += -fno-builtin
bench-malloc := malloc-thread