aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdhemerval Zanella <adhemerval.zanella@linaro.org>2019-03-11 17:01:11 +0000
committerAdhemerval Zanella <adhemerval.zanella@linaro.org>2019-07-08 17:14:04 -0300
commitf215dbbdf18893b08e0b00eb12d369e7cf4a946d (patch)
tree87e0a1e67ef362b96f88e12ca73aa952ab1c1d92 /benchtests/Makefile
parentdl-vdso: Add LINUX_4 HASH CODE to support nds32 vdso mechanism (diff)
downloadglibc-f215dbbdf18893b08e0b00eb12d369e7cf4a946d.tar.gz
glibc-f215dbbdf18893b08e0b00eb12d369e7cf4a946d.tar.bz2
glibc-f215dbbdf18893b08e0b00eb12d369e7cf4a946d.zip
benchtests: hypot benchmark
Inputs are based on argument reductions from generic and powerpc implementation. * benchtests/Makefile (bench-math): Add hypot. * benchtests/hypot-inputs: New file. Reviewed-by: Gabriel F. T. Gomes <gabrielftg@linux.ibm.com>
Diffstat (limited to 'benchtests/Makefile')
-rw-r--r--benchtests/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/benchtests/Makefile b/benchtests/Makefile
index ef400a8e48..2d49113d7e 100644
--- a/benchtests/Makefile
+++ b/benchtests/Makefile
@@ -24,7 +24,7 @@ include ../Makeconfig
bench-math := acos acosh asin asinh atan atanh cos cosh exp exp2 log log2 \
modf pow rint sin sincos sinh sqrt tan tanh fmin fmax fminf \
fmaxf powf trunc truncf expf exp2f logf log2f sincosf sinf \
- cosf isnan isinf isfinite
+ cosf isnan isinf isfinite hypot
bench-pthread := pthread_once thread_create