aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos O'Donell <carlos@systemhalted.org>2015-11-27 10:09:45 -0500
committerCarlos O'Donell <carlos@systemhalted.org>2015-11-27 10:22:38 -0500
commit90fe682d3067163aa773feecf497ef599429457a (patch)
tree112e4c0c097305fc1d82681b15592f0f8456f6ba /locale/Makefile
parentBetter workaround for aliases of *_finite symbols in vector math library. (diff)
downloadglibc-90fe682d3067163aa773feecf497ef599429457a.tar.gz
glibc-90fe682d3067163aa773feecf497ef599429457a.tar.bz2
glibc-90fe682d3067163aa773feecf497ef599429457a.zip
Rename localedir to complocaledir (bug 14259).
In preparation to fix the --localedir configure argument we must move the existing conflicting definition of localedir to a more appropriate name. Given that all current internal uses of localedir relate to the compiled locales we rename to complocaledir.
Diffstat (limited to 'locale/Makefile')
-rw-r--r--locale/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/locale/Makefile b/locale/Makefile
index f1b4343935..75afbe106c 100644
--- a/locale/Makefile
+++ b/locale/Makefile
@@ -76,12 +76,15 @@ C-translit.h: C-translit.h.in gen-translit.pl
$(PERL) gen-translit.pl < $< > $@.tmp
mv -f $@.tmp $@
-localepath = "$(localedir):$(i18ndir)"
+# The path to the compiled binary locale archive or compiled locales,
+# along with the parent path to the source locales and source
+# charmaps.
+localepath = "$(complocaledir):$(i18ndir)"
# -Iprograms doesn't really belong here, but this gets it at the head
# of the list instead of the tail, where CPPFLAGS-$(lib) gets added.
# We need it before the standard -I's to see programs/config.h first.
-locale-CPPFLAGS = -DLOCALEDIR='"$(localedir)"' \
+locale-CPPFLAGS = -DCOMPLOCALEDIR='"$(complocaledir)"' \
-DLOCALE_ALIAS_PATH='"$(msgcatdir)"' \
-Iprograms