aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorvald Riegel <triegel@redhat.com>2015-04-21 20:34:21 +0200
committerTorvald Riegel <triegel@redhat.com>2015-06-04 15:31:59 +0200
commit3c9c61febede148b79d8509e16588152d99b3774 (patch)
tree883d4c88b3ca19506e9449132bfe2c93b0798269 /nptl/Makefile
parentNaCl: Implement nacl_interface_ext_supply entry point. (diff)
downloadglibc-3c9c61febede148b79d8509e16588152d99b3774.tar.gz
glibc-3c9c61febede148b79d8509e16588152d99b3774.tar.bz2
glibc-3c9c61febede148b79d8509e16588152d99b3774.zip
Fix lost wake-up when pthread_rwlock_timedrwlock times out.
If we set up a rwlock to prefer writers (and disallow recursive rdlock acquisitions), then readers will block for writers that are blocked to acquire the lock (otherwise, readers could constantly enter and exit, and the writer would never get the lock). However, the existing implementation did not wake such readers when the writer timed out. This patch adds the missing wake-up. There's no similar case for writers being blocked on readers.
Diffstat (limited to 'nptl/Makefile')
-rw-r--r--nptl/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/nptl/Makefile b/nptl/Makefile
index 3dd2944260..62436ac48f 100644
--- a/nptl/Makefile
+++ b/nptl/Makefile
@@ -231,6 +231,7 @@ tests = tst-typesizes \
tst-rwlock1 tst-rwlock2 tst-rwlock2a tst-rwlock3 tst-rwlock4 \
tst-rwlock5 tst-rwlock6 tst-rwlock7 tst-rwlock8 tst-rwlock9 \
tst-rwlock10 tst-rwlock11 tst-rwlock12 tst-rwlock13 tst-rwlock14 \
+ tst-rwlock15 \
tst-once1 tst-once2 tst-once3 tst-once4 \
tst-key1 tst-key2 tst-key3 tst-key4 \
tst-sem1 tst-sem2 tst-sem3 tst-sem4 tst-sem5 tst-sem6 tst-sem7 \