aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdhemerval Zanella <adhemerval.zanella@linaro.org>2018-03-18 11:28:59 +0800
committerAdhemerval Zanella <adhemerval.zanella@linaro.org>2018-05-02 08:43:31 -0300
commitcf2478d53ad7071e84c724a986b56fe17f4f4ca7 (patch)
tree907b40dddc0c8a10b1f91246efe6f141a402f80d /sysdeps/unix/sysv/linux/ustat.c
parentReplace hidden_def with libm_hidden_def in math (diff)
downloadglibc-cf2478d53ad7071e84c724a986b56fe17f4f4ca7.tar.gz
glibc-cf2478d53ad7071e84c724a986b56fe17f4f4ca7.tar.bz2
glibc-cf2478d53ad7071e84c724a986b56fe17f4f4ca7.zip
Deprecate ustat syscall interface
As for sysctl, ustat has been deprecated in favor of {f}statfs. Also some newer ports which uses generic interface builds a stub version that returns ENOSYS. This patch deprecates ustat interface by removing ustat.h related headers, adding a compatibility symbol, and avoiding new ports to build and provide the symbol. Checked on x86_64-linux-gnu and i686-linux-gnu. Also checked with a check-abi on all affected ABIs. * NEWS: Add ustat.h deprecation entry. * bits/ustat.h: Remove file. * misc/sys/ustat.h: Likewise. * misc/ustat.h: Likewise. * sysdeps/unix/sysv/linux/generic/ustat.c: Likewise. * misc/Makefile (headers): Remove ustat.h and sys/ustat.h. * misc/ustat.c (__ustat): Rename to __old_ustat and export only in compatibility mode. * sysdeps/unix/sysv/linux/ustat.c (__ustat): Likewise. * sysdeps/unix/sysv/linux/mips/ustat.c: Define DEV_TO_KDEV and use generic Linux implementation.
Diffstat (limited to 'sysdeps/unix/sysv/linux/ustat.c')
-rw-r--r--sysdeps/unix/sysv/linux/ustat.c50
1 files changed, 35 insertions, 15 deletions
diff --git a/sysdeps/unix/sysv/linux/ustat.c b/sysdeps/unix/sysv/linux/ustat.c
index 8e73faad55..50204e4953 100644
--- a/sysdeps/unix/sysv/linux/ustat.c
+++ b/sysdeps/unix/sysv/linux/ustat.c
@@ -1,4 +1,5 @@
-/* Copyright (C) 1997-2018 Free Software Foundation, Inc.
+/* Get filesystem statistics (deprecated). Linux version.
+ Copyright (C) 1997-2018 Free Software Foundation, Inc.
This file is part of the GNU C Library.
Contributed by Ulrich Drepper <drepper@cygnus.com>, 1997.
@@ -16,22 +17,41 @@
License along with the GNU C Library; if not, see
<http://www.gnu.org/licenses/>. */
-#include <errno.h>
-#include <sys/ustat.h>
-#include <sys/sysmacros.h>
+#include <shlib-compat.h>
-#include <sysdep.h>
-#include <sys/syscall.h>
+/* This deprecated syscall is no longer used (replaced with {f}statfs). */
+#if SHLIB_COMPAT(libc, GLIBC_2_0, GLIBC_2_28)
-int
-ustat (dev_t dev, struct ustat *ubuf)
-{
- unsigned long long int k_dev;
+# include <sysdep.h>
+# include <errno.h>
+
+# ifndef DEV_TO_KDEV
+# define DEV_TO_KDEV(__dev) \
+ ({ \
+ unsigned long long int k_dev; \
+ k_dev = dev & ((1ULL << 32) - 1); \
+ if (k_dev != dev) \
+ return INLINE_SYSCALL_ERROR_RETURN_VALUE (EINVAL); \
+ (unsigned int) k_dev; \
+ })
+# endif
- /* We must convert the value to dev_t type used by the kernel. */
- k_dev = dev & ((1ULL << 32) - 1);
- if (k_dev != dev)
- return INLINE_SYSCALL_ERROR_RETURN_VALUE (EINVAL);
+struct ustat
+{
+ __daddr_t f_tfree; /* Number of free blocks. */
+ __ino_t f_tinode; /* Number of free inodes. */
+ char f_fname[6];
+ char f_fpack[6];
+};
- return INLINE_SYSCALL (ustat, 2, (unsigned int) k_dev, ubuf);
+int
+__old_ustat (dev_t dev, struct ustat *ubuf)
+{
+# ifdef __NR_ustat
+ return INLINE_SYSCALL_CALL (ustat, DEV_TO_KDEV (dev), ubuf);
+# else
+ return INLINE_SYSCALL_ERROR_RETURN_VALUE (ENOSYS);
+# endif
}
+compat_symbol (libc, __old_ustat, ustat, GLIBC_2_0);
+#endif /* SHLIB_COMPAT(libc, GLIBC_2_0, GLIBC_2_28) */