diff options
author | mattip <matti.picus@gmail.com> | 2015-12-06 22:03:59 +0200 |
---|---|---|
committer | mattip <matti.picus@gmail.com> | 2015-12-06 22:03:59 +0200 |
commit | a3f0a2df78f7724cf30613f378d47a8ed977fa4a (patch) | |
tree | 7db23dc2618a8467d834b7b908de6a6a564488ac /Makefile | |
parent | Test and fix: if direct_libffi_call() fails, for example because it (diff) | |
download | pypy-a3f0a2df78f7724cf30613f378d47a8ed977fa4a.tar.gz pypy-a3f0a2df78f7724cf30613f378d47a8ed977fa4a.tar.bz2 pypy-a3f0a2df78f7724cf30613f378d47a8ed977fa4a.zip |
document and add building cffi import libraries to the (unused) Makefile
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -1,5 +1,5 @@ -all: pypy-c +all: pypy-c cffi_imports PYPY_EXECUTABLE := $(shell which pypy) URAM := $(shell python -c "import sys; print 4.5 if sys.maxint>1<<32 else 2.5") @@ -10,6 +10,8 @@ else RUNINTERP = $(PYPY_EXECUTABLE) endif +.PHONY: cffi_imports + pypy-c: @echo @echo "====================================================================" @@ -36,3 +38,6 @@ endif # replaced with an opaque --jobserver option by the time this Makefile # runs. We cannot get their original value either: # http://lists.gnu.org/archive/html/help-make/2010-08/msg00106.html + +cffi_imports: + PYTHONPATH=. ./pypy-c pypy/tool/build_cffi_imports.py |