diff options
author | Armin Rigo <arigo@tunes.org> | 2013-11-01 18:23:42 +0100 |
---|---|---|
committer | Armin Rigo <arigo@tunes.org> | 2013-11-01 18:23:42 +0100 |
commit | edeba82d9caaaa4094705fccb7919e6f06b31d53 (patch) | |
tree | c7f3cc892ab74cb56b8d1a0aa2e30dd8f2ce58a1 /Makefile | |
parent | Baaah. This was testing the base MiniMarkGC class, not (diff) | |
download | pypy-edeba82d9caaaa4094705fccb7919e6f06b31d53.tar.gz pypy-edeba82d9caaaa4094705fccb7919e6f06b31d53.tar.bz2 pypy-edeba82d9caaaa4094705fccb7919e6f06b31d53.zip |
Tweak the Makefile to run "rpython" using python rather than pypy, if
there is no pypy installed. Gives a proper warning in this case.
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 28 |
1 files changed, 25 insertions, 3 deletions
@@ -1,7 +1,29 @@ all: pypy-c +PYPY_EXECUTABLE := $(shell which pypy) +URAM := $(shell python -c "import sys; print 4.5 if sys.maxint>1<<32 else 2.5") + +ifeq ($(PYPY_EXECUTABLE),) +RUNINTERP = python +else +RUNINTERP = $(PYPY_EXECUTABLE) +endif + pypy-c: - @echo "Building PyPy with JIT, it'll take about 40 minutes and 4G of RAM" - @sleep 3 - rpython/bin/rpython -Ojit pypy/goal/targetpypystandalone.py + @echo + @echo "=============================================================" +ifeq ($(PYPY_EXECUTABLE),) + @echo "Building a regular (jitting) version of PyPy, using CPython." + @echo "This takes around 2 hours and $(URAM) GB of RAM." + @echo "Note that pre-installing a PyPy binary would reduce this time" + @echo "and produce basically the same result." +else + @echo "Building a regular (jitting) version of PyPy, using" + @echo "$(PYPY_EXECUTABLE) to run the translation itself." + @echo "This takes around 45 minutes and $(URAM) GB of RAM." +endif + @echo "=============================================================" + @echo + @sleep 5 + $(RUNINTERP) rpython/bin/rpython -Ojit pypy/goal/targetpypystandalone.py |