summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwiktor w brodlo <wiktor@brodlo.net>2011-07-25 17:46:48 +0000
committerwiktor w brodlo <wiktor@brodlo.net>2011-07-25 17:46:48 +0000
commit70e91af81e0cecc600fb1ab632d472fc6d5aa631 (patch)
tree3df32908f4c2c7b2670ac034ec303968312f705f
parentsys-block/open-iscsi version bump (diff)
downloadanaconda-overlay-70e91af81e0cecc600fb1ab632d472fc6d5aa631.tar.gz
anaconda-overlay-70e91af81e0cecc600fb1ab632d472fc6d5aa631.tar.bz2
anaconda-overlay-70e91af81e0cecc600fb1ab632d472fc6d5aa631.zip
Removed unnecessary sys-boot/grub versions
-rw-r--r--sys-boot/grub/grub-0.97-r22.ebuild240
-rw-r--r--sys-boot/grub/grub-1.98-r10.ebuild141
-rw-r--r--sys-boot/grub/grub-1.98-r9.ebuild145
3 files changed, 0 insertions, 526 deletions
diff --git a/sys-boot/grub/grub-0.97-r22.ebuild b/sys-boot/grub/grub-0.97-r22.ebuild
deleted file mode 100644
index 0be60db..0000000
--- a/sys-boot/grub/grub-0.97-r22.ebuild
+++ /dev/null
@@ -1,240 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r9.ebuild,v 1.4 2009/05/15 21:11:24 maekke Exp $
-
-# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
-# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
-# we never updated any of the source code (it still all wants menu.lst),
-# and there is no indication that upstream is making the transition.
-
-inherit mount-boot eutils flag-o-matic toolchain-funcs autotools multilib
-
-PATCHVER="1.9" # Should match the revision ideally
-DESCRIPTION="GNU GRUB Legacy boot loader"
-HOMEPAGE="http://www.gnu.org/software/grub/"
-SRC_URI="mirror://gentoo/${P}.tar.gz
- ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
- mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x86-fbsd"
-IUSE="custom-cflags ncurses netboot static"
-
-DEPEND="ncurses? (
- >=sys-libs/ncurses-5.2-r5
- amd64? ( app-emulation/emul-linux-x86-baselibs )
- )"
-PROVIDE="virtual/bootloader"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # patch breaks booting for some people #111885
- rm "${WORKDIR}"/patch/400_*
-
- # Grub will not handle a kernel larger than EXTENDED_MEMSIZE Mb as
- # discovered in bug 160801. We can change this, however, using larger values
- # for this variable means that Grub needs more memory to run and boot. For a
- # kernel of size N, Grub needs (N+1)*2. Advanced users should set a custom
- # value in make.conf, it is possible to make kernels ~16Mb in size, but it
- # needs the kitchen sink built-in.
- local t="custom"
- if [[ -z ${GRUB_MAX_KERNEL_SIZE} ]] ; then
- case $(tc-arch) in
- amd64) GRUB_MAX_KERNEL_SIZE=7 ;;
- x86) GRUB_MAX_KERNEL_SIZE=3 ;;
- esac
- t="default"
- fi
- einfo "Grub will support the ${t} maximum kernel size of ${GRUB_MAX_KERNEL_SIZE} Mb (GRUB_MAX_KERNEL_SIZE)"
-
- sed -i \
- -e "/^#define.*EXTENDED_MEMSIZE/s,3,${GRUB_MAX_KERNEL_SIZE},g" \
- "${S}"/grub/asmstub.c \
- || die "Failed to hack memory size"
-
- # UUID support
- epatch "${FILESDIR}/${P}-uuid.patch"
- epatch "${FILESDIR}/${P}-uuid_doc.patch"
- # Gfxmenu support
- epatch "${FILESDIR}/${P}-gfxmenu-v8.patch"
-
- if [[ -n ${PATCHVER} ]] ; then
- EPATCH_SUFFIX="patch"
- epatch "${WORKDIR}"/patch
- eautoreconf
- fi
-}
-
-src_compile() {
- filter-flags -fPIE #168834
-
- # Fix libvolume_id build (UUID)
- export CPPFLAGS="${CPPFLAGS} -I/usr/include -I/usr/$(get_libdir)/gcc/${CHOST}/$(gcc-fullversion)/include"
-
- use amd64 && multilib_toolchain_setup x86
-
- unset BLOCK_SIZE #73499
-
- ### i686-specific code in the boot loader is a bad idea; disabling to ensure
- ### at least some compatibility if the hard drive is moved to an older or
- ### incompatible system.
-
- # grub-0.95 added -fno-stack-protector detection, to disable ssp for stage2,
- # but the objcopy's (faulty) test fails if -fstack-protector is default.
- # create a cache telling configure that objcopy is ok, and add -C to econf
- # to make use of the cache.
- #
- # CFLAGS has to be undefined running econf, else -fno-stack-protector detection fails.
- # STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
- # -fno-stack-protector detected by configure, removed from netboot's emake.
- use custom-cflags || unset CFLAGS
-
- export grub_cv_prog_objcopy_absolute=yes #79734
- use static && append-ldflags -static
-
- # Per bug 216625, the emul packages do not provide .a libs for performing
- # suitable static linking
- if use amd64 && use static ; then
- if [ -z "${GRUB_STATIC_PACKAGE_BUILDING}" ]; then
- die "You must use the grub-static package if you want a static Grub on amd64!"
- else
- eerror "You have set GRUB_STATIC_PACKAGE_BUILDING. This"
- eerror "is specifically intended for building the tarballs for the"
- eerror "grub-static package via USE='static -ncurses'."
- eerror "All bets are now off."
- ebeep 10
- fi
- fi
-
- # build the net-bootable grub first, but only if "netboot" is set
- if use netboot ; then
- econf \
- --libdir=/lib \
- --datadir=/usr/lib/grub \
- --exec-prefix=/ \
- --disable-auto-linux-mem-opt \
- --enable-diskless \
- --enable-{3c{5{03,07,09,29,95},90x},cs89x0,davicom,depca,eepro{,100}} \
- --enable-{epic100,exos205,ni5210,lance,ne2100,ni{50,65}10,natsemi} \
- --enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
- --enable-{tulip,via-rhine,w89c840} || die "netboot econf failed"
-
- emake w89c840_o_CFLAGS="-O" || die "making netboot stuff"
-
- mv -f stage2/{nbgrub,pxegrub} "${S}"/
- mv -f stage2/stage2 stage2/stage2.netboot
-
- make clean || die "make clean failed"
- fi
-
- # Now build the regular grub
- # Note that FFS and UFS2 support are broken for now - stage1_5 files too big
- econf \
- --libdir=/lib \
- --datadir=/usr/lib/grub \
- --exec-prefix=/ \
- --disable-auto-linux-mem-opt \
- $(use_with ncurses curses) \
- || die "econf failed"
-
- # sanity check due to common failure
- use ncurses && ! grep -qs "HAVE_LIBCURSES.*1" config.h && die "USE=ncurses but curses not found"
-
- emake || die "making regular stuff"
-}
-
-src_test() {
- # non-default block size also give false pass/fails.
- unset BLOCK_SIZE
- make check || die "make check failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- if use netboot ; then
- exeinto /usr/lib/grub/${CHOST}
- doexe nbgrub pxegrub stage2/stage2.netboot || die "netboot install"
- fi
-
- dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
- newdoc docs/menu.lst grub.conf.sample
- dodoc "${FILESDIR}"/grub.conf.gentoo
- prepalldocs
-
- [ -n "${GRUB_STATIC_PACKAGE_BUILDING}" ] && \
- mv \
- "${D}"/usr/share/doc/${PF} \
- "${D}"/usr/share/doc/grub-static-${PF/grub-}
-
- insinto /usr/share/grub
- doins "${FILESDIR}"/splash.xpm.gz
-
-}
-
-setup_boot_dir() {
- local boot_dir=$1
- local dir=${boot_dir}
-
- mkdir -p "${dir}"
- [[ ! -L ${dir}/boot ]] && ln -s . "${dir}/boot"
- dir="${dir}/grub"
- if [[ ! -e ${dir} ]] ; then
- mkdir "${dir}" || die "${dir} does not exist!"
- fi
-
- # change menu.lst to grub.conf
- if [[ ! -e ${dir}/grub.conf ]] && [[ -e ${dir}/menu.lst ]] ; then
- mv -f "${dir}"/menu.lst "${dir}"/grub.conf
- ewarn
- ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
- ewarn
- fi
-
- if [[ ! -e ${dir}/menu.lst ]]; then
- einfo "Linking from new grub.conf name to menu.lst"
- ln -snf grub.conf "${dir}"/menu.lst
- fi
-
- if [[ ! -e ${dir}/grub.conf ]] ; then
- s="${ROOT}/usr/share/doc/${PF}/grub.conf.gentoo"
- [[ -e "${s}" ]] && cat "${s}" >${dir}/grub.conf
- [[ -e "${s}.gz" ]] && zcat "${s}.gz" >${dir}/grub.conf
- [[ -e "${s}.bz2" ]] && bzcat "${s}.bz2" >${dir}/grub.conf
- fi
-
- einfo "Grub has been installed to ${boot_dir} successfully."
-}
-
-pkg_postinst() {
- if [[ -n ${DONT_MOUNT_BOOT} ]]; then
- elog "WARNING: you have DONT_MOUNT_BOOT in effect, so you must apply"
- elog "the following instructions for your /boot!"
- elog "Neglecting to do so may cause your system to fail to boot!"
- elog
- else
- setup_boot_dir "${ROOT}"/boot
- # Trailing output because if this is run from pkg_postinst, it gets mixed into
- # the other output.
- einfo ""
- fi
- elog "To interactively install grub files to another device such as a USB"
- elog "stick, just run the following and specify the directory as prompted:"
- elog " emerge --config =${PF}"
- elog "Alternately, you can export GRUB_ALT_INSTALLDIR=/path/to/use to tell"
- elog "grub where to install in a non-interactive way."
-
-}
-
-pkg_config() {
- local dir
- if [ ! -d "${GRUB_ALT_INSTALLDIR}" ]; then
- einfo "Enter the directory where you want to setup grub:"
- read dir
- else
- dir="${GRUB_ALT_INSTALLDIR}"
- fi
- setup_boot_dir "${dir}"
-}
diff --git a/sys-boot/grub/grub-1.98-r10.ebuild b/sys-boot/grub/grub-1.98-r10.ebuild
deleted file mode 100644
index bc0710a..0000000
--- a/sys-boot/grub/grub-1.98-r10.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.98.ebuild,v 1.1 2010/03/10 19:47:34 vapier Exp $
-
-inherit mount-boot eutils flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/grub/trunk/grub"
- inherit autotools bzr
- SRC_URI=""
-else
- SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
- mirror://gentoo/${P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GRUB 2 boot loader"
-HOMEPAGE="http://www.gnu.org/software/grub/"
-
-LICENSE="GPL-3"
-use multislot && SLOT="2" || SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="custom-cflags truetype multislot static"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r5
- dev-libs/lzo
- truetype? (
- media-libs/freetype
- media-fonts/unifont
- )"
-DEPEND="${RDEPEND}
- dev-lang/ruby"
-PDEPEND="${PDEPEND}
- sys-boot/os-prober"
-PROVIDE="virtual/bootloader"
-
-export STRIP_MASK="*/grub/*/*.mod"
-QA_EXECSTACK="sbin/grub-probe sbin/grub-setup sbin/grub-mkdevicemap"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- bzr_src_unpack
- else
- unpack ${A}
- fi
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.98-genkernel.patch
- epatch "${FILESDIR}"/${PN}-1.97-vga-deprecated.patch
- epatch "${FILESDIR}"/${PN}-1.98-wallpaper-settings-support.patch
- # see Gentoo #302634
- epatch "${FILESDIR}"/${PN}-1.98-add-legacy-rootfs-detection.patch
-
- # Ubuntu and upstream patches
- epatch "${FILESDIR}"/ubuntu-upstream-${PV}/*.diff
-
- epatch_user
-
- # see Gentoo #321569
- epatch "${FILESDIR}"/${PN}-1.98-follow-dev-mapper-symlinks.patch
-
- # Genkernel doesn't support "single" for rescue mode
- # but rather init_opts=single
- epatch "${FILESDIR}"/${PN}-1.98-genkernel-initramfs-single.patch
-
- # autogen.sh does more than just run autotools
- # need to eautomake due to weirdness #296013
- if [[ ${PV} == "9999" ]] ; then
- sed -i \
- -e '/^\(auto\|ac\)/s:^:e:' \
- -e "s:^eautomake:`which automake`:" \
- autogen.sh
- (. ./autogen.sh) || die
- fi
-}
-
-src_compile() {
- use custom-cflags || unset CFLAGS CPPFLAGS LDFLAGS
- use static && append-ldflags -static
-
- econf \
- --disable-werror \
- --sbindir=/sbin \
- --bindir=/bin \
- --libdir=/$(get_libdir) \
- --disable-efiemu \
- $(use_enable truetype grub-mkfont)
- emake -j1 || die "making regular stuff"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
- if use multislot ; then
- sed -i "s:grub-install:grub2-install:" "${D}"/sbin/grub-install || die
- mv "${D}"/sbin/grub{,2}-install || die
- mv "${D}"/sbin/grub{,2}-set-default || die
- mv "${D}"/usr/share/info/grub{,2}.info || die
- fi
-
- # install /etc/default/grub
- cp "${FILESDIR}/grub2-default" grub
- dodir /etc/default
- insinto /etc/default
- doins grub
-
- # Install fonts setup hook
- exeinto /etc/grub.d
- doexe "${FILESDIR}/00_fonts"
- doexe "${FILESDIR}/05_distro_theme"
-
- dodir /boot/grub
- insinto /boot/grub
- newins "${FILESDIR}/default-splash-6.png" default-splash.png
- # keep backward compat
- dodir /usr/share/grub
- insinto /usr/share/grub
- newins "${FILESDIR}/default-splash-6.png" default-splash.png
-
-}
-
-setup_boot_dir() {
- local boot_dir=$1
- local dir=${boot_dir}/grub
-
- if [[ ! -e ${dir}/grub.cfg ]] ; then
- einfo "Running: grub-mkconfig -o '${dir}/grub.cfg'"
- grub-mkconfig -o "${dir}/grub.cfg"
- fi
-
- #local install=grub-install
- #use multislot && install="grub2-install --grub-setup=/bin/true"
- #einfo "Running: ${install} "
- #${install}
-}
-
-pkg_postinst() {
- if use multislot ; then
- elog "You have installed grub2 with USE=multislot, so to coexist"
- elog "with grub1, the grub2 install binary is named grub2-install."
- fi
- setup_boot_dir "${ROOT}"boot
-}
diff --git a/sys-boot/grub/grub-1.98-r9.ebuild b/sys-boot/grub/grub-1.98-r9.ebuild
deleted file mode 100644
index 43a8bf4..0000000
--- a/sys-boot/grub/grub-1.98-r9.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.98.ebuild,v 1.1 2010/03/10 19:47:34 vapier Exp $
-
-inherit mount-boot eutils flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/grub/trunk/grub"
- inherit autotools bzr
- SRC_URI=""
-else
- SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
- mirror://gentoo/${P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GRUB 2 boot loader"
-HOMEPAGE="http://www.gnu.org/software/grub/"
-
-LICENSE="GPL-3"
-use multislot && SLOT="2" || SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="custom-cflags debug truetype multislot static"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r5
- dev-libs/lzo
- truetype? (
- media-libs/freetype
- media-fonts/unifont
- )"
-DEPEND="${RDEPEND}
- dev-lang/ruby"
-PDEPEND="${PDEPEND}
- sys-boot/os-prober"
-PROVIDE="virtual/bootloader"
-
-export STRIP_MASK="*/grub/*/*.mod"
-QA_EXECSTACK="sbin/grub-probe sbin/grub-setup sbin/grub-mkdevicemap"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- bzr_src_unpack
- else
- unpack ${A}
- fi
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.98-genkernel.patch
- epatch "${FILESDIR}"/${PN}-1.97-vga-deprecated.patch
- epatch "${FILESDIR}"/${PN}-1.98-wallpaper-settings-support.patch
- # see Gentoo #302634
- epatch "${FILESDIR}"/${PN}-1.98-add-legacy-rootfs-detection.patch
-
- # Ubuntu and upstream patches
- epatch "${FILESDIR}"/ubuntu-upstream-${PV}/*.diff
-
- epatch_user
-
- # see Gentoo #321569
- epatch "${FILESDIR}"/${PN}-1.98-follow-dev-mapper-symlinks.patch
-
- # Genkernel doesn't support "single" for rescue mode
- # but rather init_opts=single
- epatch "${FILESDIR}"/${PN}-1.98-genkernel-initramfs-single.patch
-
- # autogen.sh does more than just run autotools
- # need to eautomake due to weirdness #296013
- if [[ ${PV} == "9999" ]] ; then
- sed -i \
- -e '/^\(auto\|ac\)/s:^:e:' \
- -e "s:^eautomake:`which automake`:" \
- autogen.sh
- (. ./autogen.sh) || die
- fi
-}
-
-src_compile() {
- use custom-cflags || unset CFLAGS CPPFLAGS LDFLAGS
- use static && append-ldflags -static
-
- econf \
- --disable-werror \
- --sbindir=/sbin \
- --bindir=/bin \
- --libdir=/$(get_libdir) \
- --disable-efiemu \
- $(use_enable truetype grub-mkfont) \
- $(use_enable debug mm-debug) \
- $(use_enable debug grub-emu) \
- $(use_enable debug grub-emu-usb) \
- $(use_enable debug grub-fstest)
- emake -j1 || die "making regular stuff"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
- if use multislot ; then
- sed -i "s:grub-install:grub2-install:" "${D}"/sbin/grub-install || die
- mv "${D}"/sbin/grub{,2}-install || die
- mv "${D}"/sbin/grub{,2}-set-default || die
- mv "${D}"/usr/share/info/grub{,2}.info || die
- fi
-
- # install /etc/default/grub
- cp "${FILESDIR}/grub2-default" grub
- dodir /etc/default
- insinto /etc/default
- doins grub
-
- # Install fonts setup hook
- exeinto /etc/grub.d
- doexe "${FILESDIR}/00_fonts"
- doexe "${FILESDIR}/05_distro_theme"
-
- dodir /boot/grub
- insinto /boot/grub
- newins "${FILESDIR}/default-splash-6.png" default-splash.png
- # keep backward compat
- dodir /usr/share/grub
- insinto /usr/share/grub
- newins "${FILESDIR}/default-splash-6.png" default-splash.png
-
-}
-
-setup_boot_dir() {
- local boot_dir=$1
- local dir=${boot_dir}/grub
-
- if [[ ! -e ${dir}/grub.cfg ]] ; then
- einfo "Running: grub-mkconfig -o '${dir}/grub.cfg'"
- grub-mkconfig -o "${dir}/grub.cfg"
- fi
-
- #local install=grub-install
- #use multislot && install="grub2-install --grub-setup=/bin/true"
- #einfo "Running: ${install} "
- #${install}
-}
-
-pkg_postinst() {
- if use multislot ; then
- elog "You have installed grub2 with USE=multislot, so to coexist"
- elog "with grub1, the grub2 install binary is named grub2-install."
- fi
- setup_boot_dir "${ROOT}"boot
-}