aboutsummaryrefslogtreecommitdiff
path: root/fonts
diff options
context:
space:
mode:
authorwiktor w brodlo <wiktor@brodlo.net>2011-06-15 16:59:54 +0000
committerwiktor w brodlo <wiktor@brodlo.net>2011-06-15 16:59:54 +0000
commit2590d96369d0217e31dc2812690dde61dac417b5 (patch)
tree82276f787b08a28548e342c7921486f1acefab9f /fonts
parentfirst commit (diff)
downloadanaconda-2590d96369d0217e31dc2812690dde61dac417b5.tar.gz
anaconda-2590d96369d0217e31dc2812690dde61dac417b5.tar.bz2
anaconda-2590d96369d0217e31dc2812690dde61dac417b5.zip
Initial import from Sabayon (ver 0.9.9.56)
Diffstat (limited to 'fonts')
-rw-r--r--fonts/Makefile.am39
-rw-r--r--fonts/screenfont-alpha.gzbin0 -> 4893 bytes
-rw-r--r--fonts/screenfont-i386.gzbin0 -> 5507 bytes
-rw-r--r--fonts/screenfont-ia64.gzbin0 -> 3821 bytes
-rw-r--r--fonts/screenfont-ppc.gzbin0 -> 5305 bytes
-rw-r--r--fonts/screenfont-sparc.gzbin0 -> 6455 bytes
-rw-r--r--fonts/screenfont-x86_64.gzbin0 -> 5473 bytes
-rwxr-xr-xfonts/updfonts11
8 files changed, 50 insertions, 0 deletions
diff --git a/fonts/Makefile.am b/fonts/Makefile.am
new file mode 100644
index 0000000..5ad0197
--- /dev/null
+++ b/fonts/Makefile.am
@@ -0,0 +1,39 @@
+# fonts/Makefile.am for anaconda
+#
+# Copyright (C) 2009 Red Hat, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published
+# by the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# Author: David Cantrell <dcantrell@redhat.com>
+
+if IS_FONT_ARCH
+fontsdir = $(datadir)/$(PACKAGE_NAME)
+dist_fonts_DATA = screenfont-$(ARCH).gz
+endif
+
+EXTRA_DIST = screenfont-*.gz updfonts
+
+MAINTAINERCLEANFILES = Makefile.in
+
+i386:
+ ./updfonts i386
+
+alpha:
+ ./updfonts alpha
+
+sparc:
+ ./updfonts sparc
+
+ia64:
+ ./updfonts ia64
diff --git a/fonts/screenfont-alpha.gz b/fonts/screenfont-alpha.gz
new file mode 100644
index 0000000..b12001b
--- /dev/null
+++ b/fonts/screenfont-alpha.gz
Binary files differ
diff --git a/fonts/screenfont-i386.gz b/fonts/screenfont-i386.gz
new file mode 100644
index 0000000..fa88be1
--- /dev/null
+++ b/fonts/screenfont-i386.gz
Binary files differ
diff --git a/fonts/screenfont-ia64.gz b/fonts/screenfont-ia64.gz
new file mode 100644
index 0000000..ef0569c
--- /dev/null
+++ b/fonts/screenfont-ia64.gz
Binary files differ
diff --git a/fonts/screenfont-ppc.gz b/fonts/screenfont-ppc.gz
new file mode 100644
index 0000000..036064c
--- /dev/null
+++ b/fonts/screenfont-ppc.gz
Binary files differ
diff --git a/fonts/screenfont-sparc.gz b/fonts/screenfont-sparc.gz
new file mode 100644
index 0000000..0c38d3b
--- /dev/null
+++ b/fonts/screenfont-sparc.gz
Binary files differ
diff --git a/fonts/screenfont-x86_64.gz b/fonts/screenfont-x86_64.gz
new file mode 100644
index 0000000..fcaee50
--- /dev/null
+++ b/fonts/screenfont-x86_64.gz
Binary files differ
diff --git a/fonts/updfonts b/fonts/updfonts
new file mode 100755
index 0000000..10b74c1
--- /dev/null
+++ b/fonts/updfonts
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+ARCH=$1
+if [ -z "$ARCH" ]; then
+ echo "usage: $0 <arch>"
+ exit 1
+fi
+
+setfont latarcyrheb-sun16
+../utils/snarffont > screenfont-$ARCH
+gzip -9 -f screenfont-$ARCH