summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Arteaga <andyspiros@gmail.com>2011-08-22 20:01:02 +0200
committerAndrea Arteaga <andyspiros@gmail.com>2011-08-22 20:01:02 +0200
commit587860cfcdc6845385bc89a7e49bca90caaff4a1 (patch)
tree40c901a4c2be8bf89e20a45e29130f8488176923
parentReintroduced fftw 3D actions. (diff)
downloadauto-numerical-bench-587860cfcdc6845385bc89a7e49bca90caaff4a1.tar.gz
auto-numerical-bench-587860cfcdc6845385bc89a7e49bca90caaff4a1.tar.bz2
auto-numerical-bench-587860cfcdc6845385bc89a7e49bca90caaff4a1.zip
Added copyright notice.
-rwxr-xr-xexec.py19
-rw-r--r--numbench/PortageUtils.py17
-rw-r--r--numbench/basemodule.py17
-rw-r--r--numbench/benchchilds.py17
-rw-r--r--numbench/benchconfig.py17
-rw-r--r--numbench/benchload.py17
-rw-r--r--numbench/benchpkgconfig.py17
-rw-r--r--numbench/benchprint.py17
-rw-r--r--numbench/benchutils.py17
-rw-r--r--numbench/blas.py17
-rw-r--r--numbench/blas_accuracy.py17
-rw-r--r--numbench/blasbase.py17
-rw-r--r--numbench/btlbase.py17
-rw-r--r--numbench/cblas.py17
-rw-r--r--numbench/fftw.py17
-rw-r--r--numbench/htmlreport.py17
-rw-r--r--numbench/lapack.py17
-rw-r--r--numbench/lapack_accuracy.py17
-rwxr-xr-xnumbench/main.py18
-rw-r--r--numbench/metis.py17
-rw-r--r--numbench/scalapack.py17
-rw-r--r--numbench/testdescr.py17
-rw-r--r--setup.py18
23 files changed, 395 insertions, 0 deletions
diff --git a/exec.py b/exec.py
index cb4d1eb..c3b7eda 100755
--- a/exec.py
+++ b/exec.py
@@ -1,2 +1,21 @@
#!/usr/bin/python2
+
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
import numbench.main \ No newline at end of file
diff --git a/numbench/PortageUtils.py b/numbench/PortageUtils.py
index 0aad4b1..f4f6d64 100644
--- a/numbench/PortageUtils.py
+++ b/numbench/PortageUtils.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import commands as cmd
import subprocess as sp
import os, portage, shlex
diff --git a/numbench/basemodule.py b/numbench/basemodule.py
index 332e528..bf55981 100644
--- a/numbench/basemodule.py
+++ b/numbench/basemodule.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
from os.path import join as pjoin, basename, dirname
import subprocess as sp
import shlex, os
diff --git a/numbench/benchchilds.py b/numbench/benchchilds.py
index 87e9ac9..1686639 100644
--- a/numbench/benchchilds.py
+++ b/numbench/benchchilds.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
try:
copy = procs
del copy
diff --git a/numbench/benchconfig.py b/numbench/benchconfig.py
index f5f30d4..865dfcc 100644
--- a/numbench/benchconfig.py
+++ b/numbench/benchconfig.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import sys, os, time
from os.path import join as pjoin
import subprocess as sp
diff --git a/numbench/benchload.py b/numbench/benchload.py
index f226656..8363862 100644
--- a/numbench/benchload.py
+++ b/numbench/benchload.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import sys, shlex, threading, time, subprocess as sp
class PrintLoad(threading.Thread):
diff --git a/numbench/benchpkgconfig.py b/numbench/benchpkgconfig.py
index 69fddf6..9051cb4 100644
--- a/numbench/benchpkgconfig.py
+++ b/numbench/benchpkgconfig.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import os
from os.path import join as pjoin, basename, dirname, exists
import subprocess as sp
diff --git a/numbench/benchprint.py b/numbench/benchprint.py
index beb6fe8..3f3e577 100644
--- a/numbench/benchprint.py
+++ b/numbench/benchprint.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
try:
needsinitialization = not initialized
except NameError:
diff --git a/numbench/benchutils.py b/numbench/benchutils.py
index a15d9c3..1018d72 100644
--- a/numbench/benchutils.py
+++ b/numbench/benchutils.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import os, sys, shutil, string, random
import subprocess as sp
diff --git a/numbench/blas.py b/numbench/blas.py
index f6193ef..afdaa19 100644
--- a/numbench/blas.py
+++ b/numbench/blas.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import blasbase
class Module(blasbase.BLASBase):
diff --git a/numbench/blas_accuracy.py b/numbench/blas_accuracy.py
index de90ffa..9996b89 100644
--- a/numbench/blas_accuracy.py
+++ b/numbench/blas_accuracy.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import subprocess as sp
import shlex, os
from os.path import join as pjoin
diff --git a/numbench/blasbase.py b/numbench/blasbase.py
index f7c1d33..c08987f 100644
--- a/numbench/blasbase.py
+++ b/numbench/blasbase.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import os, btlbase
import subprocess as sp
import shlex
diff --git a/numbench/btlbase.py b/numbench/btlbase.py
index 26b50f4..5fac13a 100644
--- a/numbench/btlbase.py
+++ b/numbench/btlbase.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import sys, os, shlex
import subprocess as sp
from os.path import join as pjoin
diff --git a/numbench/cblas.py b/numbench/cblas.py
index c78867c..ad33663 100644
--- a/numbench/cblas.py
+++ b/numbench/cblas.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import blasbase
class Module(blasbase.BLASBase):
diff --git a/numbench/fftw.py b/numbench/fftw.py
index 8d583b5..ec30508 100644
--- a/numbench/fftw.py
+++ b/numbench/fftw.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import os, btlbase
class Module(btlbase.BTLBase):
diff --git a/numbench/htmlreport.py b/numbench/htmlreport.py
index 212b88b..a42f579 100644
--- a/numbench/htmlreport.py
+++ b/numbench/htmlreport.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import time
from os.path import join as pjoin, basename
diff --git a/numbench/lapack.py b/numbench/lapack.py
index 2f48150..f440903 100644
--- a/numbench/lapack.py
+++ b/numbench/lapack.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import os, btlbase
import subprocess as sp
import shlex
diff --git a/numbench/lapack_accuracy.py b/numbench/lapack_accuracy.py
index 5e3d4c1..f4737c0 100644
--- a/numbench/lapack_accuracy.py
+++ b/numbench/lapack_accuracy.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import subprocess as sp
import shlex, os
from os.path import join as pjoin
diff --git a/numbench/main.py b/numbench/main.py
index f0fe489..e0f5857 100755
--- a/numbench/main.py
+++ b/numbench/main.py
@@ -1,5 +1,23 @@
#! /usr/bin/env python2
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
import os, sys, signal, shlex, shutil, time
from os.path import join as pjoin
import subprocess as sp
diff --git a/numbench/metis.py b/numbench/metis.py
index 8e6940f..aad3e68 100644
--- a/numbench/metis.py
+++ b/numbench/metis.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import os, shlex, numpy as np, subprocess as sp
from os.path import realpath, exists as pexists, join as pjoin
from random import randint
diff --git a/numbench/scalapack.py b/numbench/scalapack.py
index 827417a..c639ef9 100644
--- a/numbench/scalapack.py
+++ b/numbench/scalapack.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
import os, btlbase, shlex, subprocess as sp
numproc = 4
diff --git a/numbench/testdescr.py b/numbench/testdescr.py
index 1185c01..3db919b 100644
--- a/numbench/testdescr.py
+++ b/numbench/testdescr.py
@@ -1,3 +1,20 @@
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
testdescr = {
# (C)BLAS
'axpy' : 'y = a*x + y',
diff --git a/setup.py b/setup.py
index d7a98a1..d850b17 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,23 @@
#!/usr/bin/env python
+#=====================================================
+# Copyright (C) 2011 Andrea Arteaga <andyspiros@gmail.com>
+#=====================================================
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
from distutils.core import setup
setup(name='Numbench',