summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-02-06 01:32:03 +0000
committerMike Frysinger <vapier@gentoo.org>2010-02-06 01:32:03 +0000
commit5cac7652b1653c3dc16d43a5facae52791319a62 (patch)
treeb24f255c8a1f4f1bea9eaad0c0ee397e1032112d
parentsync shadow/passwd files #301949 by Paweł Hajdan (diff)
downloadbaselayout-5cac7652b1653c3dc16d43a5facae52791319a62.tar.gz
baselayout-5cac7652b1653c3dc16d43a5facae52791319a62.tar.bz2
baselayout-5cac7652b1653c3dc16d43a5facae52791319a62.zip
ignore touch failures when doing layout on live fs #232823
svn path=/trunk/; revision=3172
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6761e125..aa5e6c8d 100644
--- a/Makefile
+++ b/Makefile
@@ -49,8 +49,9 @@ install:
layout:
# Create base filesytem layout
for x in $(KEEP_DIRS) ; do \
+ test -e $(DESTDIR)$$x/.keep && continue ; \
$(INSTALL_DIR) $(DESTDIR)$$x || exit $$? ; \
- touch $(DESTDIR)$$x/.keep || exit $$? ; \
+ touch $(DESTDIR)$$x/.keep || echo "ignoring touch failure; mounted fs?" ; \
done
# Special dirs
install -m 0700 -d $(DESTDIR)/root || exit $$?