summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-18 16:32:52 +0100
committerJustin Lecher <jlec@gentoo.org>2014-11-18 16:32:52 +0100
commit14f1b20faf3889afd3830c80814f575273f9fa4a (patch)
treef743678c6a43080bc39e3668047816d381ffbc73 /app-admin/cctrl
parentdev-python/pycclib: New dep (diff)
downloadbetagarden-14f1b20faf3889afd3830c80814f575273f9fa4a.tar.gz
betagarden-14f1b20faf3889afd3830c80814f575273f9fa4a.tar.bz2
betagarden-14f1b20faf3889afd3830c80814f575273f9fa4a.zip
app-admin/cctrl: Bump to new python eclasses; Version Bump
Package-Manager: portage-2.2.14
Diffstat (limited to 'app-admin/cctrl')
-rw-r--r--app-admin/cctrl/ChangeLog8
-rw-r--r--app-admin/cctrl/Manifest2
-rw-r--r--app-admin/cctrl/cctrl-1.14.2.ebuild35
-rw-r--r--app-admin/cctrl/cctrl-1.2.0-r1.ebuild26
-rw-r--r--app-admin/cctrl/files/cctrl-1.14.2-tests.patch16
-rw-r--r--app-admin/cctrl/metadata.xml8
6 files changed, 63 insertions, 32 deletions
diff --git a/app-admin/cctrl/ChangeLog b/app-admin/cctrl/ChangeLog
index 7c21eb4..f0e65d4 100644
--- a/app-admin/cctrl/ChangeLog
+++ b/app-admin/cctrl/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for app-admin/cctrl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*cctrl-1.14.2 (18 Nov 2014)
+
+ 18 Nov 2014; Justin Lecher <jlec@gentoo.org> -cctrl-1.2.0-r1.ebuild,
+ +cctrl-1.14.2.ebuild, +files/cctrl-1.14.2-tests.patch, metadata.xml:
+ Bump to new python eclasses; Version Bump
+
*cctrl-1.2.0-r1 (14 Dec 2012)
14 Dec 2012; Michał Górny <mgorny@gentoo.org> +cctrl-1.2.0-r1.ebuild,
diff --git a/app-admin/cctrl/Manifest b/app-admin/cctrl/Manifest
index dfc34a0..eda78af 100644
--- a/app-admin/cctrl/Manifest
+++ b/app-admin/cctrl/Manifest
@@ -1 +1 @@
-DIST cctrl-1.2.0.tar.bz2 13533 SHA256 81c9e5ee3e4ec2167d2f223300f623843b17408292d718893c443df72a185b81
+DIST cctrl-1.14.2.tar.gz 142117 SHA256 d78f5b10e4390423680de105fc6a41f50cfbb750867624dbdf067ec11fccf603 SHA512 02426abc62243ea53d9eae1715de5681e3254cf2fee166afee599f1f6bc34b4318839f60bee9e92a74cb067d2f71bffcb7a1fdd1f2580ac449e2c5d06af22ed2 WHIRLPOOL b5efbebd032ff6c3e0259ccf755893aa6ebd64b479e457593d928dca8065f5f07435951f8b356d48ba460408ca31b990a2a38754b1fc0df70f0883bb8504a2fb
diff --git a/app-admin/cctrl/cctrl-1.14.2.ebuild b/app-admin/cctrl/cctrl-1.14.2.ebuild
new file mode 100644
index 0000000..9b6458d
--- /dev/null
+++ b/app-admin/cctrl/cctrl-1.14.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="cloudControl command line utilities"
+HOMEPAGE="http://cloudcontrol.com"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=dev-python/pycclib-1.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+python_test() {
+ nosetests
+}
diff --git a/app-admin/cctrl/cctrl-1.2.0-r1.ebuild b/app-admin/cctrl/cctrl-1.2.0-r1.ebuild
deleted file mode 100644
index f69d1f9..0000000
--- a/app-admin/cctrl/cctrl-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="cloudControl command line utilities"
-HOMEPAGE="http://cloudcontrol.com"
-SRC_URI="http://launchpad.net/cctrl/trunk/${PV}/+download/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/paramiko
- >=dev-python/pycclib-1.0.1
- virtual/python-argparse"
-RDEPEND="${DEPEND}"
-
-DOCS="README"
diff --git a/app-admin/cctrl/files/cctrl-1.14.2-tests.patch b/app-admin/cctrl/files/cctrl-1.14.2-tests.patch
new file mode 100644
index 0000000..c6c7fe2
--- /dev/null
+++ b/app-admin/cctrl/files/cctrl-1.14.2-tests.patch
@@ -0,0 +1,16 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 1f0f818..f8abc93 100644
+--- a/setup.py
++++ b/setup.py
+@@ -66,7 +66,7 @@ else:
+ extra_options = dict(
+ scripts=srcscripts,
+ package_data={"cctrl": ["cacerts.txt"]},
+- packages=find_packages()
++ packages=find_packages(exclude=['tests']),
+ )
+
+ setup(
diff --git a/app-admin/cctrl/metadata.xml b/app-admin/cctrl/metadata.xml
index 91bcbcf..894dc83 100644
--- a/app-admin/cctrl/metadata.xml
+++ b/app-admin/cctrl/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>matsuu@gentoo.org</email>
- <name>MATSUU Takuto</name>
- </maintainer>
+ <maintainer>
+ <email>matsuu@gentoo.org</email>
+ <name>MATSUU Takuto</name>
+ </maintainer>
</pkgmetadata>