summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2014-06-09 15:40:52 +0200
committerSebastian Pipping <sebastian@pipping.org>2014-06-09 15:40:52 +0200
commit05a91d89cab7787dc5471a0e39428fdc63fb6f84 (patch)
tree8fd6a016a92886d3ada44470bbfc5bcd2e105ba3 /net-dns
parentapp-emulation/lxc: Drop installation of non existing TODO file; import tree c... (diff)
downloadbetagarden-05a91d89cab7787dc5471a0e39428fdc63fb6f84.tar.gz
betagarden-05a91d89cab7787dc5471a0e39428fdc63fb6f84.tar.bz2
betagarden-05a91d89cab7787dc5471a0e39428fdc63fb6f84.zip
net-dns/inadyn-mt: 02.24.40
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/inadyn-mt/inadyn-mt-02.24.40.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-dns/inadyn-mt/inadyn-mt-02.24.40.ebuild b/net-dns/inadyn-mt/inadyn-mt-02.24.40.ebuild
new file mode 100644
index 0000000..0b47aa7
--- /dev/null
+++ b/net-dns/inadyn-mt/inadyn-mt-02.24.40.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit user eutils
+
+MY_P="${PN}.v.${PV}"
+DESCRIPTION="Dynamic DNS (DynDNS) Update daemon in C that supports multiple services"
+HOMEPAGE="http://sourceforge.net/projects/inadyn-mt"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libao"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ enewuser ${PN}
+}
+
+src_prepare() {
+ rm -R bin || die
+
+ # inadyn-mt comes with outdated inadyn man pages - see inadyn-mt bug 2445206
+ rm man/inadyn.8
+ rm man/inadyn.conf.5
+}
+
+src_install() {
+ # dodir /usr/share || die
+ emake DESTDIR="${D}" INSTALL_PREFIX="${D}"/usr/share install || die
+
+ dodoc ChangeLog NEWS README NOTICE AUTHORS || die
+ dohtml readme.html || die
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ insinto /etc
+ doins "${FILESDIR}"/${PN}.conf || die
+}
+
+pkg_postinst() {
+ elog "You will need to edit /etc/inadyn-mt.conf before running inadyn-mt"
+ elog "for the first time. The format is basically the same as the"
+ elog "command line options; see inadyn-mt and inadyn-mt.conf manpages."
+}