summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-graph')
-rw-r--r--dev-python/python-graph/Manifest2
-rw-r--r--dev-python/python-graph/python-graph-1.7.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-graph/Manifest b/dev-python/python-graph/Manifest
new file mode 100644
index 0000000..0c33a76
--- /dev/null
+++ b/dev-python/python-graph/Manifest
@@ -0,0 +1,2 @@
+DIST python-graph-1.7.0.tar.bz2 189979 RMD160 43f494d9e6fa0236a5b9b00353697e344508a807 SHA1 0808a441ba275f880e39144ae37f7627fd451116 SHA256 8a04eb1d75e16232fe8e476a9413e00f40737cb0c4aa7c4b41d97dfe3fbd3a2e
+EBUILD python-graph-1.7.0.ebuild 715 RMD160 e8299360cfa8d3fd0622ba5fe9606521350fa2b3 SHA1 0cb762d84eb424f8b415abdfbffa66b65fff619e SHA256 d084eb3bb2efe48cbbbacf80f55f049714031f556031201819cbbf6514230cb5
diff --git a/dev-python/python-graph/python-graph-1.7.0.ebuild b/dev-python/python-graph/python-graph-1.7.0.ebuild
new file mode 100644
index 0000000..b34566b
--- /dev/null
+++ b/dev-python/python-graph/python-graph-1.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Library for working with graphs in Python"
+HOMEPAGE="http://code.google.com/p/python-graph/"
+SRC_URI="http://python-graph.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="" # TODO tests
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ for subdir in core dot ; do
+ cd "${S}"/${subdir}
+ distutils_src_compile
+ done
+}
+
+src_install() {
+ for subdir in core dot ; do
+ cd "${S}"/${subdir}
+ distutils_src_install
+ done
+ cd "${S}"
+
+ insinto /usr/share/${PF}/doc
+ doins docs/* || die 'doins failed'
+
+ dodoc README Changelog || die 'dodoc failed'
+}