diff options
author | Ulrich Müller <ulm@gentoo.org> | 2020-01-10 01:32:39 +0100 |
---|---|---|
committer | Ulrich Müller <ulm@gentoo.org> | 2020-01-12 10:21:25 +0100 |
commit | 5a59efa3a33383bf41466296c765d6ba096ebc25 (patch) | |
tree | dc076d05cb19579cd616079f5b022a1b1e33751f /Makefile | |
parent | appendices/contributing: Use path from root node for internal link. (diff) | |
download | devmanual-5a59efa3a33383bf41466296c765d6ba096ebc25.tar.gz devmanual-5a59efa3a33383bf41466296c765d6ba096ebc25.tar.bz2 devmanual-5a59efa3a33383bf41466296c765d6ba096ebc25.zip |
Makefile: Run tidy also on html files generated from eclass manpages.
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -4,6 +4,7 @@ XMLS := $(shell find . -name .git -prune -o -type f -name 'text.xml' -print) SVGS := $(shell find . -name .git -prune -o -type f -name '*.svg' -print) HTMLS := $(subst text.xml,index.html,$(XMLS)) +ECLASS_HTMLS := $(wildcard eclass-reference/*/index.html) IMAGES := $(patsubst %.svg,%.png,$(SVGS)) all: prereq validate $(HTMLS) $(IMAGES) documents.js @@ -52,9 +53,9 @@ validate: prereq # Run app-text/tidy-html5 on the output to detect mistakes. # We have to loop through them because otherwise tidy won't # tell you which file contains a mistake. -tidy: $(HTMLS) +tidy: $(HTMLS) $(ECLASS_HTMLS) @status=0; \ - for f in $(HTMLS); do \ + for f in $^; do \ output=$$(tidy -q -errors --drop-empty-elements no $${f} 2>&1) \ || { status=$$?; echo "Failed on $${f}:"; echo "$${output}"; }; \ done; \ |