aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-12-06 19:56:19 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-12-19 15:53:18 -0500
commit7183f91296cf25741bb31b77f88eb57698782878 (patch)
treece61801fecccf97593e8d3e77270f17ad0b25ec9 /Makefile
parentUse Gentoo-hosted minified version (diff)
downloaddevmanual-7183f91296cf25741bb31b77f88eb57698782878.tar.gz
devmanual-7183f91296cf25741bb31b77f88eb57698782878.tar.bz2
devmanual-7183f91296cf25741bb31b77f88eb57698782878.zip
Make text.xml files a dependency for documents.js, update search_index.py
Updates to any text.xml should trigger a rebuild of documents.js. The Makefile is updated to reflect that. And the updated search_index.py that takes a list of files as arguments. (This commit message is written by the committer, not the author.) Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ac024b6..90990a8 100644
--- a/Makefile
+++ b/Makefile
@@ -19,8 +19,11 @@ prereq:
{ echo "dev-libs/libxml2 is required" >&2;\
exit 1; }
-index:
- @./search_index.py text.xml > documents.js
+# Since search_index.py rebuilds the index from scratch instead of
+# updating it, we pass it the names of ALL prerequisites ($^) and not
+# just the names of the ones that are new ($?).
+documents.js: $(XMLS)
+ ./search_index.py $^ > documents.js
%.png : %.svg
convert $< $@