aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-01-16 22:49:28 +0100
committerUlrich Müller <ulm@gentoo.org>2022-01-16 22:49:28 +0100
commitdc82d8e45d48814b94458a3ce4edc396919a1d08 (patch)
treeb3bd97fd6a68105a93c18cdb3f9597268a6eb292 /Makefile
parentgeneral-concepts/pic: trivial grammar fix (+ "the") (diff)
downloaddevmanual-dc82d8e45d48814b94458a3ce4edc396919a1d08.tar.gz
devmanual-dc82d8e45d48814b94458a3ce4edc396919a1d08.tar.bz2
devmanual-dc82d8e45d48814b94458a3ce4edc396919a1d08.zip
Makefile: Simplify recipes for validate and tidy targets
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 3409931..2c7952a 100644
--- a/Makefile
+++ b/Makefile
@@ -83,8 +83,8 @@ install: all
fi
validate:
- @xmllint --noout --dtdvalid devbook.dtd $(XMLS) \
- && echo "xmllint validation successful"
+ @xmllint --noout --dtdvalid devbook.dtd $(XMLS)
+ @echo "xmllint validation successful"
# Run app-text/htmltidy on the output to detect mistakes.
# We have to loop through them because otherwise tidy won't
@@ -96,8 +96,8 @@ tidy: $(HTMLS) $(ECLASS_HTMLS)
| tidy -q -errors --drop-empty-elements no 2>&1) \
|| { status=$$?; echo "Failed on $${f}:"; echo "$${output}"; }; \
done; \
- test $${status} -eq 0 && echo "tidy validation successful"; \
exit $${status}
+ @echo "tidy validation successful"
check: validate tidy