aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-01-18 13:14:33 +0100
committerUlrich Müller <ulm@gentoo.org>2021-01-18 13:14:33 +0100
commite58b9a9894bb6fd551a43e9d71c838fa8bbf6c0e (patch)
tree144833444f08029fcea3ab2e9d786ae3940eeb46 /Makefile
parentebuild-maintenance/removal: Process for virtual removal (diff)
downloaddevmanual-e58b9a9894bb6fd551a43e9d71c838fa8bbf6c0e.tar.gz
devmanual-e58b9a9894bb6fd551a43e9d71c838fa8bbf6c0e.tar.bz2
devmanual-e58b9a9894bb6fd551a43e9d71c838fa8bbf6c0e.zip
Makefile: Add dist target
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 13f2bb9..e516e15 100644
--- a/Makefile
+++ b/Makefile
@@ -91,9 +91,16 @@ tidy: $(HTMLS) $(ECLASS_HTMLS)
test $${status} -eq 0 && echo "tidy validation successful"; \
exit $${status}
+dist:
+ COMMITDATE=$$(TZ=UTC git log -1 --pretty="format:%cd" \
+ --date="format-local:%Y%m%d"); \
+ TARBALL="devmanual-0_pre$${COMMITDATE}.tar.xz"; \
+ echo "Creating tarball: $${TARBALL}"; \
+ git archive --format=tar --prefix=devmanual/ HEAD | xz > $${TARBALL}
+
clean:
@rm -f $(HTMLS) $(IMAGES) documents.js .depend
-.PHONY: all prereq build install validate tidy clean
+.PHONY: all prereq build install validate tidy dist clean
-include .depend