summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-08 01:25:49 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-08 01:25:49 +0200
commit2b4bed339eb5bfc59d770bb830fd7299b244ee9b (patch)
treeee44faece16203466f631b64aa3ef3ebae11ec2c /Makefile
downloademacs-eix-2b4bed339eb5bfc59d770bb830fd7299b244ee9b.tar.gz
emacs-eix-2b4bed339eb5bfc59d770bb830fd7299b244ee9b.tar.bz2
emacs-eix-2b4bed339eb5bfc59d770bb830fd7299b244ee9b.zip
*: port0.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..2d92198
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+EMACS := emacs
+FIND := find
+
+EMACFLAGS := --batch -q --no-site-file
+EMACSCMD = $(EMACS) $(EMACFLAGS)
+
+
+.PHONY: all
+all: clean compile
+
+.PHONY: clean
+clean:
+ $(FIND) $(PWD) -iname "*.elc" -delete
+
+%.elc:
+ $(EMACSCMD) --eval "(byte-compile-file \"$(*).el\" 0)"
+
+.PHONY: compile
+compile: eix.elc
+
+.PHONY: install
+install: compile
+ $(EMACSCMD) \
+ --eval "(require 'package)" --eval "(package-install-file \"$(PWD)\")"