aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-05-16 19:05:25 +0300
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-05-16 19:05:25 +0300
commit8d172dbe6d443bed666745066cb05818b776caf1 (patch)
treed308d98147c8b37ac3948b62004aac18130a630b
parentdbus-glib-0.86 cross compilation fix (diff)
downloadembedded-cross-8d172dbe6d443bed666745066cb05818b776caf1.tar.gz
embedded-cross-8d172dbe6d443bed666745066cb05818b776caf1.tar.bz2
embedded-cross-8d172dbe6d443bed666745066cb05818b776caf1.zip
fix libxml2 compilation with USE=-python
Signed-off-by: Maksim 'max_posedon' Melnikau <maxposedon@gmail.com>
-rw-r--r--dev-libs/libxml2/Manifest2
-rw-r--r--dev-libs/libxml2/libxml2-2.7.7.ebuild181
2 files changed, 183 insertions, 0 deletions
diff --git a/dev-libs/libxml2/Manifest b/dev-libs/libxml2/Manifest
index 6ec63c3..db48228 100644
--- a/dev-libs/libxml2/Manifest
+++ b/dev-libs/libxml2/Manifest
@@ -3,6 +3,8 @@ AUX libxml2-2.7.3-cross-python-configure.patch 2666 RMD160 b73cd082fc2778781a4d7
AUX libxml2-2.7.3-cross-python.patch 296 RMD160 432d71ed54950b2159f878ab4a858fd777a3370f SHA1 1ae84bfc6622fb20754d4c8f0f59e7b8740d9a8f SHA256 9d9f9966807e6cc92474afcc24f3a4a9eabdb5fb844047749042368c4e7e69c8
AUX libxml2-2.7.3-printf-rename.patch 17280 RMD160 920065d543127026c526f00856e9a2a8fb41e42d SHA1 9a9515a1ea7c7313aa8e6bb607f987560504aaed SHA256 a7206cbd8a675e2d944f330255d648502d143472a2d96daa4753e422614b8520
DIST libxml2-2.7.3.tar.gz 4789450 RMD160 14018347531fd135366cee9fd9d760a1988546e2 SHA1 fd4e427fb55c977876bc74c0e552ef7d3d794a07 SHA256 432464d8c9bd8060d9c1fdef1cfa75803c1a363ceac20b21f8c7e34e056e5a98
+DIST libxml2-2.7.7.tar.gz 4868502 RMD160 9f72c778c3e9e348a68eada0cf624c012658c085 SHA1 8592824a2788574a172cbddcdc72f734ff87abe3 SHA256 af5b781418ba4fff556fa43c50086658ea8a2f31909c2b625c2ce913a1d9eb68
DIST xsts-2002-01-16.tar.gz 6894439 RMD160 e8905fe1451a1c367b0104af24edca73bad1db08 SHA1 ca6344e6c47f8c28231f5b213d0c8deb0311a409 SHA256 55e5c08db29946a91ea8e70e8f2418d3fd30d8b6777941dfba7f54726ffd9914
DIST xsts-2004-01-14.tar.gz 2761085 RMD160 faff2d7826e47ae9968564bc83dab1b54c5e4bf6 SHA1 5896c2aa2cda464246306c5cf0577ed506eefaab SHA256 09bdf9f81f381ebf9bc158a9472e498e896f7a02eb7461146e9abe1b9493ca17
EBUILD libxml2-2.7.3-r2.ebuild 4622 RMD160 43a52d926c6c25e8db3e918180a26dfa657877a9 SHA1 97846b88da832ca7bf36cfb3105755ec8ac27e3a SHA256 edaf8c7cf5def4a325d8acd758d2bf203b1837b2b2675944cf933616ee4afab5
+EBUILD libxml2-2.7.7.ebuild 4744 RMD160 d44380157ba66315290ddce5f14585c605302a20 SHA1 13111573a81ba7a82b5fbd0d5e0c8045776bae0d SHA256 23083cffe264b3f58c8825107bbd2cbd8e788be32c86ef8e61c9d8335e33512b
diff --git a/dev-libs/libxml2/libxml2-2.7.7.ebuild b/dev-libs/libxml2/libxml2-2.7.7.ebuild
new file mode 100644
index 0000000..a3c4ccc
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.7.7.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.7.ebuild,v 1.3 2010/04/07 21:16:18 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit libtool flag-o-matic eutils python
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="debug doc examples ipv6 python readline test"
+
+XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
+XSTS_NAME_1="xmlschema2002-01-16"
+XSTS_NAME_2="xmlschema2004-01-14"
+XSTS_TARBALL_1="xsts-2002-01-16.tar.gz"
+XSTS_TARBALL_2="xsts-2004-01-14.tar.gz"
+
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz
+ test? (
+ ${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
+ ${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2} )"
+
+RDEPEND="sys-libs/zlib
+ python? ( <dev-lang/python-3 )
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+src_unpack() {
+ # ${A} isn't used to avoid unpacking of test tarballs into $WORKDIR,
+ # as they are needed as tarballs in ${S}/xstc instead and not unpacked
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ if use test; then
+ cp "${DISTDIR}/${XSTS_TARBALL_1}" \
+ "${DISTDIR}/${XSTS_TARBALL_2}" \
+ "${S}"/xstc/ \
+ || die "Failed to install test tarballs"
+ fi
+}
+
+src_prepare() {
+ epunt_cxx
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # Python bindings are built/tested/installed manually.
+ sed -e "s/@PYTHON_SUBDIR@//" -i Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+
+ # --with-mem-debug causes unusual segmentation faults (bug #105120).
+
+ local myconf="--with-zlib
+ --with-html-subdir=${PF}/html
+ --docdir=/usr/share/doc/${PF}
+ $(use_with debug run-debug)
+ $(use_with python)
+ $(use_with readline)
+ $(use_with readline history)
+ $(use_enable ipv6)"
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ if use python; then
+ python_execute_function -f -q econf ${myconf}
+ else
+ econf ${myconf}
+ fi
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+ building() {
+ emake PYTHON_INCLUDES="$(python_get_includedir)" \
+ PYTHON_SITE_PACKAGES="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_test() {
+ default
+
+ if use python; then
+ testing() {
+ emake test
+ }
+ python_execute_function -s --source-dir python testing
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/examples \
+ install || die "Installation failed"
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" \
+ PYTHON_SITE_PACKAGES="$(python_get_sitedir)" \
+ docsdir=/usr/share/doc/${PF}/python \
+ exampledir=/usr/share/doc/${PF}/python/examples \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+
+ python_clean_sitedirs
+ fi
+
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc AUTHORS ChangeLog Copyright NEWS README* TODO* || die "dodoc failed"
+
+ if ! use python; then
+ rm -rf "${D}"/usr/share/doc/${PF}/python
+ rm -rf "${D}"/usr/share/doc/${PN}-python-${PV}
+ fi
+
+ if ! use doc; then
+ rm -rf "${D}"/usr/share/gtk-doc
+ rm -rf "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ rm -rf "${D}/usr/share/doc/${PF}/python/examples"
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize drv_libxml2.py libxml2.py
+ fi
+
+ # We don't want to do the xmlcatalog during stage1, as xmlcatalog will not
+ # be in / and stage1 builds to ROOT=/tmp/stage1root. This fixes bug #208887.
+ if [ "${ROOT}" != "/" ]
+ then
+ elog "Skipping XML catalog creation for stage building (bug #208887)."
+ else
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}etc/xml" ] || mkdir -p "${ROOT}etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup drv_libxml2.py libxml2.py
+ fi
+}