aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-06-28 12:34:45 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-06-28 12:34:45 +0000
commit9de30a02ebc3c970f94dd2743370866622eae61f (patch)
tree3a0e00b096f454999b4beeb664cd21413e300d17 /media-libs
parentFix is in portage now. Closes ticket #107. (diff)
downloadembedded-cross-9de30a02ebc3c970f94dd2743370866622eae61f.tar.gz
embedded-cross-9de30a02ebc3c970f94dd2743370866622eae61f.tar.bz2
embedded-cross-9de30a02ebc3c970f94dd2743370866622eae61f.zip
Remove -L/usr/lib from the libGL*.la files distributed with the mesa ebuild.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/Manifest4
-rw-r--r--media-libs/mesa/mesa-7.4.4.ebuild273
2 files changed, 277 insertions, 0 deletions
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
new file mode 100644
index 0000000..2c44244
--- /dev/null
+++ b/media-libs/mesa/Manifest
@@ -0,0 +1,4 @@
+AUX lib/libGL.la 738 RMD160 5fc51b20c44911959e0f6df3f3f27b5295d29e05 SHA1 74a17708397c018608a7bda37385aaacdebfe01c SHA256 f2969a4789a43efb101dd38b44d62e185b3acfb307a22d3cfde8cb13934fb0f6
+AUX lib/libGLU.la 741 RMD160 0d942585beba97bf6983b575039a3fa86d43312e SHA1 e89f8f7ece1bbea512dcb8b51edd97d221cf214f SHA256 bf39565f13b721efd813773395d5ff3a9bba2aaca46171b3fd2d08105506abd1
+DIST MesaLib-7.4.4.tar.bz2 3375615 RMD160 9c9a5e8b7f8d2fd175cc8542e2aecf48edf8c084 SHA1 1cdcef24900489bc0a879013b2138c0d9aedffe3 SHA256 eaf73d7a3a2dc959ddc0753abaa18160c64bec00b35bf4a0c96040b2072918ec
+EBUILD mesa-7.4.4.ebuild 7722 RMD160 019abf0239996dfb0e8777f1fa43046b08d63397 SHA1 56c36e3712d73a847234e5db6d7e2b79e8d17646 SHA256 faab5636f062d3572a28ad39eb34923d0f758e2a609614ade827c29335b9793c
diff --git a/media-libs/mesa/mesa-7.4.4.ebuild b/media-libs/mesa/mesa-7.4.4.ebuild
new file mode 100644
index 0000000..ce7e448
--- /dev/null
+++ b/media-libs/mesa/mesa-7.4.4.ebuild
@@ -0,0 +1,273 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.4.4.ebuild,v 1.1 2009/06/24 17:43:44 remi Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git"
+ EXPERIMENTAL="true"
+ IUSE_VIDEO_CARDS_UNSTABLE="video_cards_nouveau"
+ IUSE_UNSTABLE="gallium"
+ # User can also specify branch by simply adding MESA_LIVE_BRANCH="blesmrt"
+ # to the make.conf, where blesmrt is desired branch.
+ [[ -z ${MESA_LIVE_BRANCH} ]] || EGIT_BRANCH="${MESA_LIVE_BRANCH}"
+fi
+
+inherit autotools multilib flag-o-matic ${GIT_ECLASS} portability
+
+OPENGL_DIR="xorg-x11"
+
+MY_PN="${PN/m/M}"
+MY_P="${MY_PN}-${PV/_/-}"
+MY_SRC_P="${MY_PN}Lib-${PV/_/-}"
+DESCRIPTION="OpenGL-like graphic library for Linux"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+#SRC_PATCHES="mirror://gentoo/${P}-gentoo-patches-01.tar.bz2"
+if [[ $PV = *_rc* ]]; then
+ SRC_URI="http://www.mesa3d.org/beta/${MY_SRC_P}.tar.gz
+ ${SRC_PATCHES}"
+elif [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="mirror://sourceforge/mesa3d/${MY_SRC_P}.tar.bz2
+ ${SRC_PATCHES}"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE_VIDEO_CARDS="${IUSE_VIDEO_CARDS_UNSTABLE}
+ video_cards_intel
+ video_cards_mach64
+ video_cards_mga
+ video_cards_none
+ video_cards_r128
+ video_cards_radeon
+ video_cards_radeonhd
+ video_cards_s3virge
+ video_cards_savage
+ video_cards_sis
+ video_cards_sunffb
+ video_cards_tdfx
+ video_cards_trident
+ video_cards_via"
+IUSE="${IUSE_VIDEO_CARDS} ${IUSE_UNSTABLE}
+ debug doc motif nptl pic xcb kernel_FreeBSD"
+
+# keep correct libdrm and dri2proto dep
+# keep blocks in rdepend for binpkg
+RDEPEND="!<=x11-base/xorg-x11-6.9
+ !<=x11-proto/xf86driproto-2.0.3
+ app-admin/eselect-opengl
+ dev-libs/expat
+ >=x11-libs/libdrm-2.4.6
+ x11-libs/libICE
+ x11-libs/libX11[xcb?]
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ motif? ( x11-libs/openmotif )
+ doc? ( app-doc/opengl-manpages )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-misc/makedepend
+ >=x11-proto/dri2proto-1.99.3
+ >=x11-proto/glproto-1.4.8
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xf86driproto
+"
+# glew depend on mesa and it is needed in runtime
+PDEPEND=">=media-libs/glew-1.5.1"
+
+S="${WORKDIR}/${MY_P}"
+
+# Think about: ggi, svga, fbcon, no-X configs
+
+pkg_setup() {
+ if use debug; then
+ append-flags -g
+ fi
+
+ # gcc 4.2 has buggy ivopts
+ if [[ $(gcc-version) = "4.2" ]]; then
+ append-flags -fno-ivopts
+ fi
+
+ # recommended by upstream
+ append-flags -ffast-math
+}
+
+src_unpack() {
+ [[ $PV = 9999* ]] && git_src_unpack || unpack ${A}
+}
+
+src_prepare() {
+ # apply patches
+ if [[ ${PV} != 9999* && -n ${SRC_PATCHES} ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+ # FreeBSD 6.* doesn't have posix_memalign().
+ [[ ${CHOST} == *-freebsd6.* ]] && \
+ sed -i -e "s/-DHAVE_POSIX_MEMALIGN//" configure.ac
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # Configurable DRI drivers
+ driver_enable swrast
+ driver_enable video_cards_intel i810 i915 i965
+ driver_enable video_cards_mach64 mach64
+ driver_enable video_cards_mga mga
+ driver_enable video_cards_r128 r128
+ # ATI has two implementations as video_cards
+ driver_enable video_cards_radeon radeon r200 r300
+ driver_enable video_cards_radeonhd r300
+ driver_enable video_cards_s3virge s3v
+ driver_enable video_cards_savage savage
+ driver_enable video_cards_sis sis
+ driver_enable video_cards_sunffb ffb
+ driver_enable video_cards_tdfx tdfx
+ driver_enable video_cards_trident trident
+ driver_enable video_cards_via unichrome
+
+ # all live (experimental) stuff is wrapped around with experimental variable
+ # so the users cant get to this parts even with enabled useflags (downgrade
+ # from live to stable for example)
+ if [[ -n ${EXPERIMENTAL} ]]; then
+ # nouveau works only with gallium and intel, radeon, radeonhd can use
+ # gallium as alternative implementation (NOTE: THIS IS EXPERIMENTAL)
+ if use video_cards_nouveau && ! use gallium ; then
+ elog "Nouveau driver is available only via gallium interface."
+ elog "Enable gallium useflag if you want to use nouveau."
+ echo
+ fi
+ # state trackers, for now enable the one i want
+ # think about this bit more...
+ myconf="${myconf} $(use_enable gallium)"
+ if use gallium; then
+ elog "Warning gallium interface is highly experimental so use"
+ elog "it only if you feel really really brave."
+ elog
+ elog "Intel: works only i915."
+ elog "Nouveau: only available implementation, so no other choice"
+ elog "Radeon: not working, disabled."
+ echo
+ myconf="${myconf}
+ --with-state-trackers=glx,dri,egl
+ $(use_enable video_cards_nouveau gallium-nouveau)
+ $(use_enable video_cards_intel gallium-intel)"
+ #$(use_enable video_cards_radeon gallium-radeon)
+ #$(use_enable video_cards_radeonhd gallium-radeon)"
+ fi
+ fi
+
+ # Deactivate assembly code for pic build
+ # Sparc assembly code is not working
+ myconf="${myconf} $(use_enable !pic asm)"
+ myconf="${myconf} $(use_enable !sparc asm)"
+
+ # --with-driver=dri|xlib|osmesa ; might get changed later to something
+ # else than dri
+ econf \
+ --with-driver=dri \
+ --disable-glut \
+ --without-demos \
+ $(use_enable debug) \
+ $(use_enable motif glw) \
+ $(use_enable motif) \
+ $(use_enable nptl glx-tls) \
+ $(use_enable xcb) \
+ --with-dri-drivers=${DRI_DRIVERS} \
+ ${myconf}
+}
+
+src_install() {
+ dodir /usr
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ # Remove redundant headers
+ # GLUT thing
+ rm -f "${D}"/usr/include/GL/glut*.h || die "Removing glut include failed."
+ # Glew headers
+ rm -f "${D}"/usr/include/GL/{glew,glxew,wglew}.h \
+ || die "Removing glew includes failed."
+
+ # Move libGL and others from /usr/lib to /usr/lib/opengl/blah/lib
+ # because user can eselect desired GL provider.
+ ebegin "Moving libGL and friends for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/{lib,extensions,include}
+ local x
+ for x in "${D}"/usr/$(get_libdir)/libGL.{la,a,so*}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/lib \
+ || die "Failed to move ${x}"
+ fi
+ done
+ for x in "${D}"/usr/include/GL/{gl.h,glx.h,glext.h,glxext.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include \
+ || die "Failed to move ${x}"
+ fi
+ done
+ eend $?
+
+ # Install libtool archives
+ insinto /usr/$(get_libdir)
+ # Should this use the -L/usr/lib instead of -L/usr/$(get_libdir)?
+ # Please confirm and update this comment or the file.
+ doins "${FILESDIR}"/lib/libGLU.la || die "doins libGLU.la failed"
+ sed \
+ -e "s:\${libdir}:$(get_libdir):g" \
+ "${FILESDIR}"/lib/libGL.la \
+ > "${D}"/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
+
+ # On *BSD libcs dlopen() and similar functions are present directly in
+ # libc.so and does not require linking to libdl. portability eclass takes
+ # care of finding the needed library (if needed) witht the dlopen_lib
+ # function.
+ sed -i \
+ -e 's:-ldl:'$(dlopen_lib)':g' \
+ "${D}"/usr/$(get_libdir)/{libGLU.la,opengl/xorg-x11/lib/libGL.la} \
+ || die "sed dlopen failed"
+}
+
+pkg_postinst() {
+ # Switch to the xorg implementation.
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}
+
+# $1 - VIDEO_CARDS flag
+# other args - names of DRI drivers to enable
+driver_enable() {
+ case $# in
+ # for enabling unconditionally
+ 1)
+ DRI_DRIVERS="${DRI_DRIVERS},$1"
+ ;;
+ *)
+ if use $1; then
+ shift
+ for i in $@; do
+ DRI_DRIVERS="${DRI_DRIVERS},${i}"
+ done
+ fi
+ ;;
+ esac
+}