aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2009-03-18 02:38:55 +0000
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2009-03-18 02:38:55 +0000
commitcc3ef2393202a6a2cbca43f43b0eeb3bc31ad6be (patch)
tree07de529739f25be2af1972cbe499778d5ae83051 /media-libs
parentSynced the wrong direction, sorry! (diff)
downloadembedded-cross-cc3ef2393202a6a2cbca43f43b0eeb3bc31ad6be.tar.gz
embedded-cross-cc3ef2393202a6a2cbca43f43b0eeb3bc31ad6be.tar.bz2
embedded-cross-cc3ef2393202a6a2cbca43f43b0eeb3bc31ad6be.zip
big cleanup commit, if I broke smth for somebody - sorry
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/Manifest3
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.16-r1.ebuild107
-rw-r--r--media-libs/alsa-lib/files/alsa-lib-exec_prefix-fix.patch11
3 files changed, 0 insertions, 121 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
deleted file mode 100644
index 7366c12..0000000
--- a/media-libs/alsa-lib/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX alsa-lib-exec_prefix-fix.patch 364 RMD160 e120c380bbcee9a61de5b2dc15b18a19b93ae203 SHA1 8bcae36901a8c0c4f45b8ba62b14cd8b516b8c50 SHA256 112f05640753463efd8aac5febae9e2c5c11a380e5c3937fb1e242f9b7c9f378
-DIST alsa-lib-1.0.16.tar.bz2 782235 RMD160 828e1d101e0cc2814db2276e08c26ecb9aa0f94d SHA1 9cca050bf3fb18bf87aeeabe205415431d4d8653 SHA256 ae19b33f109e9185c4df709fcab7f6cbbacce82565c5025ba4ebc0e2beca26cd
-EBUILD alsa-lib-1.0.16-r1.ebuild 3136 RMD160 20c5e43a0d0b877cc339da6af04449175de349ff SHA1 da0507da03a40649601ab77a94d66b98c19004f2 SHA256 24eba915a93e36e864be175a1ff19127d83b8d8c82a2217dabde5fe048bea8b3
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.16-r1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.16-r1.ebuild
deleted file mode 100644
index 035c321..0000000
--- a/media-libs/alsa-lib/alsa-lib-1.0.16-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.16-r1.ebuild,v 1.1 2008/05/13 14:40:14 beandog Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="1.9"
-
-inherit eutils autotools libtool
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture Library"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="doc debug alisp midi python"
-
-RDEPEND="python? ( dev-lang/python )"
-DEPEND="${RDEPEND}
- >=media-sound/alsa-headers-${PV}
- doc? ( >=app-doc/doxygen-1.2.6 )"
-
-IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file null empty share meter hooks lfloat ladspa dmix dshare dsnoop asym iec958
-softvol extplug ioplug"
-
-for plugin in ${IUSE_PCM_PLUGIN}; do
- IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
-done
-
-pkg_setup() {
- if [ -z "${ALSA_PCM_PLUGINS}" ] ; then
- ewarn "You haven't selected _any_ PCM plugins. Either you set it to something like the default"
- ewarn "(which is being set in the profile UNLESS you unset them) or alsa based applications"
- ewarn "are going to *misbehave* !"
- epause 5
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
-
- # Fix the exec_prefix later used in the .pc file.
- # We need to call autoconf afterwards, because the patch touches configure.in
- epatch "${FILESDIR}/alsa-lib-exec_prefix-fix.patch"
-
- eautoreconf || die 'autoreconf failed'
-
- #elibtoolize
- epunt_cxx
-}
-
-src_compile() {
- local myconf
- use elibc_uclibc && myconf="--without-versioned"
-
- # needed to avoid gcc looping internaly
- use hppa && export CFLAGS="-O1 -pipe"
-
- econf \
- --enable-static \
- --enable-shared \
- --disable-resmgr \
- $(use_with debug) \
- $(use_enable alisp) \
- $(use_enable python) \
- $(use_enable midi instr) \
- $(use_enable midi seq) $(use_enable midi aload) \
- --with-pcm-plugins="${ALSA_PCM_PLUGINS}" \
- --disable-dependency-tracking \
- ${myconf} \
- || die "configure failed"
-
- emake || die "make failed"
-
- if use doc; then
- emake doc || die "failed to generate docs"
- fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
- xargs -0 sed -i -e "s:${S}::"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc ChangeLog TODO
- use doc && dohtml -r doc/doxygen/html/*
-}
-
-pkg_postinst() {
- ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
- ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
- ewarn "using ALSA output crash."
- ewarn "Note that dmix output is enabled by default on the 'default' device"
- ewarn "since ALSA 1.0.9."
- elog ""
- elog "Please try in-kernel ALSA drivers instead of the alsa-drivers ebuild."
- elog "If alsa-drivers works for you where a recent kernel does not, we want "
- elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
- elog "However, if you notice no sound output or instability, please try to "
- elog "upgrade your kernel to a newer version first."
-}
diff --git a/media-libs/alsa-lib/files/alsa-lib-exec_prefix-fix.patch b/media-libs/alsa-lib/files/alsa-lib-exec_prefix-fix.patch
deleted file mode 100644
index 55eccaa..0000000
--- a/media-libs/alsa-lib/files/alsa-lib-exec_prefix-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in 2008-12-14 14:36:12.000000000 +0100
-+++ configure.in.new 2008-12-14 14:45:18.000000000 +0100
-@@ -79,7 +79,7 @@
- AC_SUBST(ALSA_CONFIG_DIR)
-
- dnl ALSA plugin directory
--test "x$exec_prefix" = xNONE && exec_prefix=$prefix
-+test "x$exec_prefix" = xNONE && exec_prefix='${prefix}'
-
- AC_ARG_WITH(plugindir,
- AS_HELP_STRING([--with-plugindir=dir],