aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog17
-rw-r--r--Makefile65
-rw-r--r--README2
-rw-r--r--etc/Makefile16
-rw-r--r--etc/conf.d/Makefile20
-rw-r--r--etc/init.d/Makefile20
-rw-r--r--etc/vdr/Makefile20
-rw-r--r--etc/vdr/commands/Makefile20
-rw-r--r--etc/vdr/reccmds/Makefile20
-rw-r--r--usr/Makefile20
-rw-r--r--usr/bin/Makefile23
-rw-r--r--usr/sbin/Makefile25
-rw-r--r--usr/share/vdr/Makefile20
-rw-r--r--usr/share/vdr/bin/Makefile20
-rw-r--r--usr/share/vdr/dvdchanger/Makefile14
-rwxr-xr-xusr/share/vdr/dvdchanger/dvdchanger_readdvd.sh32
-rwxr-xr-xusr/share/vdr/dvdchanger/dvdchanger_writedvd.sh37
-rw-r--r--usr/share/vdr/inc/Makefile20
-rw-r--r--usr/share/vdr/rcscript/Makefile20
-rw-r--r--usr/share/vdr/record/Makefile20
-rw-r--r--usr/share/vdr/shutdown/Makefile24
21 files changed, 421 insertions, 54 deletions
diff --git a/ChangeLog b/ChangeLog
index ea42e6b..e491e5e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,23 @@
# ChangeLog for gentoo-vdr-scripts
# $Id$
+*gentoo-vdr-scripts-0.4.1 (04 Oct 2007)
+
+ 04 Oct 2007; Matthias Schwarzott <zzam@gentoo.org> usr/share/vdr/Makefile,
+ +usr/share/vdr/dvdchanger/Makefile,
+ +usr/share/vdr/dvdchanger/dvdchanger_readdvd.sh,
+ +usr/share/vdr/dvdchanger/dvdchanger_writedvd.sh:
+ Added vdr-dvd-scripts.
+
+ 04 Oct 2007; Matthias Schwarzott <zzam@gentoo.org> Makefile,
+ +etc/Makefile, +etc/conf.d/Makefile, +etc/init.d/Makefile,
+ +etc/vdr/Makefile, +etc/vdr/commands/Makefile, +etc/vdr/reccmds/Makefile,
+ +usr/Makefile, usr/bin/Makefile, +usr/sbin/Makefile,
+ +usr/share/vdr/Makefile, +usr/share/vdr/bin/Makefile,
+ +usr/share/vdr/inc/Makefile, +usr/share/vdr/rcscript/Makefile,
+ +usr/share/vdr/record/Makefile, +usr/share/vdr/shutdown/Makefile:
+ Make install now is distributed over makefiles in every directory.
+
03 Oct 2007; Matthias Schwarzott <zzam@gentoo.org>
usr/share/vdr/rcscript/pre-start-30-parameter.sh, etc/conf.d/vdr:
Added parameter to modify VDR niceness.
diff --git a/Makefile b/Makefile
index 241d737..ade5ca5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,16 @@
# $Id$
-SHELL=/bin/bash
+SHELL = /bin/bash
-all:
- make -C usr/bin
+SUBDIRS = etc usr
+
+all: compile
+
+compile:
+ $(MAKE) -C usr/bin compile
+
+clean:
+ $(MAKE) -C usr/bin clean
VERSION := $(shell grep '^Version' README | awk '{ print $$2 }')
TMPDIR = /tmp
@@ -18,52 +25,10 @@ dist:
@echo Distribution package created as $(PACKAGE).tar.bz2
install:
- install -m 0755 -o root -g root -d $(DESTDIR)/etc/conf.d
- install -m 0755 -o root -g root -d $(DESTDIR)/etc/init.d
-
- install -m 0644 -o root -g root etc/conf.d/vdr* $(DESTDIR)/etc/conf.d
- install -m 0755 -o root -g root etc/init.d/vdr $(DESTDIR)/etc/init.d
- install -m 0755 -o root -g root etc/init.d/wakeup-reboot-halt $(DESTDIR)/etc/init.d
-
-
- install -m 0755 -o root -g root -d $(DESTDIR)/usr/sbin
- install -m 0755 -o root -g root usr/sbin/vdr-watchdogd $(DESTDIR)/usr/sbin
- install -m 0755 -o root -g root usr/sbin/acpi-wakeup.sh $(DESTDIR)/usr/sbin
-
- install -m 0755 -o root -g root -d $(DESTDIR)/usr/bin
- install -m 0755 -o root -g root usr/bin/wait_on_pid $(DESTDIR)/usr/bin
-
- #install -m 0755 -o root -g root -d $(DESTDIR)/usr/bin
- #install -m 0755 -o root -g root usr/bin/vdr-start $(DESTDIR)/usr/bin
-
- install -m 0755 -o root -g root -d $(DESTDIR)/usr/share/vdr/rcscript
- install -m 0644 -o root -g root usr/share/vdr/rcscript/*.sh $(DESTDIR)/usr/share/vdr/rcscript/
-
- install -m 0755 -o root -g root -d $(DESTDIR)/usr/share/vdr/shutdown
- install -m 0644 -o root -g root usr/share/vdr/shutdown/{shutdown,pre,periodic}*.sh $(DESTDIR)/usr/share/vdr/shutdown/
- install -m 0644 -o root -g root usr/share/vdr/shutdown/wakeup-{acpi,none}.sh $(DESTDIR)/usr/share/vdr/shutdown/
-
-ifdef NVRAM
- install -m 0644 -o root -g root usr/share/vdr/shutdown/wakeup-nvram.sh $(DESTDIR)/usr/share/vdr/shutdown/
-endif
-
- install -m 0755 -o root -g root -d $(DESTDIR)/usr/share/vdr/inc
- install -m 0644 -o root -g root usr/share/vdr/inc/*.sh $(DESTDIR)/usr/share/vdr/inc/
-
- install -m 0755 -o root -g root -d $(DESTDIR)/usr/share/vdr/record
- install -m 0644 -o root -g root usr/share/vdr/record/*.sh $(DESTDIR)/usr/share/vdr/record/
-
- install -m 0755 -o root -g root -d $(DESTDIR)/usr/share/vdr/bin
- install -m 0755 -o root -g root usr/share/vdr/bin/*.sh $(DESTDIR)/usr/share/vdr/bin/
-
- install -m 0755 -o vdr -g vdr -d $(DESTDIR)/var/vdr/{shutdown-data,merged-config-files}
-
- install -m 0755 -o vdr -g vdr -d $(DESTDIR)/etc/vdr
- install -m 0755 -o vdr -g vdr -d $(DESTDIR)/etc/vdr/commands
- install -m 0644 -o vdr -g vdr etc/vdr/commands/commands.*.conf* $(DESTDIR)/etc/vdr/commands
- install -m 0755 -o vdr -g vdr -d $(DESTDIR)/etc/vdr/reccmds
- install -m 0644 -o vdr -g vdr etc/vdr/reccmds/reccmds.*.conf $(DESTDIR)/etc/vdr/reccmds
-
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+ @install -m 0755 -o vdr -g vdr -d $(DESTDIR)/var/vdr/{shutdown-data,merged-config-files}
snapshot:
svn export . gentoo-vdr-scripts-snapshot
@@ -72,4 +37,4 @@ snapshot:
rm gentoo-vdr-scripts-snapshot.tgz
rm -rf gentoo-vdr-scripts-snapshot
-.PHONY: all install snapshot
+.PHONY: all compile install snapshot
diff --git a/README b/README
index ccd8038..5d2412c 100644
--- a/README
+++ b/README
@@ -1,7 +1,7 @@
README for gentoo-vdr-scripts
$Id$
-Version 0.4.0
+Version 0.4.1
This package contains all support scripts for vdr to make
it like a real set top box.
diff --git a/etc/Makefile b/etc/Makefile
new file mode 100644
index 0000000..ddb212f
--- /dev/null
+++ b/etc/Makefile
@@ -0,0 +1,16 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/etc
+SUBDIRS = conf.d init.d vdr
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/etc/conf.d/Makefile b/etc/conf.d/Makefile
new file mode 100644
index 0000000..c57751c
--- /dev/null
+++ b/etc/conf.d/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/etc/conf.d
+SUBDIRS =
+BINS =
+CONFS = $(wildcard vdr*)
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ #install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ @install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/etc/init.d/Makefile b/etc/init.d/Makefile
new file mode 100644
index 0000000..01666f4
--- /dev/null
+++ b/etc/init.d/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/etc/init.d
+SUBDIRS =
+BINS = vdr wakeup-reboot-halt
+CONFS =
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ #install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/etc/vdr/Makefile b/etc/vdr/Makefile
new file mode 100644
index 0000000..7a93b2c
--- /dev/null
+++ b/etc/vdr/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/etc/vdr
+SUBDIRS = commands reccmds
+BINS =
+CONFS =
+
+all:
+
+install:
+ @install -m 0755 -o vdr -g vdr -d $(MYDIR)
+ #install -m 0755 -o vdr -g vdr $(BINS) $(MYDIR)
+ #install -m 0644 -o vdr -g vdr $(CONFS) $(MYDIR)
+ for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/etc/vdr/commands/Makefile b/etc/vdr/commands/Makefile
new file mode 100644
index 0000000..21055c3
--- /dev/null
+++ b/etc/vdr/commands/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/etc/vdr/commands
+SUBDIRS =
+BINS =
+CONFS = $(wildcard commands.*.conf*)
+
+all:
+
+install:
+ @install -m 0755 -o vdr -g vdr -d $(MYDIR)
+ #install -m 0755 -o vdr -g vdr $(BINS) $(MYDIR)
+ @install -m 0644 -o vdr -g vdr $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/etc/vdr/reccmds/Makefile b/etc/vdr/reccmds/Makefile
new file mode 100644
index 0000000..91295fe
--- /dev/null
+++ b/etc/vdr/reccmds/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/etc/vdr/reccmds
+SUBDIRS =
+BINS =
+CONFS = $(wildcard reccmds.*.conf*)
+
+all:
+
+install:
+ @install -m 0755 -o vdr -g vdr -d $(MYDIR)
+ #install -m 0755 -o vdr -g vdr $(BINS) $(MYDIR)
+ @install -m 0644 -o vdr -g vdr $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/Makefile b/usr/Makefile
new file mode 100644
index 0000000..6c39193
--- /dev/null
+++ b/usr/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr
+SUBDIRS = bin sbin share/vdr
+BINS =
+CONFS =
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ #install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ #install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/bin/Makefile b/usr/bin/Makefile
index f9be7db..857371e 100644
--- a/usr/bin/Makefile
+++ b/usr/bin/Makefile
@@ -1,8 +1,25 @@
-BINS=wait_on_pid
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
-all: $(BINS)
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/bin
+SUBDIRS =
+BINS = wait_on_pid
+CONFS =
+
+all: compile
+
+compile: $(BINS)
clean:
rm $(BINS)
-
+install: $(BINS)
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ #install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/sbin/Makefile b/usr/sbin/Makefile
new file mode 100644
index 0000000..5330dfb
--- /dev/null
+++ b/usr/sbin/Makefile
@@ -0,0 +1,25 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/sbin
+SUBDIRS =
+BINS = acpi-wakeup.sh vdr-watchdogd
+CONFS =
+
+all: compile
+
+compile: $(BINS)
+
+clean:
+ rm $(BINS)
+
+install: $(BINS)
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ #install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/share/vdr/Makefile b/usr/share/vdr/Makefile
new file mode 100644
index 0000000..4b0b7a9
--- /dev/null
+++ b/usr/share/vdr/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/share/vdr
+SUBDIRS = bin inc rcscript record shutdown dvdchanger
+BINS =
+CONFS =
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ #install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ #install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/share/vdr/bin/Makefile b/usr/share/vdr/bin/Makefile
new file mode 100644
index 0000000..012b76f
--- /dev/null
+++ b/usr/share/vdr/bin/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/share/vdr/bin
+SUBDIRS =
+BINS = $(wildcard *.sh)
+CONFS =
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ #install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/share/vdr/dvdchanger/Makefile b/usr/share/vdr/dvdchanger/Makefile
new file mode 100644
index 0000000..30ac4a3
--- /dev/null
+++ b/usr/share/vdr/dvdchanger/Makefile
@@ -0,0 +1,14 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/share/vdr/dvdchanger
+BINS = dvdchanger_readdvd.sh dvdchanger_writedvd.sh
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0755 -o root -g root $(BINS) $(MYDIR)
+
+.PHONY: all install
diff --git a/usr/share/vdr/dvdchanger/dvdchanger_readdvd.sh b/usr/share/vdr/dvdchanger/dvdchanger_readdvd.sh
new file mode 100755
index 0000000..5ab0d86
--- /dev/null
+++ b/usr/share/vdr/dvdchanger/dvdchanger_readdvd.sh
@@ -0,0 +1,32 @@
+#!/bin/bash
+#
+# dvdselect_readdvd.sh
+#
+# source: dvdselect-plugin
+#
+# an LinVDR angepasst, da LinVDR kein at-Kommando hat
+# modified for LinVDR, because there is no at-command
+#
+# This script will by called by the vdr-plugin dvdselect to copy a DVD to
+# the local drive.
+#
+# It gets the following parameters:
+#
+# $1 = directory for dvd's (see plugin configuration menu)
+# $2 = name of dvd
+# $3 = original dvd-device
+
+if [[ -z ${EXECUTED_BY_VDR_BG} ]]; then
+ VDR_BG=/usr/share/vdr/bin/vdr-bg.sh
+ [[ -e ${VDR_BG} ]] || VDR_BG=/usr/lib/vdr/bin/vdr-bg.sh
+
+ exec "${VDR_BG}" "${0}" "${@}"
+ exit
+fi
+
+rm -f "$1/$2"
+
+svdrpsend.pl -d localhost "MESG DVD einlesen gestartet"
+dd if="$3" of="$1/$2"
+svdrpsend.pl -d localhost "MESG DVD $2 fertig"
+
diff --git a/usr/share/vdr/dvdchanger/dvdchanger_writedvd.sh b/usr/share/vdr/dvdchanger/dvdchanger_writedvd.sh
new file mode 100755
index 0000000..86571c2
--- /dev/null
+++ b/usr/share/vdr/dvdchanger/dvdchanger_writedvd.sh
@@ -0,0 +1,37 @@
+#!/bin/bash
+#
+# $Header: /var/cvsroot/gentoo-x86/media-tv/vdr-dvd-scripts/files/0.0.3/dvdchanger_writedvd.sh,v 1.1 2007/07/21 22:40:13 hd_brummy Exp $
+#
+# 04 Mar 2006; Joerg Bornkessel <hd_brummy@gentoo.org>
+# addaptded to gentoo-vdr-scripts
+
+if [[ -z ${EXECUTED_BY_VDR_BG} ]]; then
+ VDR_BG=/usr/share/vdr/bin/vdr-bg.sh
+ [[ -e ${VDR_BG} ]] || VDR_BG=/usr/lib/vdr/bin/vdr-bg.sh
+
+ exec "${VDR_BG}" "${0}" "${@}"
+ exit
+fi
+
+[[ -e /etc/conf.d/vdr.cd-dvd ]] && source /etc/conf.d/vdr.cd-dvd
+
+ISO_FILE="${1// IMAGE/}"
+
+#logger -t burnscript burn ${ISO_FILE} --
+
+: ${VDR_DVDWRITER:=/dev/dvd}
+
+[[ -e /etc/conf.d/vdr.dvdswitch ]] && source /etc/conf.d/vdr.dvdswitch
+
+
+DVD_RECORDCMD="growisofs"
+DVDPLUS_RECORD_OPTS="-use-the-force-luke=tty -dvd-compat"
+if [[ -n ${VDR_DVDBURNSPEED} ]]; then
+ DVDPLUS_RECORD_OPTS="${DVDPLUS_RECORD_OPTS} -speed=${VDR_DVDBURNSPEED}"
+fi
+
+unset SUDO_COMMAND
+
+svdrpsend.pl -d localhost "MESG DVD burn initiated"
+"$DVD_RECORDCMD" $DVDPLUS_RECORD_OPTS -Z "$VDR_DVDWRITER"="${ISO_FILE}"
+svdrpsend.pl -d localhost "MESG DVD burn completed"
diff --git a/usr/share/vdr/inc/Makefile b/usr/share/vdr/inc/Makefile
new file mode 100644
index 0000000..9b38645
--- /dev/null
+++ b/usr/share/vdr/inc/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/share/vdr/inc
+SUBDIRS =
+BINS =
+CONFS = $(wildcard *.sh)
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ #install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ @install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/share/vdr/rcscript/Makefile b/usr/share/vdr/rcscript/Makefile
new file mode 100644
index 0000000..dcc2319
--- /dev/null
+++ b/usr/share/vdr/rcscript/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/share/vdr/rcscript
+SUBDIRS =
+BINS =
+CONFS = $(wildcard *.sh)
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ #install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ @install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/share/vdr/record/Makefile b/usr/share/vdr/record/Makefile
new file mode 100644
index 0000000..b8c80e8
--- /dev/null
+++ b/usr/share/vdr/record/Makefile
@@ -0,0 +1,20 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/share/vdr/record
+SUBDIRS =
+BINS =
+CONFS = $(wildcard *.sh)
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ #install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ @install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install
diff --git a/usr/share/vdr/shutdown/Makefile b/usr/share/vdr/shutdown/Makefile
new file mode 100644
index 0000000..9532c62
--- /dev/null
+++ b/usr/share/vdr/shutdown/Makefile
@@ -0,0 +1,24 @@
+# $Id: Makefile 454 2007-05-30 09:56:54Z zzam $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/share/vdr/shutdown
+SUBDIRS =
+BINS =
+WAKEUP = wakeup-acpi.sh wakeup-none.sh
+ifdef NVRAM
+ WAKEUP += wakeup-nvram.sh
+endif
+CONFS = $(wildcard shutdown*.sh pre*.sh periodic*.sh) $(WAKEUP)
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ #install -m 0755 -o root -g root $(BINS) $(MYDIR)
+ @install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+ @for DIR in $(SUBDIRS); do \
+ $(MAKE) -C $$DIR install; \
+ done
+
+.PHONY: all install