aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/man/meson.build b/man/meson.build
new file mode 100644
index 0000000..aa888f7
--- /dev/null
+++ b/man/meson.build
@@ -0,0 +1,23 @@
+man_pages_out = []
+man_pages_in = [
+ 'ebump.1',
+ 'eclean.1',
+ 'enalyze.1',
+ 'epkginfo.1',
+ 'equery.1',
+ 'eread.1',
+ 'eshowkw.1',
+ 'euse.1',
+ 'imlate.1',
+ 'revdep-rebuild.1',
+]
+
+foreach man_page : man_pages_in
+ man_pages_out += configure_file(
+ input : man_page,
+ output : man_page,
+ configuration : conf_data
+ )
+endforeach
+
+install_man(man_pages_out)