summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-03-13 19:06:45 +0100
committerRémi Cardona <remi@gentoo.org>2008-03-13 19:06:45 +0100
commit4399a7047e17cca1f714a762f664382764837336 (patch)
tree79985eb120c5bbd63f97b71e834b03b905715768 /app-cdr
parent * import and bump cheese to 2.22 (diff)
downloadgnome-4399a7047e17cca1f714a762f664382764837336.tar.gz
gnome-4399a7047e17cca1f714a762f664382764837336.tar.bz2
gnome-4399a7047e17cca1f714a762f664382764837336.zip
app-cdr/cdrdao: fix build failure with libsigc++ 2.2
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdrdao/Manifest4
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild69
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.2-nonlinux.patch12
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.2-use-new-sigc++-API.patch12
4 files changed, 97 insertions, 0 deletions
diff --git a/app-cdr/cdrdao/Manifest b/app-cdr/cdrdao/Manifest
new file mode 100644
index 00000000..8bb1062e
--- /dev/null
+++ b/app-cdr/cdrdao/Manifest
@@ -0,0 +1,4 @@
+AUX cdrdao-1.2.2-nonlinux.patch 380 RMD160 d58247e7faeb12b3bf416845f41aa9a77aa6d1ef SHA1 955a6e56e3264e773241d89ac0fd603ba5bcff31 SHA256 e15d0d3302272e958d8d5df705cd4146653aff2a55b5b582f04e70814cab7cd3
+AUX cdrdao-1.2.2-use-new-sigc++-API.patch 481 RMD160 48f39ef4b6f9db81a00b6fbbe6b44c0f0cd49a5b SHA1 092bd7a492026d5dd47e9c2ff9e2b2acf3f8a3bc SHA256 3d0159dfa815c92f82d16407977fe875f005224d28ccc00238a73df2474bba63
+DIST cdrdao-1.2.2.tar.bz2 1408344 RMD160 c537c535a4106655f89f7cfa5895ffcb5b9464e2 SHA1 2699e56e00342c1fa2a3815ed02418fe964b276b SHA256 de180041e57f8e1c88c9b6f9b6c51b0abf0dc2744c4fa37a0248d48f40e58038
+EBUILD cdrdao-1.2.2-r1.ebuild 1855 RMD160 d7727ad6f32b4c938bf780e0120c4ff2e0a59f3c SHA1 e218760f5cb11e96a2e29997392c741876a5c1be SHA256 f4f61e36cf9f0e8869a07fd07bb91233dc00c5227ac146fbdc136c8d3c87be11
diff --git a/app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild b/app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild
new file mode 100644
index 00000000..ba51cda6
--- /dev/null
+++ b/app-cdr/cdrdao/cdrdao-1.2.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrdao/cdrdao-1.2.2.ebuild,v 1.9 2007/11/14 19:27:22 drac Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
+HOMEPAGE="http://cdrdao.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cdrdao/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnome debug encode pccts"
+RESTRICT="strip"
+
+RDEPEND="encode? ( >=media-sound/lame-3.90 )
+ gnome? ( >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libgnomemm-2.6
+ >=dev-cpp/libgnomecanvasmm-2.6
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libgnomeuimm-2.6
+ media-libs/libao )"
+DEPEND="pccts? ( >=dev-util/pccts-1.33.24-r1 )
+ virtual/cdrtools
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fixes bug #212530
+ epatch "${FILESDIR}/${PN}-1.2.2-use-new-sigc++-API.patch"
+
+ # FreeBSD needs this patch
+ # I think the correct define should be linux, but this will maintain
+ # the status quo for the time being.
+ # Upstream bug #1596097
+ epatch "${FILESDIR}/${P}"-nonlinux.patch
+
+ # Display better SCSI messages (advise from Bug 43003)
+ cd scsilib/include
+ sed -i -e 's:HAVE_SCANSTACK:NO_FRIGGING_SCANSTACK:g' xmconfig.h
+ sed -i -e 's:HAVE_SCANSTACK:NO_FRIGGING_SCANSTACK:g' mconfig.h
+}
+
+src_compile() {
+ # A few CFLAGS do not work see bug #99998
+ strip-flags
+ append-flags "-fno-inline"
+
+ econf \
+ $(use_enable debug) \
+ $(use_with gnome xdao) \
+ $(use_with encode lame) \
+ $(use_with pccts pcctsbin /usr/bin) \
+ $(use_with pccts pcctsinc /usr/include/pccts) \
+ --disable-dependency-tracking || die "configure failed"
+
+ make || die "could not compile"
+}
+
+src_install() {
+ einstall || die "could not install"
+
+ cd "${S}"
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README*
+}
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.2-nonlinux.patch b/app-cdr/cdrdao/files/cdrdao-1.2.2-nonlinux.patch
new file mode 100644
index 00000000..a5800d37
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.2-nonlinux.patch
@@ -0,0 +1,12 @@
+diff -ur a/dao/ScsiIf-lib.cc b/dao/ScsiIf-lib.cc
+--- a/dao/ScsiIf-lib.cc 2007-08-22 12:21:11 +0100
++++ b/dao/ScsiIf-lib.cc 2007-08-22 12:25:04 +0100
+@@ -430,7 +430,7 @@
+ #include "ScsiIf-common.cc"
+ //<<<<<<< ScsiIf-lib.cc
+
+-#ifndef linux
++#ifdef wedontwantthis
+
+ /* Function for mapping any SCSI device to the corresponding SG device.
+ * Taken from D. Gilbert's example code.
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.2-use-new-sigc++-API.patch b/app-cdr/cdrdao/files/cdrdao-1.2.2-use-new-sigc++-API.patch
new file mode 100644
index 00000000..12731c07
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.2-use-new-sigc++-API.patch
@@ -0,0 +1,12 @@
+http://cdrdao.cvs.sourceforge.net/cdrdao/cdrdao/xdao/xcdrdao.cc?r1=1.30&r2=1.31&view=patch
+--- xdao/xcdrdao.cc 2007/08/15 14:24:49 1.30
++++ xdao/xcdrdao.cc 2007/09/11 08:58:42 1.31
+@@ -144,7 +144,7 @@
+ installSignalHandler(SIGCHLD, signalHandler);
+
+ // setup periodic GUI updates
+- Glib::signal_timeout().connect(SigC::slot(&guiUpdatePeriodic), 2000);
++ Glib::signal_timeout().connect(sigc::ptr_fun(&guiUpdatePeriodic), 2000);
+
+ installSignalHandler(SIGPIPE, SIG_IGN);
+