summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2014-11-30 17:57:52 +0100
committerRémi Cardona <remi@gentoo.org>2014-11-30 18:03:21 +0100
commitf6aa75a8258c9764f902ac9c623fce5ce5fe3fb0 (patch)
tree86dad7e5795f3020af30c787715e696e18497a99 /app-text
parentx11-libs/gtk+: Fix build with dash as /bin/sh (diff)
downloadgnome-f6aa75a8258c9764f902ac9c623fce5ce5fe3fb0.tar.gz
gnome-f6aa75a8258c9764f902ac9c623fce5ce5fe3fb0.tar.bz2
gnome-f6aa75a8258c9764f902ac9c623fce5ce5fe3fb0.zip
app-text/evince: Fix build with non-bash /bin/sh
Patch comes from upstream git, so -9999 doesn't need it.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/evince/evince-3.14.1.ebuild7
-rw-r--r--app-text/evince/files/evince-non-bash-support.patch28
2 files changed, 34 insertions, 1 deletions
diff --git a/app-text/evince/evince-3.14.1.ebuild b/app-text/evince/evince-3.14.1.ebuild
index 01283b1d..0ed7b716 100644
--- a/app-text/evince/evince-3.14.1.ebuild
+++ b/app-text/evince/evince-3.14.1.ebuild
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
-inherit eutils gnome2
+inherit eutils autotools gnome2
DESCRIPTION="Simple document viewer for GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
@@ -67,6 +67,11 @@ DEPEND="${COMMON_DEPEND}
RESTRICT="test"
src_prepare() {
+ # Fix build with non-bash /bin/sh, see bug #526410
+ epatch "${FILESDIR}/${PN}-non-bash-support.patch"
+
+ eautoreconf
+
gnome2_src_prepare
# Do not depend on adwaita-icon-theme, bug #326855, #391859
diff --git a/app-text/evince/files/evince-non-bash-support.patch b/app-text/evince/files/evince-non-bash-support.patch
new file mode 100644
index 00000000..979d1860
--- /dev/null
+++ b/app-text/evince/files/evince-non-bash-support.patch
@@ -0,0 +1,28 @@
+From 59daf398bc0f1d7895eee3a776b33a9c9310ad21 Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Sun, 26 Oct 2014 23:54:47 +0300
+Subject: configure.ac: workaround quoting issues
+
+BROWSER_PLUGIN_DIR variable substitution is not portable. In particular
+it does not work in dash. Replace it with conditional.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=739226
+
+diff --git a/configure.ac b/configure.ac
+index 56bf93c..dd4bcab 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -455,7 +455,9 @@ AC_ARG_ENABLE([browser-plugin],
+ if test x$enable_browser_plugin = "xyes" ; then
+ PKG_CHECK_MODULES([BROWSER_PLUGIN],[gtk+-3.0 >= $GTK_REQUIRED gthread-2.0 gio-2.0 >= $GLIB_REQUIRED])
+
+- BROWSER_PLUGIN_DIR="${BROWSER_PLUGIN_DIR:-"\${libdir}/mozilla/plugins"}"
++ if test -z "${BROWSER_PLUGIN_DIR}"; then
++ BROWSER_PLUGIN_DIR="\${libdir}/mozilla/plugins"
++ fi
+ AC_ARG_VAR([BROWSER_PLUGIN_DIR],[Where to install the plugin to])
+ fi
+
+--
+cgit v0.10.1
+