aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
new file mode 100644
index 0000000..c3a4dd9
--- /dev/null
+++ b/src/meson.build
@@ -0,0 +1,36 @@
+subdir('java_config_2')
+
+py_bins = [
+ 'depend-java-query',
+ 'gjl',
+ 'java-config-2',
+]
+
+# It might seem sensible to use py.install_sources() to install the Python
+# scripts, but it's really just a wrapper around install_data that forces the
+# install_dir. Meson 1.2.0 and later also optimize to bytecode, but Gentoo does
+# this in the ebuild.
+install_data(
+ py_bins,
+ install_dir: get_option('bindir'),
+ install_mode: 'rwxr-xr-x',
+)
+
+if python_only
+ subdir_done()
+endif
+
+launcherdir_rel = 'share' / 'java-config-2' / 'launcher'
+launcherdir = system_wide ? eprefix / launcherdir_rel \
+ : datadir / eprefix / launcherdir_rel
+
+launcher_bash = configure_file(
+ input: 'launcher.bash',
+ output: 'launcher.bash',
+ configuration: conf_data,
+)
+
+install_data(
+ [launcher_bash],
+ install_dir: launcherdir,
+)